Results 1 to 6 of 6

Thread: KDE nor NVIDIA-Settings listing the desired resolution

  1. #1
    Join Date
    Jul 2008
    Location
    United Kingdom
    Posts
    1,146

    Default KDE nor NVIDIA-Settings listing the desired resolution

    Hello,

    Using the ' official' proprietary NVIDIA driver for my NVIDIA 9100M G I cannot select the native resolution (1920x1200) for my Samsung 2443bw using openSUSE 13.1. In fact the highest it will go is 1024x768.

    Using the 'Advanced' button in nvidia-settings I tried manually adjusting the resolution to 1920x1200 using the input fields it provides but the end result looks very not-native. If I use DVI I can select the resolution just fine and it looks fine but I need the DVI connection for my other PC. Is there another way to force a resolution?

    All I found are references to sax2 which is no longer in openSUSE and to editing /etc/X11/xorg which seems to be missing.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: KDE nor NVIDIA-Settings listing the desired resolution

    Quote Originally Posted by Axeia View Post
    Hello,

    Using the ' official' proprietary NVIDIA driver for my NVIDIA 9100M G I cannot select the native resolution (1920x1200) for my Samsung 2443bw using openSUSE 13.1. In fact the highest it will go is 1024x768.

    Using the 'Advanced' button in nvidia-settings I tried manually adjusting the resolution to 1920x1200 using the input fields it provides but the end result looks very not-native. If I use DVI I can select the resolution just fine and it looks fine but I need the DVI connection for my other PC. Is there another way to force a resolution?
    So, is this monitor connected via analogue VGA output? Sometimes EDID can be the issue, and so the nvidia driver defaults to a lower resolution. Have a look at /var/log/Xorg.0.log, as this will almost certainly provide an explanation (especially as you mention that the correct display resolution is obtained using DVI cable).

    You may want to share the log here, and the best way to do that is to use http://paste.opensuse.org/

    Post the link that it generrates here.

    All I found are references to sax2 which is no longer in openSUSE and to editing /etc/X11/xorg which seems to be missing.
    The sax2 utility was deprecated years ago, and kernel-mode-setting drivers have largely obfuscated the need for it anyway. Edits to the newer Xorg configuration files (located within the /etc/X11/xorg.conf.d/ directory) can still be made if necessary, or /etc/X11/xorg.conf can still be used if preferred.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: KDE nor NVIDIA-Settings listing the desired resolution

    Two possible approaches to obtaining the desired display resolution

    1. This old thread may be helpful to you with using a compatible modeline for your monitor and creating a minmal working xorg.conf file.

    2. Since you report that the native display resolution is obtained when DVI connectivity is used, then you could also use nvidia-settings "Adquire EDID" function and save the file. It is then possible to load the EDID from file as outlined here

    http://wiki.xbmc.org/index.php?title...read_from_EDID

  4. #4
    Join Date
    Jul 2008
    Location
    United Kingdom
    Posts
    1,146

    Default Re: KDE nor NVIDIA-Settings listing the desired resolution

    EDID seems to be the culprit. I'll see what I can do after reading your last link and report back. Thank you
    Quote Originally Posted by Xorg.0.log
    [140371.226] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
    Xorg.0.log

  5. #5
    Join Date
    Jul 2008
    Location
    United Kingdom
    Posts
    1,146

    Default Re: KDE nor NVIDIA-Settings listing the desired resolution

    Thanks again, got it working
    Backed up the EDID through the NVIDIA-settings UI and then added the code below to
    /etc/X11/xorg.conf.d/50-device.conf :
    Code:
    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option         "NoLogo" "true"
    Option         "ConnectedMonitor" "CRT-0"
    Option         "CustomEDID" "CRT-0:/home/Server/.config/monitor/edid.bin"
    Option         "IgnoreEDID" "false"
    Option         "UseEDID" "true"
    EndSection

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: KDE nor NVIDIA-Settings listing the desired resolution

    Quote Originally Posted by Axeia View Post
    Thanks again, got it working
    Backed up the EDID through the NVIDIA-settings UI and then added the code below to
    /etc/X11/xorg.conf.d/50-device.conf :
    Code:
    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option         "NoLogo" "true"
    Option         "ConnectedMonitor" "CRT-0"
    Option         "CustomEDID" "CRT-0:/home/Server/.config/monitor/edid.bin"
    Option         "IgnoreEDID" "false"
    Option         "UseEDID" "true"
    EndSection
    Thanks for the update. I'm glad that did the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •