Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Seit heute plötzlich keine Internetverbindung mehr

  1. #1

    Default Seit heute plötzlich keine Internetverbindung mehr

    Liebe Leute,

    seit heute Mittag funktioniert das Internet auf meinem Hauptrechner plötzlich nicht mehr (openSUSE 13.1). War in den letzten Tagen von den Repositories KDE:411 und KDE:412 auf :Current umgestiegen. Und gestern gab es ja auch irgendwelche Updates - die hab ich noch gezogen. Auf meinem Zweitrechner läuft noch alles ganz normal, mit Internetverbindung.

    Ich gehe über's WLAN ins Netz und benutze den "NetworkManager" um online zu gehen. Auf meinem Hauptrechner verbindet er sich auch mit meinem WLAN-Netzwerk und zeigt keinerlei Fehlermeldung an. Es gibt aber nur einige kb Up- und Downstream (50-100Kib). Firefox kann allerdings nicht auf's Netz zugreifen und auch KOrganizer ist offline.

    Ich habe wirklich keinen Plan, da ich meines Wissens nichts geändert habe, außer evtl. Updates zu installieren. Hat jemand vielleicht einen Rat, wie man die Ursache des Problems ausfindig machen könnte?

    Besten Gruß

    Edit: Habe jetzt mal versuchsweise das Netzwerkkabel reingesteckt. Er sagt, die Verbindung steht. Allerdings können meine Programme nicht auf's Netz zugreifen.

  2. #2

    Default AW: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by Susesuser View Post
    seit heute Mittag funktioniert das Internet auf meinem Hauptrechner plötzlich nicht mehr (openSUSE 13.1). War in den letzten Tagen von den Repositories KDE:411 und KDE:412 auf :Current umgestiegen. Und gestern gab es ja auch irgendwelche Updates - die hab ich noch gezogen. Auf meinem Zweitrechner läuft noch alles ganz normal, mit Internetverbindung.
    Also die letzten Updates können eigtl. kein Problem mit der Internetverbindung verursachen, soweit ich das sehen kann.
    Allerdings gibts in KDE:Current (so wie auch schon in KDE:Release:xy) NetworkManager-Pakete, wenn du da einen Mix hast, kanns sein, dass der NetworkManager nicht mehr richtig funktioniert.

    Du könntest mal als Test probieren, in YaST->Netzwerkgeräte->Netzwerkeinstellungen->Globale Optionen auf "Traditionelle Methode mit ifup" umschalten, und das WLAN dann durch Klick auf "Bearbeiten" (unter "Übersicht") konfigurieren.
    Gehts dann? Wenn ja, dann würds am NetworkManager liegen. In dem Fall solltest du als erstes mal schauen, dass wirklich alle Pakete von KDE:Current stammen.

    Ansonsten wäre als erstes wohl mal interessant, ob du Rechner im Internet überhaupt erreichen kannst.
    Probier mal:
    Code:
    ping 8.8.8.8
    sowie:
    Code:
    ping google.com
    Wenn das erste geht und das zweite nicht, funktioniert "nur" die Namensauflösung nicht.

  3. #3

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Danke für die schnelle Antwort!

    Also
    Code:
    ping 8.8.8.8
    funktioniert (alle paar ms gibt es eine Rückmeldung),
    Code:
    ping google.com
    nicht.

    Wenn ich auf dem Hauptrechner von ifup wieder zurück auf "Benutzergesteuert mithilfe von NetworkManager" gehe, kommt eine Meldung "Applet benötigt" - NetworkManager wird über Desktop-Applet gesteuert. (KDE-Plasma-Miniprogramm für KDE...). Stellen Sie sicher, dass es aktiv und falls nicht - manuell starten.

    Liegt es vllt. daran? Wie heißt das Programm und wo könnte ich es starten?

    Besten Gruß und Dank

  4. #4

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by Susesuser View Post
    Also
    Code:
    ping 8.8.8.8
    funktioniert (alle paar ms gibt es eine Rückmeldung),
    Code:
    ping google.com
    nicht.
    War das jetzt mit ifup oder mit NetworkManager?

    Wenn du in die Datei /etc/resolv.conf als letzte Zeile "nameserver 8.8.8.8" einfügst, gehts dann auch mit "google.com" z.B.?
    Und kannst du bitte mal die Datei posten, bevor du die Änderung machst?

    Wenn ich auf dem Hauptrechner von ifup wieder zurück auf "Benutzergesteuert mithilfe von NetworkManager" gehe, kommt eine Meldung "Applet benötigt" - NetworkManager wird über Desktop-Applet gesteuert. (KDE-Plasma-Miniprogramm für KDE...). Stellen Sie sicher, dass es aktiv und falls nicht - manuell starten.

    Liegt es vllt. daran? Wie heißt das Programm und wo könnte ich es starten?
    Die Meldung kommt _immer_, hat also nicht unbedingt was zu bedeuten.
    Das NetworkManager Applet müsste normalerweise standardmäßig aktiviert sein (im "Systemabschnitt der Kontrollleiste" rechts unten), vor allem wenn du vorher den NetworkManager benutzt hast. Das ist das Symbol, dass die Netzwerkverbindungen anzeigt.

  5. #5

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by wolfi323 View Post
    War das jetzt mit ifup oder mit NetworkManager?
    Das war mit dem NetworkManager.

    Wenn du in die Datei /etc/resolv.conf als letzte Zeile "nameserver 8.8.8.8" einfügst, gehts dann auch mit "google.com" z.B.?
    Und kannst du bitte mal die Datei posten, bevor du die Änderung machst?
    Das würde ich gerne tun, leider steht mir meine bescheidene Konsolenkenntnis im Weg. Mit dem Befehl "cat" komme ich leider nicht weiter, da die Ausgabe kryptisch ist. Und wenn ich mir die Datei über Kompare oder KWrite ausgeben lassen will, zickt er auch rum. Könntest du mir bitte noch einen entsprechenden Codeschnipsel vorschlagen, mit dem ich weiterkomme?

    Vielen Dank

  6. #6

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by Susesuser View Post
    Das war mit dem NetworkManager.
    OK, dann sollte eigentlich mit der NetworkManager Installation alles in Ordnung sein.

    Das würde ich gerne tun, leider steht mir meine bescheidene Konsolenkenntnis im Weg. Mit dem Befehl "cat" komme ich leider nicht weiter, da die Ausgabe kryptisch ist. Und wenn ich mir die Datei über Kompare oder KWrite ausgeben lassen will, zickt er auch rum. Könntest du mir bitte noch einen entsprechenden Codeschnipsel vorschlagen, mit dem ich weiterkomme?
    Die Ausgabe ist kryptisch? Wie meinst du das?
    Das sollte eine normale Textdatei sein.
    Ändern solltest du sie damit können:
    Code:
    kdesu kwrite /etc/resolv.conf
    Und was meinst du mit "zickt rum"? Bekommst du eine Fehlermeldung? Oder unlesbare Zeichen?

    Allerdings sollte die sowieso richtig beim Aufbau der Netzwerkverbindung angelegt werden.
    Versuch bitte mal die Verbindung im NetworkManager zu bearbeiten, schau bitte, ob unter "IPv4-Adresse" die Methode auf "Automatisch (DHCP)" gestellt ist.
    Last edited by wolfi323; 05-Apr-2014 at 11:42.

  7. #7

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by wolfi323 View Post
    Die Ausgabe ist kryptisch? Wie meinst du das?
    Das sollte eine normale Textdatei sein.
    Wenn ich mir die Datei mit
    Code:
    cat resolv.conf
    auf meinem funktionierenden Rechner mit Internetverbindung anzeigen lassen, wird auch eine ganz normale Textdatei angezeigt. Bei meinem Rechner ohne Verbindung kommt eine einzeilige Folge von komischen ASCII-Zeichen (Weiße Kästchen mit Fragezeichen und schraffierte Rechtecke). Die Datei scheint arg gelitten zu haben.

    Ändern solltest du sie damit können:
    Code:
    kdesu kwrite /etc/resolv.conf
    Es erscheint das Editorfenster mit leerer Datei - ich werde die wohl komplett neu anlegen müssen. Soll ich sie mir vom funktionierenden auf den nicht-funktionierenden Rechner kopieren?


    EDIT: Die Datei "resolv.config.netconfig" ist intakt. "resolv.config" ist zerschossen. Vllt. ist die Doppelexistenz der Kern des Problems?

    Tatsächlich: Auf dem funktionierenden Rechner gibt es die Datei "resolv.config.netconfig" auch gar nicht. Wie habe ich das denn wieder geschafft?

    Allerdings sollte die sowieso richtig beim Aufbau der Netzwerkverbindung angelegt werden.
    Versuch bitte mal die Verbindung im NetworkManager zu bearbeiten, schau bitte, ob unter "IPv4-Adresse" die Methode auf "Automatisch (DHCP)" gestellt ist.
    Ja, Automatisch mit DHCP ist eingestellt.

  8. #8

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by Susesuser View Post
    Wenn ich mir die Datei mit
    Code:
    cat resolv.conf
    auf meinem funktionierenden Rechner mit Internetverbindung anzeigen lassen, wird auch eine ganz normale Textdatei angezeigt. Bei meinem Rechner ohne Verbindung kommt eine einzeilige Folge von komischen ASCII-Zeichen (Weiße Kästchen mit Fragezeichen und schraffierte Rechtecke). Die Datei scheint arg gelitten zu haben.



    Es erscheint das Editorfenster mit leerer Datei - ich werde die wohl komplett neu anlegen müssen. Soll ich sie mir vom funktionierenden auf den nicht-funktionierenden Rechner kopieren?


    EDIT: Die Datei "resolv.config.netconfig" ist intakt. "resolv.config" ist zerschossen. Vllt. ist die Doppelexistenz der Kern des Problems?

    Tatsächlich: Auf dem funktionierenden Rechner gibt es die Datei "resolv.config.netconfig" auch gar nicht. Wie habe ich das denn wieder geschafft?
    Nochmal zur Sicherheit: die Datei heißt resolv.conf, nicht resolv.config.
    Dass die Datei scheinbar nur Müll enthält, kann natürlich wirklich (und ist vermutlich auch) die Ursache des Problems sein.
    Du brauchst sie aber nicht vom anderen Rechner rüberkopieren.
    Sie sollte eigentlich automatisch anhand der Netzwerkeinstellungen erzeugt werden.

    Also lösche sie einfach und mach einen Neustart, dann wird hoffentlich der Internetzugriff wieder funktionieren.

    resolv.conf.netconfig ist vermutlich eine Sicherheitskopie, die angelegt wurde, weil resolv.conf schon existiert.
    Du könntest also auch die in resolv.conf umbenennen.
    Ansonsten kannst du die auch einfach löschen.

  9. #9

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by wolfi323 View Post
    Nochmal zur Sicherheit: die Datei heißt resolv.conf, nicht resolv.config.
    Dass die Datei scheinbar nur Müll enthält, kann natürlich wirklich (und ist vermutlich auch) die Ursache des Problems sein.
    Du brauchst sie aber nicht vom anderen Rechner rüberkopieren.
    Sie sollte eigentlich automatisch anhand der Netzwerkeinstellungen erzeugt werden.

    Also lösche sie einfach und mach einen Neustart, dann wird hoffentlich der Internetzugriff wieder funktionieren.
    Phantastisch - es funktioniert wieder! Vielen Dank für deine Mühe!

    Was mich jetzt fast noch am meisten interessiert: Was könnte die Ursache dieser korrumpierten Datei gewesen sein? Ich weiß, dass ich den Rechner zuletzt etwas unsanft "hart" heruntergefahren habe. Vllt. lag es daran?

    Jedenfalls Danke nochmal!

  10. #10

    Default Re: Seit heute plötzlich keine Internetverbindung mehr

    Quote Originally Posted by Susesuser View Post
    Phantastisch - es funktioniert wieder! Vielen Dank für deine Mühe!
    Freut mich!

    Was mich jetzt fast noch am meisten interessiert: Was könnte die Ursache dieser korrumpierten Datei gewesen sein? Ich weiß, dass ich den Rechner zuletzt etwas unsanft "hart" heruntergefahren habe. Vllt. lag es daran?
    Tja, ich kann jetzt natürlich auch nur raten, und es könnte viele Ursachen haben.
    Aber ein korruptes Filesystem (verursacht durch unsanftes "hartes" Herunterfahren) könnte sowas tatsächlich verursachen, ja.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •