Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ping not respond, SSh not login,

  1. #1

    Default Ping not respond, SSh not login,

    Dear all,

    after installing 13.1, I really sorry, lot of things not working. Too complex now.

    Can not login from local subnet using ssh, even after modify /etc/ssh/sshd_config

    Pings from pcs in local subnet not responding too.

    And more, but I need this two basic things to continue.

    From 13.1 to other computers not problems at all. I can login into others linux using ssh.

    Thanks in advance.

  2. #2

    Default Re: Ping not respond, SSh not login,

    Quote Originally Posted by sergioszy View Post
    Can not login from local subnet using ssh, even after modify /etc/ssh/sshd_config

    Pings from pcs in local subnet not responding too.

    And more, but I need this two basic things to continue.

    From 13.1 to other computers not problems at all. I can login into others linux using ssh.
    Probably the Firewall is blocking.
    Try to disable/stop it temporarily in YaST->Security and Users->Firewall.

    And make sure that the sshd is running. See YaST->System->Services Manager.

  3. #3

    Default Re: Ping not respond, SSh not login,

    On 04/04/2014 11:56 AM, sergioszy wrote:
    >
    > Dear all,
    >
    > after installing 13.1, I really sorry, lot of things not working. Too
    > complex now.
    >
    > Can not login from local subnet using ssh, even after modify
    > /etc/ssh/sshd_config


    First, be sure SSH is running, as a default install will not have it
    running. You can use Yast to start the service, and set it to auto-start
    in the future.

    After that, you should make sure that the firewall is not blocking TCP 22,
    which you also do via Yast: Security: Firewall. Add 'Secure Shell' from
    the list of allowed services, save and that should be it. To load this
    from the command line:

    Code:
    --------------------
    sudo /sbin/yats firewall
    --------------------

    > Pings from pcs in local subnet not responding too.


    The default firewall does not block ICMP echo requests, so this isn't the
    firewall unless you've customized it to block somehow.

    > And more, but I need this two basic things to continue.
    >
    > From 13.1 to other computers not problems at all. I can login into
    > others linux using ssh.


    Ask the 13.1 box a bit about itself and post back the results:

    Code:
    --------------------
    #IP information
    ip addr

    #Route information
    ip route

    #listening services
    /usr/sbin/ss -planeto | grep LISTEN

    #Firewall configuration
    /usr/sbin/iptables-save
    --------------------

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Ping not respond, SSh not login,

    A newbie might not have recognized the typo
    Code:
    --------------------
    sudo /sbin/yats firewall
    --------------------
    should be
    Code:
    Code:
     --------------------
     sudo /sbin/yast firewall
     --------------------
    Agree with previous posts.
    Verify ssh service is running.
    Verify firewall has been configured to allow incoming ssh connections.

    The YAST methods described should work.

    TSU

  5. #5

    Default Re: Ping not respond, SSh not login,

    Quote Originally Posted by tsu2 View Post
    A newbie might not have recognized the typo

    should be
    Code:
    Code:
     --------------------
     sudo /sbin/yast firewall
     --------------------
    Agree with previous posts.
    Verify ssh service is running.
    Verify firewall has been configured to allow incoming ssh connections.

    The YAST methods described should work.

    TSU
    yast is TUI and yast2 is GUI so it should be.

    Code:
    /sbin/yast2

  6. #6

    Default Re: Ping not respond, SSh not login,

    To check if the firewall is up
    Code:
    rcSuSEfirewall2 status
    To disable the firewall
    Code:
    rcSuSEfirewall2 stop
    To check if sshd is running
    Code:
    rcsshd status
    Of course if you want to use a gui tool then
    Code:
    yast2 firewall
    is what you want as it was suggested above

    To check which port is open

    Code:
    nmap {remotehost|remote-ip}

    replace remotehost and remote-ip accordingly and you don't need both just pick one

  7. #7

    Default Re: Ping not respond, SSh not login,

    On 04/05/2014 10:56 PM, jetchisel pecked at the keyboard and wrote:
    > To check if the firewall is up
    >
    > Code:
    > --------------------
    > rcSuSEfirewall2 status
    > --------------------


    Unless you are using systemd in which case it would be:

    Code:
    systemctl status SuSEfirewall2
    Change the status with start, stop, enable for the function you are
    looking for. Systemctl is <tab><tab> friendly.

    Ken

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Ping not respond, SSh not login,

    On 2014-04-06 13:44, Ken Schneider wrote:
    > On 04/05/2014 10:56 PM, jetchisel pecked at the keyboard and wrote:
    >> To check if the firewall is up
    >>
    >> Code:
    >> --------------------
    >> rcSuSEfirewall2 status
    >> --------------------

    >
    > Unless you are using systemd in which case it would be:


    Nope. Even in that case, the rc... syntax works. There was a decision to
    keep in openSUSE the rc... links, and even more, make sure that
    services that don't have it create it or the package will not build in OBS.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  9. #9

    Default Re: Ping not respond, SSh not login,

    On 04/06/2014 09:18 AM, Carlos E. R. pecked at the keyboard and wrote:
    > On 2014-04-06 13:44, Ken Schneider wrote:
    >> On 04/05/2014 10:56 PM, jetchisel pecked at the keyboard and wrote:
    >>> To check if the firewall is up
    >>>
    >>> Code:
    >>> --------------------
    >>> rcSuSEfirewall2 status
    >>> --------------------

    >> Unless you are using systemd in which case it would be:

    > Nope. Even in that case, the rc... syntax works. There was a decision to
    > keep in openSUSE the rc... links, and even more, make sure that
    > services that don't have it create it or the package will not build in OBS.
    >


    That is true, for now. At some point they will go away.

    Once you get used to using systemctl and it's <tab><tab> capabilities it
    becomes easier to use. You can even use 'systemctl start <tab><tab>' and
    it will (I believe) only show services that are not started. Therefore I
    find it to actually more intuitive.

    Ken

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Ping not respond, SSh not login,

    On 2014-04-06 21:52, Ken Schneider wrote:

    >>> Unless you are using systemd in which case it would be:

    >> Nope. Even in that case, the rc... syntax works. There was a decision to
    >> keep in openSUSE the rc... links, and even more, make sure that
    >> services that don't have it create it or the package will not build in
    >> OBS.
    >>

    >
    > That is true, for now. At some point they will go away.


    No, they will not. It is official openSUSE policy to keep them, and
    enforce adding them with an automated check in OBS.

    See:

    +++···························
    Date: Wed, 29 Jan 2014 13:48:05 +0100
    From: Ludwig Nussel <...@suse.de>
    To: openSUSE Factory list <opensuse-factory@opensuse.org>
    Subject: [opensuse-factory] rc* symlinks and systemd

    Hi,

    openSUSE has a packing policy of requiring rc* symlinks for each
    init script. So for e.g. /etc/init.d/foo there must be a symlink
    /usb/sbin/rcfoo -> /etc/init.d/foo. There is an rpmlint check for this
    policy (suse-missing-rclink).
    ....
    ···························++-


    And it was accepted, none refused.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •