Results 1 to 7 of 7

Thread: (c)?clive will not work

  1. #1
    Join Date
    Aug 2011
    Location
    usa
    Posts
    232

    Default (c)?clive will not work

    Code:
    % clive --quvi='/usr/bin/quvi scan ' -F 'http://www.youtube.com/watch?example'
    Copyright (C) 2012,2013  Toni Gundogdu <legatvs@gmail.com>
    quvi comes with ABSOLUTELY NO WARRANTY.  You may redistribute copies of
    quvi under the terms of the GNU Affero General Public License version 3
    or later. For more information, see <http://www.gnu.org/licenses/agpl.html>.
    
    To contact the developers, please mail to <quvi-devel@lists.sourceforge.net>
    Detect a download command from $PATH
      Check for curl ...7.32.0
    Checking ...error: while parsing options: Unknown option -vq
    This is similar to my last post on quvi. quvi now works but (c)?clive does not. I'm not sure where the '-vq' came from so I don't know how to fix it. In cclives case I turned on the environmental variables

    Code:
    LIBQUVI_SHOW_SCRIPT=1
    LIBQUVI_SHOW_SCANDIR=1
    and, after relizing that it was looking in the wrong places I copied all the scripts into "/home/me/.libquvi-scripts/" and tried again only to find out that I am missing some scripts that it wants.

    Code:
    cclive --query-format 'http://www.youtube.com/watch?example'
    quvi: scan_dir: /home/me/lua/util: No such file or directory
    quvi: scan_dir: /home/me/.libquvi-scripts/lua/util
    quvi: scan_dir: found script: /home/me/.libquvi-scripts/lua/util/resolve_redirections.lua
    quvi: scan_dir: found script: /home/me/.libquvi-scripts/lua/util/convert_entities.lua
    quvi: scan_dir: found script: /home/me/.libquvi-scripts/lua/util/to_file_ext.lua
    quvi: scan_dir: /home/me/.config/libquvi-scripts/lua/util: No such file or directory
    quvi: scan_dir: /home/me/.local/share/libquvi-scripts/lua/util: No such file or directory
    quvi: scan_dir: /usr/share/libquvi-scripts/lua/util: No such file or directory
    quvi: scan_dir: /home/me/lua/website: No such file or directory
    quvi: scan_dir: /home/me/.libquvi-scripts/lua/website: No such file or directory
    quvi: scan_dir: /home/me/.config/libquvi-scripts/lua/website: No such file or directory
    quvi: scan_dir: /home/me/.local/share/libquvi-scripts/lua/website: No such file or directory
    quvi: scan_dir: /usr/share/libquvi-scripts/lua/website: No such file or directory
    libquvi: error: lua website scripts not found
    I have all the scripts and dependecies installed so what's up?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,103

    Default Re: (c)?clive will not work

    On Thu, 03 Apr 2014 19:16:01 +0000, ballsystemlord wrote:

    > I'm not sure where the '-vq' came from so I don't know how to fix it.


    It seems to be pulling those options from the --quvi= parameter, which in
    my own installation does not seem to be a valid option.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Aug 2011
    Location
    usa
    Posts
    232

    Default Re: (c)?clive will not work

    I'd agree with you that that's where it's getting those options from but, See the man page under:
    Code:
    OPTIONS - CONFIGURATION
           The "configuration" options may be read from the config file.  See
           "FILES".
    
       --quvi arg
           arg to be invoked to start the quvi(1) command which clive uses to
           parse the media details. This is typically a full path to quvi(1) with
           any additional options. Overrides any value set by autodetection.
    
           The following specifiers can be used in the arg:
    
             %u .. Media stream URL
    
           All occurences of the specifier will be replaced. clive will
           automatically append "--quiet" to arg.
    If I fail to pass this option I get:

    Code:
    Check for curl ...7.32.0
    Checking ...error: `http://www.youtube.com/watch?example' is not a quvi command. See 'quvi help'.
    The syntax for the command is:

    Code:
    clive [-F] [-n] [--format=<value<gt>] [--output-file=<value<gt>]
        [--filename-format=<value>] [--config-file=<value<gt>] [--quvi=<value>]
        [--get-with=<value>] [--regexp=<value>] [--exec=<value>] [--help]
        [--version] [--license] [--quiet] [<url> | <file>]
    So I should not have to pass anything but the url I think.
    If I just pass scan (a quvi command) to clive I get)

    Code:
    scan: invalid option -- 'h'
    blah blah blah
    And it prints out the scan commands options (note this is not quvi scan this is dvb-1.1.1's scan command.)

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,103

    Default Re: (c)?clive will not work

    On Wed, 09 Apr 2014 18:36:01 +0000, ballsystemlord wrote:

    > So I should not have to pass anything but the url I think.


    The man page is incorrect if the option doesn't work.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5
    Join Date
    Aug 2011
    Location
    usa
    Posts
    232

    Default Re: (c)?clive will not work

    I'll report this as an error, but what about cclive?

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: (c)?clive will not work

    On 2014-04-28 20:46, ballsystemlord wrote:
    >
    > I'll report this as an error, but what about cclive?


    In another thread, I noticed that I have a similar error to yours.
    I have problems with clive, but not with cclive:

    Code:
    
    > cer@AmonLanc:~> clive -F "https://www.youtube.com/watch?v=rsL6mKxtOlQ"
    > Detect quvi from $PATH
    >   Check for quvi ...0.9.3
    > Copyright (C) 2012,2013  Toni Gundogdu <legatvs@gmail.com>
    > quvi comes with ABSOLUTELY NO WARRANTY.  You may redistribute copies of
    > quvi under the terms of the GNU Affero General Public License version 3
    > or later. For more information, see <http://www.gnu.org/licenses/agpl.html>.
    >
    > To contact the developers, please mail to <quvi-devel@lists.sourceforge.net>
    > Detect a download command from $PATH
    >   Check for curl ...7.32.0
    > Checking ...error: `https://www.youtube.com/watch?v=rsL6mKxtOlQ' is not a quvi command. See 'quvi help'.
    > cer@AmonLanc:~>
    And that syntax is directly out of the man page.

    But cclive does, so the url is correct:

    Code:
    
    > cer@AmonLanc:~> cclive -F "https://www.youtube.com/watch?v=rsL6mKxtOlQ"
    > Checking ... ....... ....... done.
    > fmt05_240p|fmt17_144p|fmt18_360p|fmt36_240p|fmt43_360p : https://www.youtube.com/watch?v=rsL6mKxtOlQ
    > cer@AmonLanc:~>
    ·······················++-


    However, the person that told me to use clive, has no problems with my
    line... we still have to compare our rpm versions, but I'm not at home now.


    I just comment it here in case it helps you or somebody knows why it
    fails for some people.

    (that machine of mine is 32 bit, in case it is relevant).

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7
    Join Date
    Aug 2011
    Location
    usa
    Posts
    232

    Default Re: (c)?clive will not work

    Thanks, but I'm still getting "libquvi: error: lua website scripts not found". If you could tell me what versions you are using of the programs....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •