Results 1 to 7 of 7

Thread: Sleep or hibernate shuts down wireless

  1. #1

    Default Sleep or hibernate shuts down wireless

    I'm new to Linux. Recently installed OpenSUSE 13.1 to a new partition on my HD. After initiating either 'sleep' or 'hibernate', the Belkin N150 Wi-Fi USB adapter shuts off, and when I wake up the computer, the dongle remains shut off and I cannot connect to my wireless network. A full shutdown of the computer followed by a restart restores the connection as if nothing had happened.

    I found the 2010 thread about these functions disrupting wireless, but could not understand enough about the replies to know whether they related to my situation or not, or even if the thread actually produced an answer to the instant problem.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Sleep or hibernate shuts down wireless

    On 2014-04-03 19:56, YellowJacket wrote:
    >
    > I'm new to Linux. Recently installed OpenSUSE 13.1 to a new partition
    > on my HD. After initiating either 'sleep' or 'hibernate', the Belkin
    > N150 Wi-Fi USB adapter shuts off, and when I wake up the computer, the
    > dongle remains shut off and I cannot connect to my wireless network. A
    > full shutdown of the computer followed by a restart restores the
    > connection as if nothing had happened.


    Did you try un-plugging the dongle, and re-plugging it?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3

    Default Re: Sleep or hibernate shuts down wireless

    You can try to restart the network though. Either via Network Manager enable and disable wireless or

    Code:
    su -
    enter the root's password then

    Code:
    rcnetwork restart
    Then check dmesg

    Code:
    dmesg

  4. #4

    Default Re: Sleep or hibernate shuts down wireless

    Did you try un-plugging the dongle, and re-plugging it?

    --
    I tried it, but it didn't work. But thanks for the suggestion.

  5. #5

    Default Re: Sleep or hibernate shuts down wireless

    Did you try un-plugging the dongle, and re-plugging it?

    --
    This did work the last time I tried it after using hibernate. However, when I tried to use sleep, the "on" light for the computer came on, but nothing would ever come up on the screen at all - like it was shut down, so I couldn't get to the stage of even trying this fix for sleep.

    As I said before, if I do a total shutdown, everything comes back. So, this is not a priority - just something I would like to get to work, if I can.

    Thanks.

  6. #6

    Default Re: Sleep or hibernate shuts down wireless

    Quote Originally Posted by jetchisel View Post
    You can try to restart the network though. Either via Network Manager enable and disable wireless or

    Code:
    su -
    enter the root's password then

    Code:
    rcnetwork restart
    Then check dmesg

    Code:
    dmesg
    As I said in response to another post (above), when I use sleep, nothing will come up on the screen at all, even though the lights say the computer is back on.

    After using hibernate, it boots back up, but the dongle has been shut down so I don't have a network connection. I could not get it to restart using the Network Manager. I then tried the codes above, but it didn't restart the network either. "dmesg" returned about 40 pages of lines. Just in case the last 20 or so would reveal anything, they were as follows:

    230.551599] Restarting kernel threads ... done.
    [ 230.551774] Restarting tasks ... done.
    [ 231.206849] PM: Basic memory bitmaps freed
    [ 231.630293] IPv6: ADDRCONF(NETDEV_UP): enp0s11f1u8: link is not ready
    [ 231.639389] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 231.941301] IPv6: ADDRCONF(NETDEV_UP): enp0s11f1u8: link is not ready
    [ 231.958117] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 231.958391] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 255.003964] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 288.003075] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 331.004474] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 356.510342] IPv6: ADDRCONF(NETDEV_UP): enp0s11f1u8: link is not ready
    [ 356.814439] IPv6: ADDRCONF(NETDEV_UP): enp0s11f1u8: link is not ready
    [ 356.841361] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 356.843792] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 380.005705] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 413.002864] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 445.953938] b44 ssb0:0 eth0: powering down PHY
    [ 446.134745] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 446.239306] IPv6: ADDRCONF(NETDEV_UP): enp0s11f1u8: link is not ready
    [ 446.546321] IPv6: ADDRCONF(NETDEV_UP): enp0s11f1u8: link is not ready
    [ 446.552975] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 446.579790] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    [ 446.580238] r8712u 1-8:1.0 enp0s11f1u8: In r8711_wx_set_scan: bDriverStopped=1
    linux-2xtd:~ #

    I have figured out a workaround for the hibernate problem. I just pull out the dongle before initiating it, then replace it after the hibernating process terminates (computer 'on' light goes out).

    I would like the sleep function to work, but it is not a priority. If you think of anything else, let me know.

    Thanks.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Sleep or hibernate shuts down wireless

    I have figured out a workaround for the hibernate problem. I just pull out the dongle before initiating it, then replace it after the hibernating process terminates (computer 'on' light goes out).
    Carlos did actually suggest that to you. (It is a common way of re-initializing usb hardware.)

    I would like the sleep function to work, but it is not a priority. If you think of anything else, let me know.

    Thanks.
    You could try creating a config file (eg custom.config) in /etc/pm/config.d/ directory with
    Code:
    SUSPEND_MODULES=r8712u
    That might help with suspending the kernel module and reinstating cleanly on wake up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •