Results 1 to 8 of 8

Thread: Video playback trouble

  1. #1

    Default Video playback trouble

    Hi, I'm using OpenSUSE 13.1, I hae downloaded the one click install codecs.

    Kaffiene will play some things, but not many (plus it has a green line along the bottom of the screen which makes it unusable even when it does play).

    I downloaded totem, doesn't do anything at all. It will usually just close when I try to open a vid.

    VLC will play everything I throw at it, but when I play a HD video there is a stutter every now and then.

    Can someone help to fix these problems? I like to have several working media players.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Video playback trouble

    https://forums.opensuse.org/entry.ph...allation-Guide

    Personally I prefer smplayer or vlc

    What GPU do you have?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Video playback trouble

    I have a 4GB GTX 770 (Gigabyte Windforce).

    Take a look at this, I was following the guide you posted.

    Code:
    linux-kmee:/home/calvin # zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs
    Loading repository data...
    Reading installed packages...
    'gstreamer-plugins-base' is already installed.
    There is an update candidate for 'gstreamer-plugins-base', but it is from a different vendor. Use 'zypper install gstreamer-plugins-base-1.2.3-2.12.x86_64' to install this candidate.
    'gstreamer-0_10-plugins-bad' is already installed.
    No update candidate for 'gstreamer-0_10-plugins-bad-0.10.23-24.37.x86_64'. The highest available version is already installed.
    'gstreamer-plugins-bad' is already installed.
    There is an update candidate for 'gstreamer-plugins-bad', but it is from a different vendor. Use 'zypper install gstreamer-plugins-bad-1.2.3-5.17.x86_64' to install this candidate.
    'lame' is already installed.
    No update candidate for 'lame-3.99.5-1013.6.x86_64'. The highest available version is already installed.
    'vlc' is already installed.
    No update candidate for 'vlc-2.1.4-199.16.x86_64'. The highest available version is already installed.
    'gstreamer-0_10-plugins-good' is already installed.
    There is an update candidate for 'gstreamer-0_10-plugins-good', but it is from a different vendor. Use 'zypper install gstreamer-0_10-plugins-good-0.10.31-17.5.x86_64' to install this candidate.
    'gstreamer-0_10-plugins-ugly' is already installed.
    No update candidate for 'gstreamer-0_10-plugins-ugly-0.10.19-12.4.x86_64'. The highest available version is already installed.
    'gstreamer-plugins-good' is already installed.
    There is an update candidate for 'gstreamer-plugins-good', but it is from a different vendor. Use 'zypper install gstreamer-plugins-good-1.2.3-4.2.x86_64' to install this candidate.
    'gstreamer-0_10-plugins-ffmpeg' is already installed.
    No update candidate for 'gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.3.x86_64'. The highest available version is already installed.
    'libxine2-codecs' is already installed.
    No update candidate for 'libxine2-codecs-1.2.3-89.6.x86_64'. The highest available version is already installed.
    'gstreamer-0_10-plugins-ugly-orig-addon' is already installed.
    No update candidate for 'gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-12.4.x86_64'. The highest available version is already installed.
    'k3b-codecs' is already installed.
    No update candidate for 'k3b-codecs-2.0.2-18.44.x86_64'. The highest available version is already installed.
    'vlc-codecs' is already installed.
    No update candidate for 'vlc-codecs-2.1.4-199.16.x86_64'. The highest available version is already installed.
    'libdvdcss2' is already installed.
    No update candidate for 'libdvdcss2-1.2.13-5.2.x86_64'. The highest available version is already installed.
    'flash-player' is already installed.
    No update candidate for 'flash-player-11.2.202.346-38.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    6 Problems:
    Problem: ffmpeg-2.2-1.3.x86_64 requires libavcodec55 = 2.2, but this requirement cannot be provided
    Problem: gstreamer-plugins-ugly-1.2.3-2.2.x86_64 requires gstreamer >= 1.2.0, but this requirement cannot be provided
    Problem: gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64 requires gstreamer-plugins-bad >= 1.2.3, but this requirement cannot be provided
    Problem: gstreamer-plugins-ugly-orig-addon-1.2.3-2.2.x86_64 requires gstreamer-plugins-ugly >= 1.2.3, but this requirement cannot be provided
    Problem: gstreamer-plugins-good-extra-1.2.3-4.2.x86_64 requires gstreamer-plugins-good = 1.2.3, but this requirement cannot be provided
    Problem: gstreamer-0_10-plugins-bad-orig-addon-0.10.23-24.37.x86_64 requires libmpeg2encpp-2.0.so.0()(64bit), but this requirement cannot be provided
    
    Problem: ffmpeg-2.2-1.3.x86_64 requires libavcodec55 = 2.2, but this requirement cannot be provided
      uninstallable providers: libavcodec55-2.2-1.3.i586[ftp.gwdg.de-suse]
                       libavcodec55-2.2-1.3.x86_64[ftp.gwdg.de-suse]
                       libavcodec55-2.2-1.3.i586[packman]
                       libavcodec55-2.2-1.3.x86_64[packman]
     Solution 1: deinstallation of libavfilter3-2.1.4-1.3.x86_64
     Solution 2: do not install ffmpeg-2.2-1.3.x86_64
     Solution 3: do not install ffmpeg-2.2-1.3.x86_64
     Solution 4: break ffmpeg-2.2-1.3.x86_64 by ignoring some of its dependencies
    Which one should I choose? I get a LOT of problems like this, too many to post really.

  4. #4

    Default Re: Video playback trouble

    Sorry about the messy format, let's try again:

    Code:
    zypper install libxine2-codecs ffmpeg lame  gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad  gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon  gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon  gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07  gstreamer-plugins-base gstreamer-plugins-bad  gstreamer-plugins-bad-orig-addon gstreamer-plugins-good  gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon  gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux  gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc  smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs
    Here' the output of that:

    Code:
    Problem: ffmpeg-2.2-1.3.x86_64 requires libavcodec55 = 2.2, but this requirement cannot be provided
      uninstallable providers: libavcodec55-2.2-1.3.i586[ftp.gwdg.de-suse]
                       libavcodec55-2.2-1.3.x86_64[ftp.gwdg.de-suse]
                       libavcodec55-2.2-1.3.i586[packman]
                       libavcodec55-2.2-1.3.x86_64[packman]
     Solution 1: deinstallation of libavfilter3-2.1.4-1.3.x86_64
     Solution 2: do not install ffmpeg-2.2-1.3.x86_64
     Solution 3: do not install ffmpeg-2.2-1.3.x86_64
     Solution 4: break ffmpeg-2.2-1.3.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c):

  5. #5

    Default Re: Video playback trouble

    Quote Originally Posted by Astralogic View Post
    Code:
    Problem: ffmpeg-2.2-1.3.x86_64 requires libavcodec55 = 2.2, but this requirement cannot be provided
      uninstallable providers: libavcodec55-2.2-1.3.i586[ftp.gwdg.de-suse]
                       libavcodec55-2.2-1.3.x86_64[ftp.gwdg.de-suse]
                       libavcodec55-2.2-1.3.i586[packman]
                       libavcodec55-2.2-1.3.x86_64[packman]
     Solution 1: deinstallation of libavfilter3-2.1.4-1.3.x86_64
     Solution 2: do not install ffmpeg-2.2-1.3.x86_64
     Solution 3: do not install ffmpeg-2.2-1.3.x86_64
     Solution 4: break ffmpeg-2.2-1.3.x86_64 by ignoring some of its dependencies
    Which one should I choose? I get a LOT of problems like this, too many to post really.
    Choose Solution 1 "deinstallation of libavfilter3". That package does not exist anymore after ffmpeg's update to 2.2.
    It is called "libavfilter4" now, which should get installed automatically. (that's why there is a conflict in the first place)

    Oh, and obviously you have TWO Packman repos. Remove one in YaST->Software Repositories.
    Last edited by wolfi323; 03-Apr-2014 at 11:36.

  6. #6

    Default Re: Video playback trouble

    Quote Originally Posted by wolfi323 View Post
    Choose Solution 1 "deinstallation of libavfilter3". That package does not exist anymore after ffmpeg's update to 2.2.
    It is called "libavfilter4" now, which should get installed automatically. (that's why there is a conflict in the first place)

    Oh, and obviously you have TWO Packman repos. Remove one in YaST->Software Repositories.
    OK I removed a packman repo. What should I do about this:

    Code:
    Problem: gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64 requires libmpeg2encpp-2.0.so.0()(64bit), but this requirement cannot be provided
      uninstallable providers: libmjpegutils-2_0-0-2.0.0-57.4.x86_64[ftp.gwdg.de-suse]
     Solution 1: Following actions will be done:
      do not install gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64
      do not install gstreamer-0_10-plugins-bad-orig-addon-0.10.23-24.37.x86_64
     Solution 2: install libmjpegutils-2_0-0-2.0.0-57.4.x86_64 (with vendor change)
      openSUSE  -->  http://packman.links2linux.de
     Solution 3: break gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64 by ignoring some of its dependencies

  7. #7

    Default Re: Video playback trouble

    Quote Originally Posted by Astralogic View Post
    OK I removed a packman repo. What should I do about this:

    Code:
    Problem: gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64 requires libmpeg2encpp-2.0.so.0()(64bit), but this requirement cannot be provided
      uninstallable providers: libmjpegutils-2_0-0-2.0.0-57.4.x86_64[ftp.gwdg.de-suse]
     Solution 1: Following actions will be done:
      do not install gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64
      do not install gstreamer-0_10-plugins-bad-orig-addon-0.10.23-24.37.x86_64
     Solution 2: install libmjpegutils-2_0-0-2.0.0-57.4.x86_64 (with vendor change)
      openSUSE  -->  http://packman.links2linux.de
     Solution 3: break gstreamer-plugins-bad-orig-addon-1.2.3-5.17.x86_64 by ignoring some of its dependencies
    But this is mentioned in the link above:
    If you face choices. Look carefully for the option to let the package/s switch from openSUSE > packman
    So choose:
    Code:
    Solution 2: install libmjpegutils-2_0-0-2.0.0-57.4.x86_64 (with vendor change)
      openSUSE  -->  http://packman.links2linux.de
    And for every following similar question, again choose "install xxx (with vendor change) openSUSE --> http://packman.links2linux.de".
    Last edited by wolfi323; 04-Apr-2014 at 05:30.

  8. #8

    Default Re: Video playback trouble

    THanks, I went through them all without a problem. Hopefully everything will play now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •