Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: NFS user mounts

  1. #1

    Default NFS user mounts

    I have an NFS client mounting a share set up via YaST (in openSUSE 13.1 x80_64). I have put "users" into the options so I could mount the share from GUI with a regular user. However, whenever I try to mount it from Dolphin, I get an error:
    mount.nfs: not installed setuid - "user" NFS mounts not supported.
    This seems to be new, since I don't recall ever having this issue in 12.3. Does anyone else have this issue? Any ideas on how to allow regular users to mount NFS shares again?

    For the record, this is the fstab entry in question:
    Code:
    dragon:/export/storage  /mnt/storage    nfs     users,soft,bg,intr,timeo=5,retrans=5,actimeo=10,retry=5,noauto,vers=3 0 0

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: NFS user mounts

    On Thu, 03 Apr 2014 15:16:01 +0000, GreatEmerald wrote:

    > I have put "users" into the options


    That should be "user" not "users".

    I use NFS mounts on my systems here, and "user" is what I use, and it
    works fine.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: NFS user mounts

    According to man mount, it shouldn't make a difference... But I'll try that.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: NFS user mounts

    On Thu, 03 Apr 2014 16:16:01 +0000, GreatEmerald wrote:

    > According to man mount, it shouldn't make a difference... But I'll try
    > that.


    Good to know, I've always used 'user', so wasn't aware it was treated as
    a synonym.

    I do note that my mount.nfs is flagged SUID as well, so if anything,
    doing that should resolve the message.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,734

    Default Re: NFS user mounts

    Well, man mount states:
    user
    Allow an ordinary user to mount the filesystem. The name of the mounting user is written to mtab so that he can unmount the filesystem again. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid).
    users
    Allow every user to mount and unmount the filesystem. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line users,exec,dev,suid).
    Thus imho the OP has a point here.
    Henk van Velden

  6. #6

    Default Re: NFS user mounts

    Quote Originally Posted by hendersj View Post
    I do note that my mount.nfs is flagged SUID as well, so if anything,
    doing that should resolve the message.
    Mine's doesn't seem to be:
    Code:
    > ls -l /sbin/mount.nfs*
    -rwxr-xr-x 1 root root 110760 2014-02-04 12:50 /sbin/mount.nfs
    lrwxrwxrwx 1 root root      9 2014-02-14 15:50 /sbin/mount.nfs4 -> mount.nfs
    I'm pretty sure I haven't changed anything in that regard... So why is it not set to suid? There must be a reason why it's like that now? Since suid is related to security, I don't want to mess around with it unless I really have to...

  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: NFS user mounts

    On Thu, 03 Apr 2014 18:16:01 +0000, hcvv wrote:

    > Well, man mount states:
    >> user Allow an ordinary user to mount the filesystem. The name of the
    >> mounting user is written to mtab so that he can unmount the filesystem
    >> again. This option implies the options noexec, nosuid, and nodev
    >> (unless overridden by subsequent options, as in the option line
    >> user,exec,dev,suid).
    >> users Allow every user to mount and unmount the filesystem. This option
    >> implies the options noexec, nosuid, and nodev (unless overridden by
    >> subsequent options, as in the option line users,exec,dev,suid).
    >>

    > Thus imho the OP has a point here.


    Not sure I follow.

    If mount.nfs isn't setuid, then user mounts won't work. My installation
    was already set up that way, though.

    The fstab options don't have anything to do with whether mount.nfs is
    setuid or not, though.

    The fix is to make mount.nfs setuid.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: NFS user mounts

    On Thu, 03 Apr 2014 18:36:01 +0000, GreatEmerald wrote:

    > hendersj;2634795 Wrote:
    >> I do note that my mount.nfs is flagged SUID as well, so if anything,
    >> doing that should resolve the message.

    >
    > Mine's doesn't seem to be:
    >
    > Code:
    > --------------------
    > > ls -l /sbin/mount.nfs*

    > -rwxr-xr-x 1 root root 110760 2014-02-04 12:50 /sbin/mount.nfs
    > lrwxrwxrwx 1 root root 9 2014-02-14 15:50 /sbin/mount.nfs4 ->
    > mount.nfs
    > --------------------
    >
    >
    > I'm pretty sure I haven't changed anything in that regard... So why is
    > it not set to suid? There must be a reason why it's like that now? Since
    > suid is related to security, I don't want to mess around with it unless
    > I really have to...


    No idea why it isn't, but on my system it is, and it's necessary to do
    what you want, so you should set it if you want users to be able to mount
    NFS filesystems.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,734

    Default Re: NFS user mounts

    I have:
    Code:
    boven:~ # ls -l $(which mount.nfs)
    -rwsr-xr-x 1 root root 110760 Feb  4 11:50 /sbin/mount.nfs
    boven:~ #
    I do not know why you have different.
    You could of course change, but then there a re a few questions, like
    • why did this happen in the first place?
    • how many more are there at fault?
    Henk van Velden

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,734

    Default Re: NFS user mounts

    Quote Originally Posted by hendersj View Post
    On Thu, 03 Apr 2014 16:16:01 +0000, GreatEmerald wrote:

    > According to man mount, it shouldn't make a difference... But I'll try
    > that.


    Good to know, I've always used 'user', so wasn't aware it was treated as
    a synonym.

    I do note that my mount.nfs is flagged SUID as well, so if anything,
    doing that should resolve the message.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    It seems that we do a fair amount of cross posting here.

    My citations from the man page were because I read from your post tthat users might be wrong were user is OK. And thy are no synonyms. The one allows only the user that mounted to do an umount. The other lets all users umount irrespective of who mounted.

    Of course the original problem is the missing SUID bit. Easy to change, But that is only a symptom. What is the root cause?
    Henk van Velden

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •