Results 1 to 4 of 4

Thread: rpm error

  1. #1
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default rpm error

    I was just searching the rpm database for installed apps

    I saw this error:
    Code:
    error: rpmdbNextIterator: skipping h#    2346 blob size(7508): BAD, 8 + 16 * il(21) + dl(3836)
    I tried a rebuild of the db as I was unsure of this error the --rebuilddb brought up the same error

    Advices welcome
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  2. #2

    Default Re: rpm error

    Hi, perhaps this http://lists.opensuse.org/opensuse/2.../msg01725.html and the messages after it will help (especially this : "There is another way: in "/var/adm/backup/rpmdb" you have daily bakcups of that database made by cron (run-crons: suse.de-backup-rpmdb). By default it keeps 5 copies, you can increase the number somewhere in /etc/sysconfig. Once you get a good copy, you only need to worry about what you did the last days(s)." HTH Lenwolf

  3. #3

    Default Re: rpm error

    Quote Originally Posted by caf4926 View Post
    I was just searching the rpm database for installed apps

    I saw this error:
    Code:
    error: rpmdbNextIterator: skipping h#    2346 blob size(7508): BAD, 8 + 16 * il(21) + dl(3836)
    I tried a rebuild of the db as I was unsure of this error the --rebuilddb brought up the same error

    Advices welcome
    Well, I've never seen this before, but it really looks like a corrupted rpm database IMHO.

    --rebuilddb does NOT rebuild the main rpm database (/var/lib/rpm/Packages, which contains the list of installed packages), it only recreates the other dbs that can be inferred by that.

    I think you should try to restore the database from one of the backups in /var/adm/backup/rpmdb/.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: rpm error

    zypper ve
    found a broken dependency and following that --rebuilddb
    all was good

    Thanks
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •