Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: slow fade in screen before login appears

  1. #1

    Default slow fade in screen before login appears

    I've pretty much managed to set everything up to my liking on both my desktop and the laptop. A few issues remain though.

    My desktop pc is extremely slow when it comes to GUI. After grub, the initial screen with the cameleon is supposed to fade in fast and then seamlessly display the login box. However, it takes like 30 seconds for the image to fade in, I can count the individual fades as the image get brighter, its that slow. Then when the login box is supposed to display, the screen goes black and comes back with the login box. After that, everything seems fine.

    I tried removing the themed login but that doesn't remove this fade effect.

    My box is running 13.1 fully updated with Nvidia drivers from the repositories (331.60 I believe). But I don't think the driver is active at that point, I tihnk that's why the screen goes blank to display the login screen.

    Is this lower res screen coming from grub perhaps?

    Any ideas how I can solve this?

    Thanks!

  2. #2

    Default Re: slow fade in screen before login appears

    Quote Originally Posted by AnarKist View Post
    My desktop pc is extremely slow when it comes to GUI. After grub, the initial screen with the cameleon is supposed to fade in fast and then seamlessly display the login box. However, it takes like 30 seconds for the image to fade in, I can count the individual fades as the image get brighter, its that slow.
    The picture is NOT supposed to fade in fast.
    It's purpose is to fade in slowly until the system has booted up completely to show the boot progress.

    Then when the login box is supposed to display, the screen goes black and comes back with the login box. After that, everything seems fine.

    I tried removing the themed login but that doesn't remove this fade effect.

    My box is running 13.1 fully updated with Nvidia drivers from the repositories (331.60 I believe). But I don't think the driver is active at that point, I tihnk that's why the screen goes blank to display the login screen.
    No, that's a limitation of kdm, the login screen. And yes, the driver is active at that point.

    I think GNOME's gdm does it better so you might want to try that if that disturbs you.
    (Install the package "gdm", and set DISPLAYMANGER="gdm" in /etc/sysconfig/displaymanager)
    You could also try lightdm as well.

    Is this lower res screen coming from grub perhaps?
    Yes, you can set the grub2/bootsplash resolution in YaST->Boot Loader->Boot Loader Options. ("Use Graphical Console")
    The default "Autodetected by Grub2" does not work well with all cards, so explicitely set a resolution there.

  3. #3

    Default Re: slow fade in screen before login appears

    Quote Originally Posted by wolfi323 View Post
    The picture is NOT supposed to fade in fast.
    It's purpose is to fade in slowly until the system has booted up completely to show the boot progress.
    Oh, oke. I assumed that because on the laptop the entire boot process takes less than 7 seconds. I barely see the fade because its followed up by the login screen so quickly.

    Quote Originally Posted by wolfi323 View Post
    No, that's a limitation of kdm, the login screen. And yes, the driver is active at that point.

    I think GNOME's gdm does it better so you might want to try that if that disturbs you.
    (Install the package "gdm", and set DISPLAYMANGER="gdm" in /etc/sysconfig/displaymanager)
    You could also try lightdm as well.
    I don't think that is really the issue here so I'll leave it as it is. I need to troubleshoot why its loading so slow which is before the login is displayed. The HD led is continuously burning during the fade phase.


    Quote Originally Posted by wolfi323 View Post
    Yes, you can set the grub2/bootsplash resolution in YaST->Boot Loader->Boot Loader Options. ("Use Graphical Console")
    The default "Autodetected by Grub2" does not work well with all cards, so explicitely set a resolution there.
    I'll have a look but I doubt it will change anything.

    Boot from Grub menu (after POST) takes 50 seconds to the login screen. I'm booting in EFI mode.

    The system is an Asus P8P67 with 2600k I7 (running stock, not overclocked) with 16GB 1600Mhz memory (running on SPD settings). Disk is a Samsung 830 256GB on SATA6 (port 0).

    The laptop is also Asus, N55SF with mobile i7 version (forget which one exactly) with Kingston 128GB SSD (the cheaper one). Boots in less than 7 seconds.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,284

    Default Re: slow fade in screen before login appears

    Press esc during the boot and you will see things as they start. maybe it will give you insight on what is slow

  5. #5

    Default Re: slow fade in screen before login appears

    Thanks guys.

    It seems to just be slow with everything, but LSB (configuring network or something?) took some noticable time but its not the main cause, it just takes a few seconds.

    I uploaded a bootchart if anyone wants to have a look.

  6. #6

    Default Re: slow fade in screen before login appears

    On Wed, 02 Apr 2014 16:06:01 GMT
    AnarKist <AnarKist@no-mx.forums.opensuse.org> wrote:

    >
    > I've pretty much managed to set everything up to my liking on both my
    > desktop and the laptop. A few issues remain though.
    >
    > My desktop pc is extremely slow when it comes to GUI. After grub, the
    > initial screen with the cameleon is supposed to fade in fast and then
    > seamlessly display the login box. However, it takes like 30 seconds
    > for the image to fade in, I can count the individual fades as the
    > image get brighter, its -that- slow. Then when the login box is
    > supposed to display, the screen goes black and comes back with the
    > login box. After that, everything seems fine.
    >
    > I tried removing the themed login but that doesn't remove this fade
    > effect.
    >
    > My box is running 13.1 fully updated with Nvidia drivers from the
    > repositories (331.60 I believe). But I don't think the driver is
    > active at that point, I tihnk that's why the screen goes blank to
    > display the login screen.
    >
    > Is this lower res screen coming from grub perhaps?
    >
    > Any ideas how I can solve this?
    >


    You could try replacing nVidia driver with nouveau though that might
    cause other trouble - my machine would lock up occasionally with the
    nouveau driver. I got problems with that boot display after replacing
    nouveau with nVidia on 13.1. The screen comes in fairly bright, then
    fades rapidly to black and then slowly brightens again. I recognise the
    problem from way back and I think nVidia have picked up an old version
    of the display.


    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 13.2-m0 (64-bit); KDE 4.12.2; AMD Phenom II X2 550 Processor;
    Kernel: 3.14.0-rc5; Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA)

  7. #7

    Default Re: slow fade in screen before login appears

    Quote Originally Posted by AnarKist View Post
    Thanks guys.

    It seems to just be slow with everything, but LSB (configuring network or something?) took some noticable time but its not the main cause, it just takes a few seconds.

    I uploaded a bootchart if anyone wants to have a look.
    Well, in that bootchart, the vmware kernel modules got recompiled which of course takes time.

    Btw, you can also use "systemd-analyze blame" to see a list of which service takes how long to start on boot.
    And "systemd-analyze critical-chain" shows the longest chain that makes up the boot time.

  8. #8

    Default Re: slow fade in screen before login appears

    Quote Originally Posted by wolfi323 View Post
    Well, in that bootchart, the vmware kernel modules got recompiled which of course takes time.

    Btw, you can also use "systemd-analyze blame" to see a list of which service takes how long to start on boot.
    22.042s network.service
    11.961s vmware-workstation-server.service
    4.019s systemd-tmpfiles-clean.service
    1.177s vmware.service

    I'm running Vmware Workstation, one of the first things I installed so I'm not sure how it booted before. But 22 secs on network.service is a lot isn't it?

    Quote Originally Posted by wolfi323 View Post
    And "systemd-analyze critical-chain" shows the longest chain that makes up the boot time.
    systemd-analyze critical-chain
    The time after the unit is active or started is printed after the "@" character.
    The time the unit takes to start is printed after the "+" character.

    graphical.target @38.167s
    └─multi-user.target @38.167s
    └─vmware-workstation-server.service @26.205s +11.961s
    └─vmware.service @25.026s +1.177s
    └─network.target @25.026s
    └─network.service @2.984s +22.042s
    └─SuSEfirewall2_init.service @2.926s +56ms
    └─basic.target @2.922s
    └─sockets.target @2.922s
    └─dbus.socket @2.922s
    └─sysinit.target @2.920s
    └─sys-fs-fuse-connections.mount @25.091s +1ms
    └─systemd-modules-load.service @2.480s +51ms
    └─systemd-readahead-replay.service @2.269s +206ms

    Looks like we're getting somewhere. Vmware-workstation-server I think is for shared Vm's. I don't need that, I'll look into disablign that tomorrow.

    Any ideas what I can do about 22 secs for network service?

    Thanks again! Appreciate the help.

  9. #9

    Default Re: slow fade in screen before login appears

    Quote Originally Posted by AnarKist View Post
    I'm running Vmware Workstation, one of the first things I installed so I'm not sure how it booted before.
    You could disable vmware-workstation-server.service (in vmware's settings f.e.). It is only needed if you want to connect to your VMs via the network.
    But 22 secs on network.service is a lot isn't it?
    Yes. You could try to switch to NetworkManager to see if that helps.

  10. #10

    Default Re: slow fade in screen before login appears

    Quote Originally Posted by wolfi323 View Post
    You could disable vmware-workstation-server.service (in vmware's settings f.e.). It is only needed if you want to connect to your VMs via the network.
    Disabling from within Vmware settings doesn't help. I need to check with those systemd commands later today but last night I did a quick reboot and the time is still ~50 seconds.

    Quote Originally Posted by wolfi323 View Post
    Yes. You could try to switch to NetworkManager to see if that helps.
    I'll see if I can figure out how to switch, not sure how that works but it can't be that hard.

    Cheers.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •