Results 1 to 6 of 6

Thread: shutdown/restart anomaly

  1. #1
    Join Date
    Jan 2009
    Location
    Mesa, AZ
    Posts
    29

    Default shutdown/restart anomaly

    Hello everyone I've been using openSUSE for almost 3 weeks and have noticed that sometimes like once every 20 restarts it will take a bit longer to restart, its like it freezes on the shutdown screen the screen that has the image of the grey background and the vine on the right side, the vine will slowly disappear then leave the grey background image, usually its about 30sec to 1min long then it goes ahead and restarts.

    This happens on 13.1 and Tumbleweed which im currently using. Is this normal ? does anyone else notice this behavior also ?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: shutdown/restart anomaly

    Quote Originally Posted by garikfox View Post
    Hello everyone I've been using openSUSE for almost 3 weeks and have noticed that sometimes like once every 20 restarts it will take a bit longer to restart, its like it freezes on the shutdown screen the screen that has the image of the grey background and the vine on the right side, the vine will slowly disappear then leave the grey background image, usually its about 30sec to 1min long then it goes ahead and restarts.

    This happens on 13.1 and Tumbleweed which im currently using. Is this normal ? does anyone else notice this behavior also ?
    I've noticed that. However, it is a lot better than when 13.1 was first released. Then it was more like 50% of the time.

    Make sure you have applied all online updates.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: shutdown/restart anomaly

    Doesn’t fsck get run every X restarts?

  4. #4

    Default Re: shutdown/restart anomaly

    Quote Originally Posted by gogalthorp View Post
    Doesn’t fsck get run every X restarts?
    Depending on the filesystem and its settings, yes.
    But this is done on _boot_, not on shutdown.

    This problem is a bug in systemd though AFAIK.
    The user session cannot be killed for some reason and systemd waits until the (30 seconds?) timeout to continue the shutdown.
    If you press ESC, you can see it.

    I experience this from time to time as well, but have no idea what triggers it.
    But I think there's a bugreport about that.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: shutdown/restart anomaly

    On 2014-04-02 18:46, gogalthorp wrote:
    >
    > Doesn’t fsck get run every X restarts?


    Not really.

    There is a method to detect, or guess, if the system was properly closed
    the previous time.

    On 11.4, which was about the last to use system V, you can see the
    method used - with the current systemd, I don't know -. Look at
    "/etc/init.d/ boot.rootfsck and boot.localfs":

    If the file "/fastboot" exists, there is no fsck done.

    If the file /forcefsck"" exists, fsck is forced.


    Then, some filesystem types do always a fast check (reiserfs? xfs?);
    only if symptoms of problems are found it does a real check.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  6. #6
    Join Date
    Jan 2009
    Location
    Mesa, AZ
    Posts
    29

    Default Re: shutdown/restart anomaly

    Thanks guys, I see this is fairly normal behavior then.
    MSI H81M-P33 | Intel Pentium G3220 | 2x4GB Corsair Vengeance | Toshiba Q Series Pro 128GB | openSUSE Tumbleweed 64-bit (KDE)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •