Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

  1. #1

    Default Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    I upgrade to 4.12 but i don't see much difference. I was looking for a solution to downgrade but no luck. Is there a way to remove 4.12 withou braking my system. I really like it as is.

    I used this thread to do the upgrade :
    http://www.muktware.com/2013/12/inst...use-13-1/17881

    Now I get this when doing any update :
    The following 59 package updates will NOT be installed:


    any help would be appreciated

    Thanks
    Last edited by frenchman1010; 31-Mar-2014 at 08:56. Reason: Fix Title

  2. #2

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Quote Originally Posted by frenchman1010 View Post
    I upgrade to 4.12 but i don't see much difference. I was looking for a solution to downgrade but no luck. Is there a way to remove 4.12 withou braking my system. I really like it as is.

    I used this thread to do the upgrade :
    http://www.muktware.com/2013/12/inst...use-13-1/17881
    What other repos do you have?
    Code:
    zypper lr -d
    The easiest way would be to disable/remove the repo and run "sudo zypper dup". If you use KDE:Extra as well, don't forget to switch that back to the standard openSUSE_13.1 flavor before that.
    But with many additional repos this could lead to problems.

    Now I get this when doing any update :
    The following 59 package updates will NOT be installed:
    That just tells you that those packages would exist in another repo with a higher version or build number.
    zypper doesn't switch packages to another repo by default, and normally you wouldn't want it to.

  3. #3

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    There is the output from terminal:

    1 | Google-Chrome | Google-Chrome | Yes | No | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    2 | KDE412 | KDE412 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    3 | KDE412E | KDE412E | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    4 | download.opensuse.org-Education | openSUSE BuildService - Education | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    5 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    6 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.1/ |
    7 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |
    8 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    9 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    10 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    11 | repo-oss | openSUSE-13.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    12 | repo-source | openSUSE-13.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    13 | repo-update | openSUSE-13.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    14 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Disable repo 2 and 3

    Then open a terminal and do

    Code:
    su -
    zypper dup
    reboot and then do this:
    https://dl.dropboxusercontent.com/u/...Switch_KDE.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Quote Originally Posted by frenchman1010 View Post
    I upgrade to 4.12 but i don't see much difference. I was looking for a solution to downgrade but no luck. Is there a way to remove 4.12 withou braking my system. I really like it as is.

    I used this thread to do the upgrade :
    http://www.muktware.com/2013/12/inst...use-13-1/17881

    Now I get this when doing any update :
    The following 59 package updates will NOT be installed:


    any help would be appreciated

    Thanks
    if you don't see much difference why switch back?
    Is there some problem that you didn't have in KDE 4.11?
    Visually KDE 4.12 is identical to 4.11 but there are probably some improvements that may not be immediately obvious.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Quote Originally Posted by frenchman1010 View Post
    I upgrade to 4.12 but i don't see much difference. I was looking for a solution to downgrade but no luck. Is there a way to remove 4.12 withou braking my system. I really like it as is.

    I used this thread to do the upgrade :
    http://www.muktware.com/2013/12/inst...use-13-1/17881

    Now I get this when doing any update :
    The following 59 package updates will NOT be installed:


    any help would be appreciated

    Thanks
    The packages that will not be installed is normal if you have followed my guide on switching to a vendor such as Packman.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Quote Originally Posted by frenchman1010 View Post
    I upgrade to 4.12 but i don't see much difference. I was looking for a solution to downgrade but no luck. Is there a way to remove 4.12 withou braking my system. I really like it as is.

    I used this thread to do the upgrade :
    http://www.muktware.com/2013/12/inst...use-13-1/17881

    Now I get this when doing any update :
    The following 59 package updates will NOT be installed:


    any help would be appreciated

    Thanks
    Restore from the backup you made before doing the upgrade.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Quote Originally Posted by Fraser_Bell View Post
    Restore from the backup you made before doing the upgrade.
    The method outlined by wolfie323 and caf4926 should be sufficient. (I've done the same previously when needing to switch between KDE versions for bug reporting purposes.)

  9. #9

    Default Re: Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Quote Originally Posted by caf4926 View Post
    Disable repo 2 and 3
    Disabling repo 3 shouldn't be necessary, but as I mentioned already you should change the URL to the standard openSUSE_13.1 flavor before you run the "zypper dup".

    Either edit the corresponding file in /etc/zypp/repos.d/ with a text editor, or change it in YaST->Software Repositories.
    The URL should be:
    http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/

  10. #10

    Default Re: (SOLVED) Want to downgrade from KDE 4.12 on OpenSuse 13.1 to original stock

    Thank you everyone for the great help. wolfi323 thank you, it works.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •