Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Настройка Intel/ATI графики

  1. #1
    Join Date
    Mar 2014
    Location
    Dnepropetrovsk
    Posts
    105

    Default Настройка Intel/ATI графики

    Добрый день!

    Никак не могу заставить работать дискретную видеокарту на своём Lenovo IdeaPad G500A (Intel Core i5-3230M, Intel HD Graphics 4000, AMD Radeon HD 8750M) под OpenSUSE 12.3.

    Интеловский драйвер на встроенной карте стоит нормально. Все обновления системы проставлены.

    Перед тем, как ставить fglrx драйвер, проставила недостающие программы, требуемые AMD. Единственное только, что касается XFree86-Mesa-libGL, я думаю, что установленные Mesa-libGL-devel и т.д., это и есть то, что требуется.

    Ставить драйвер пробовала разными способами, в частности, предложенным в http://ru.opensuse.org/SDB:AMD_fglrx, "Ручная сборка и установка rpm" (нижеприведенные описания будут относиться именно к этой попытке, хотя в остальных случаях результат тот же, разве с разницей во второстепенных строках .log-файлов). После завершающей установку перезагрузки Х-ы не запускаются. Попытка их запуска заканчивается строкой "[OK] Reached Target Graphical Interface".

    Ключевые моменты Xorg.0.log-файла:
    Code:
    . . .
    [    19.861] (==) ServerLayout "aticonfig Layout"
    [    19.861] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
    [    19.861] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
    [    19.861] (**) |   |-->Device "aticonfig-Device[0]-0"
    [    19.861] (==) Automatically adding devices
    [    19.861] (==) Automatically enabling devices
    [    19.861] (==) Automatically adding GPU devices
    . . .
    [    19.861] (II) Module ABI versions:
    [    19.861]     X.Org ANSI C Emulation: 0.4
    [    19.861]     X.Org Video Driver: 13.1
    [    19.861]     X.Org XInput driver : 18.0
    [    19.861]     X.Org Server Extension : 7.0
    [    19.862] (II) config/udev: Adding drm device (/dev/dri/card0)
    [    20.593] (--) PCI:*(0:0:2:0) 8086:0166:17aa:3800 rev 9, Mem @ 0xd8000000/4194304, 0xc0000000/268435456, I/O @ 0x00004000/64
    [    20.593] (--) PCI: (0:1:0:0) 1002:6600:17aa:3800 rev 0, Mem @ 0xd0000000/134217728, 0xd8600000/262144, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
    [    20.593] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    . . .
    [    20.593] (II) LoadModule: "glx"
    [    20.632] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    [    20.647] (II) Module glx: vendor="Advanced Micro Devices, Inc."
    . . .
    [    20.647] (II) LoadModule: "fglrx"
    [    20.661] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
    . . .
    [    20.893] (II) Loading sub module "fglrxdrm"
    [    20.893] (II) LoadModule: "fglrxdrm"
    [    20.893] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
    . . .
    [    20.914] (++) using VT number 7
    
    [    20.914] (WW) Falling back to old probe method for fglrx
    [    20.983] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
    [    20.999] ukiDynamicMajor: found major device number 250
    [    20.999] ukiDynamicMajor: found major device number 250
    [    20.999] ukiOpenByBusid: Searching for BusID PCI:1:0:0
    [    20.999] ukiOpenDevice: node name is /dev/ati/card0
    [    20.999] ukiOpenDevice: open result is 9, (OK)
    [    21.716] ukiOpenDevice: open result is 9, (OK)
    [    21.716] ukiOpenByBusid: ukiOpenMinor returns 9
    [    21.716] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
    [    21.867] (--) Chipset Supported AMD Graphics Processor (0x6600) found
    [    21.881] (II) fglrx: intel VGA device detected, load intel driver.
    [    21.881] (II) LoadModule: "intel"
    [    21.881] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [    21.883] (II) Module intel: vendor="X.Org Foundation"
    . . .
    [    21.884] (II) fglrx(0): pEnt->device->identifier=0x1e0e4f0
    [    21.884] (II) intel(1): pEnt->device->identifier=(nil)
    [    21.884] (EE) Screen 1 deleted because of no matching config section.
    [    21.884] (II) UnloadModule: "intel"
    [    21.885] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
    [    21.885] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
    [    22.761] (II) fglrx(0): PowerXpress: Diagnostic output from /usr/lib64/fglrx/switchlibGL:
    Switch to AMD
    . . .
    [    22.824] (II) Loading sub module "fb"
    [    22.824] (II) LoadModule: "fb"
    [    22.825] (II) Loading /usr/lib64/xorg/modules/libfb.so
    [    22.825] (II) Module fb: vendor="X.Org Foundation"
    . . .
    [    22.825] (II) Loading sub module "glamoregl"
    [    22.825] (II) LoadModule: "glamoregl"
    [    22.825] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [    22.826] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    [    22.826] (II) UnloadModule: "glamoregl"
    [    22.826] (II) Unloading glamoregl
    [    22.826] (EE) fglrx: Failed to load module "glamoregl" (loader failed, 7)
    [    22.827] (WW) fglrx(0): glamor not available
    [    22.827] (II) Loading sub module "dri2"
    [    22.827] (II) LoadModule: "dri2"
    [    22.827] (II) Module "dri2" already built-in
    . . .
    [    22.827] (II) Loading sub module "fglrxdrm"
    [    22.827] (II) LoadModule: "fglrxdrm"
    [    22.827] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
    [    22.827] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
    . . .
    [    22.837] (WW) fglrx(0): board is an unknown third party board, chipset is supported
    . . .
    [    23.093] (EE) fglrx(0): Failed to open CMMQS connection.
    [    23.093] (EE) 
    [    23.094] (EE) Backtrace:
    [    23.115] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x58f946]
    [    23.115] (EE) 1: /usr/bin/Xorg (0x400000+0x1937b9) [0x5937b9]
    [    23.115] (EE) 2: /lib64/libpthread.so.0 (0x7ff5ef509000+0xf1f0) [0x7ff5ef5181f0]
    [    23.115] (EE) 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (swlDrmFreeSurfaces+0x42) [0x7ff5ecb2cc72]
    [    23.115] (EE) 4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxDriCloseScreen+0x14d) [0x7ff5eca84cbd]
    [    23.115] (EE) 5: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxDriScreenInit+0x8eb) [0x7ff5eca8435b]
    [    23.115] (EE) 6: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxScreenInit+0xf80) [0x7ff5eca7dd90]
    [    23.116] (EE) 7: /usr/bin/Xorg (AddScreen+0x85) [0x43d7d5]
    [    23.116] (EE) 8: /usr/bin/Xorg (InitOutput+0x3fa) [0x47eeaa]
    [    23.116] (EE) 9: /usr/bin/Xorg (0x400000+0x2be86) [0x42be86]
    [    23.116] (EE) 10: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7ff5ee392a15]
    [    23.116] (EE) 11: /usr/bin/Xorg (0x400000+0x2c3ad) [0x42c3ad]
    [    23.116] (EE) 
    [    23.116] (EE) Segmentation fault at address 0x8a0
    [    23.116] 
    Fatal server error:
    [    23.116] Caught signal 11 (Segmentation fault). Server aborting
    Далее, я последовала совету загрузиться с параметром "nomodeset", однако Х-ы всё равно не запустились. Xorg.0.log отличался отсутствием строки "(II) config/udev: Adding drm device (/dev/dri/card0)" перед перечислением доступных видеокарт, а также концовкой:
    Code:
    [    19.672] (--) Chipset Supported AMD Graphics Processor (0x6600) found
    [    19.675] (II) fglrx: intel VGA device detected, load intel driver.
    [    19.675] (II) LoadModule: "intel"
    [    19.675] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [    19.676] (II) Module intel: vendor="X.Org Foundation"
    [    19.676]     compiled for 1.13.1, module version = 2.20.19
    [    19.676]     Module class: X.Org Video Driver
    [    19.676]     ABI class: X.Org Video Driver, version 13.1
    [    19.677] (II) fglrx(0): pEnt->device->identifier=0xb684f0
    [    19.679] 
    Fatal server error:
    [    19.679] atiddxProbe: fail to probe intel VGA device
    [    19.679] (EE)
    Попыток запуска всего остального, в отличие от предыдущего случая, не было.

    Если удалить /etc/X11/xorg.conf, Х-ы, в принципе, запускаются на интеловской карте, но без glx и некоторых других модулей.

    После удаления fglrx-драйвера графика на встроенной карте запускается как положено.

    Если у кого-то получалось запустить видеокарту AMD в подобной системе на проприетарном драйвере, помогите, пожалуйста. Должно же оно как-то работать...

    Заранее благодарна.
    С ув., Наташа.

  2. #2
    Join Date
    Dec 2010
    Location
    Belarus
    Posts
    984

    Default Re: Настройка Intel/ATI графики

    Копайте в этом направление:
    (EE) Screen 1 deleted because of no matching config section.
    Quote Originally Posted by natasha
    Далее, я последовала совету загрузиться с параметром "nomodeset"...
    Для гибридной графики - не пойдет.

  3. #3

    Default Re: Настройка Intel/ATI графики

    А лучше вот в этом
    (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    «Если не говорить пользователям, что линукс это сложно и страшно, то им совершенно все равно, в чем не разбираться. » — ЛОР

  4. #4
    Join Date
    Dec 2010
    Location
    Belarus
    Posts
    984

    Default Re: Настройка Intel/ATI графики

    Quote Originally Posted by EGDFree View Post
    А лучше вот в этом
    Вполне нормальная реакция, если не используется драйвер от интела:
    Code:
    ldd -d /usr/lib/xorg/modules/libglamoregl.so
            linux-gate.so.1 (0xb77a6000)
            libEGL.so.1 => /usr/lib/libEGL.so.1 (0xb775e000)
            libpthread.so.0 => /lib/libpthread.so.0 (0xb7741000)
            libgbm.so.1 => /usr/lib/libgbm.so.1 (0xb7739000)
            libglamor.so.0 => /usr/lib/libglamor.so.0 (0xb76fb000)
            libc.so.6 => /lib/libc.so.6 (0xb7549000)
            libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0xb7546000)
            libX11.so.6 => /usr/lib/libX11.so.6 (0xb740b000)
            libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0xb7405000)
            libxcb-xfixes.so.0 => /usr/lib/libxcb-xfixes.so.0 (0xb73fd000)
            libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb73d9000)
            libwayland-client.so.0 => /usr/lib/libwayland-client.so.0 (0xb73ce000)
            libwayland-server.so.0 => /usr/lib/libwayland-server.so.0 (0xb73c0000)
            libudev.so.1 => /usr/lib/libudev.so.1 (0xb73ad000)
            libdl.so.2 => /lib/libdl.so.2 (0xb73a8000)
            libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb7399000)
            /lib/ld-linux.so.2 (0xb77a7000)
            libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xb7295000)
            libXau.so.6 => /usr/lib/libXau.so.6 (0xb7291000)
            libffi.so.4 => /usr/lib/libffi.so.4 (0xb728a000)
            librt.so.1 => /lib/librt.so.1 (0xb7281000)
            libselinux.so.1 => /lib/libselinux.so.1 (0xb725d000)
            libnvidia-tls.so.331.49 => /usr/lib/tls/libnvidia-tls.so.331.49 (0xb7258000)
            libnvidia-glcore.so.331.49 => /usr/lib/libnvidia-glcore.so.331.49 (0xb5013000)
            libXext.so.6 => /usr/lib/libXext.so.6 (0xb5000000)
            libpcre.so.1 => /usr/lib/libpcre.so.1 (0xb4f96000)
            libm.so.6 => /lib/libm.so.6 (0xb4f50000)
    undefined symbol: serverClient  (/usr/lib/libglamor.so.0)
    undefined symbol: RegionEmptyData       (/usr/lib/libglamor.so.0)
    undefined symbol: PictureScreenPrivateKeyRec    (/usr/lib/libglamor.so.0)
    undefined symbol: PixmapWidthPaddingInfo        (/usr/lib/libglamor.so.0)
    undefined symbol: RegionEmptyBox        (/usr/lib/libglamor.so.0)
    undefined symbol: miChangeGC    (/usr/lib/libglamor.so.0)
    undefined symbol: miCopyGC      (/usr/lib/libglamor.so.0)
    undefined symbol: miDestroyGC   (/usr/lib/libglamor.so.0)
    undefined symbol: miChangeClip  (/usr/lib/libglamor.so.0)
    undefined symbol: miDestroyClip (/usr/lib/libglamor.so.0)
    undefined symbol: miCopyClip    (/usr/lib/libglamor.so.0)
    undefined symbol: miPolyRectangle       (/usr/lib/libglamor.so.0)
    undefined symbol: miPolyArc     (/usr/lib/libglamor.so.0)
    undefined symbol: miFillPolygon (/usr/lib/libglamor.so.0)
    undefined symbol: miPolyFillArc (/usr/lib/libglamor.so.0)
    undefined symbol: miPolyText8   (/usr/lib/libglamor.so.0)
    undefined symbol: miPolyText16  (/usr/lib/libglamor.so.0)
    undefined symbol: miImageText8  (/usr/lib/libglamor.so.0)
    undefined symbol: miImageText16 (/usr/lib/libglamor.so.0)
    undefined symbol: _glapi_tls_Context    (/usr/lib/xorg/modules/libglamoregl.so)

  5. #5
    Join Date
    Mar 2014
    Location
    Dnepropetrovsk
    Posts
    105

    Default Re: Настройка Intel/ATI графики

    Добрый день!

    Спасибо за советы. Смотрю, что пишут люди по указанным ошибкам, но пока ничего полезного не видно.

    -------------------

    Есть пара промежуточных вопросов.

    1. Что такое CMMQS connection ((EE) fglrx(0): Failed to open CMMQS connection. -- в Xorg.0.log-файле перед Backtrace)?

    2. Что делает драйвер fglrx с интеловскими модулями glx и glamoregl? Поставив ATI-шный драйвер, удалив xorg.conf и отключив дискретную карту в BIOS-е, запускаю Х-ы -- в Xorg.0.log ошибки при запуске этих модулей: glx он пытается запустить тот, что от ATI, а при попытке загрузки glamoregl выдаёт ту же ошибку, на которую обратил внимание EGDFree в #3.

    Буду благодарна, если кто-то объяснит это.
    С ув., Наташа.

  6. #6
    Join Date
    Dec 2010
    Location
    Belarus
    Posts
    984

    Default Re: Настройка Intel/ATI графики

    Слишком проприетарные вопросы: что такое, что делает и т. д.
    У вас PowerXpress, а значит аналог optimus от nvidia.
    Что это значит?
    А то, что запуск иксов может быть только на одной карте, т. е. на той, которая физически подключена к дисплею ноутбука. Все остальное разруливается переменными окружениями до библиотек и соответствующей поддержкой данной технологии припроетарным драйвером. Поэтому, я бы забыл бы об установки драйвера сложным способом и установил бы из репозитория. Далее проверил, что происходит здесь:
    Code:
    grep "NO_KMS_IN_INITRD\|INITRD_MODULES" /etc/sysconfig/kernel
    - здесь:
    Code:
    grep -i fglrx /etc/modules-load.d/*
    - здесь:
    Code:
    sudo grep -is modeset /etc/default/*
    - и здесь:
    Code:
    grep -i "screen\|fglrx\|intel" /etc/X11/xorg.conf.d/*
    Что же касается glamor, то можно прочитать здесь

  7. #7
    Join Date
    Mar 2014
    Location
    Dnepropetrovsk
    Posts
    105

    Default Re: Настройка Intel/ATI графики

    Добрый день!

    Извините уж за такие вопросы. Интересно же... Спасибо за ссылку.

    Поставила драйвер из YaST2. Разницы никакой. Вот результат выполнения вышеприведенных команд:

    Code:
    > grep "NO_KMS_IN_INITRD\|INITRD_MODULES" /etc/sysconfig/kernel
    INITRD_MODULES=""
    NO_KMS_IN_INITRD="yes"
    DOMU_INITRD_MODULES="xennet xenblk"
    Code:
    > grep -i fglrx /etc/modules-load.d/*
    grep: /etc/modules-load.d/*: No such file or directory
    Code:
    # grep -is modeset /etc/default/*
    /etc/default/grub:GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    /etc/default/grub.old:GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    Code:
    > grep -i "screen\|fglrx\|intel" /etc/X11/xorg.conf.d/*
    /etc/X11/xorg.conf.d/10-evdev.conf:        Identifier "evdev touchscreen catchall"
    /etc/X11/xorg.conf.d/10-evdev.conf:        MatchIsTouchscreen "on"
    /etc/X11/xorg.conf.d/11-mouse.conf:    Identifier    "Microsoft IntelliMouse Explorer"
    /etc/X11/xorg.conf.d/11-mouse.conf:    MatchProduct    "IntelliMouse Explorer 4.0 (IntelliPoint)"
    /etc/X11/xorg.conf.d/50-screen.conf:# Having multiple "Screen" sections is known to be problematic. Make
    /etc/X11/xorg.conf.d/50-screen.conf:#Section "Screen"
    /etc/X11/xorg.conf.d/50-screen.conf:#  Identifier "Default Screen"
    /etc/X11/xorg.conf.d/99-saxdevice.conf:Driver "intel"
    /etc/X11/xorg.conf.d/99-saxdevice.conf:Driver "intel"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Section "Screen"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Identifier "SaX3-screen"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Section "Screen"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Identifier "SaX3-screen"

  8. #8
    Join Date
    Dec 2010
    Location
    Belarus
    Posts
    984

    Default Re: Настройка Intel/ATI графики

    А вот и виновники этого:
    (EE) Screen 1 deleted because of no matching config section.
    Соответственно удалить все, что выделено:
    grep -i "screen\|fglrx\|intel" /etc/X11/xorg.conf.d/*
    /etc/X11/xorg.conf.d/10-evdev.conf: Identifier "evdev touchscreen catchall"
    /etc/X11/xorg.conf.d/10-evdev.conf: MatchIsTouchscreen "on"
    /etc/X11/xorg.conf.d/11-mouse.conf: Identifier "Microsoft IntelliMouse Explorer"
    /etc/X11/xorg.conf.d/11-mouse.conf: MatchProduct "IntelliMouse Explorer 4.0 (IntelliPoint)"
    /etc/X11/xorg.conf.d/50-screen.conf:# Having multiple "Screen" sections is known to be problematic. Make
    /etc/X11/xorg.conf.d/50-screen.conf:#Section "Screen"
    /etc/X11/xorg.conf.d/50-screen.conf:# Identifier "Default Screen"
    /etc/X11/xorg.conf.d/99-saxdevice.conf:Driver "intel"
    /etc/X11/xorg.conf.d/99-saxdevice.conf:Driver "intel"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Section "Screen"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Identifier "SaX3-screen"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Section "Screen"
    /etc/X11/xorg.conf.d/99-saxscreen.conf:Identifier "SaX3-screen"
    Ну и конечно же выполнить это:
    Code:
    sudo /sbin/yast2 sysconfig set NO_KMS_IN_INITRD="no"
    Далее создайте xorg.conf, как и создавали раньше.
    Удачной загрузки.
    Last edited by Minton; 06-Nov-2014 at 13:57.

  9. #9
    Join Date
    Dec 2010
    Location
    Belarus
    Posts
    984

    Default Re: Настройка Intel/ATI графики

    Вообще удаляйте все, что связано с /etc/X11/xorg.conf.d/99-sax*.сonf.
    Там еще есть настройки монитора и т.д.

  10. #10
    Join Date
    Mar 2014
    Location
    Dnepropetrovsk
    Posts
    105

    Default Re: Настройка Intel/ATI графики

    Здравствуйте!

    Сделала то, что вы написали.

    На xorg.conf, созданном командой aticonfig --initial -f, Х-ы не запустились. Xorg.0.conf аналогичен представленному в #1.

    Но на минимальном xorg.conf-е,

    Code:
    Section "ServerLayout"
               Identifier           "Lout"
    EndSection
    графика запускается на интеловской карте, причём, если переключиться на неё как положенно,

    Code:
    # aticonfig --px-igpu
    всё запускается, как надо, в Xorg.0.log-е ошибок нет, glxinfo, glxgears, fglrxinfo дают содержательные результаты.

    Но при переключении на дискретную карту, на ней Х-ы реально не стартуют. Xorg.0.log таков

    Code:
    [   931.241] (==) ServerLayout "Lout"
    [   931.241] (==) No screen section available. Using defaults.
    [   931.241] (**) |-->Screen "Default Screen Section" (0)
    [   931.241] (**) |   |-->Monitor "<default monitor>"
    [   931.241] (==) No monitor specified for screen "Default Screen Section".
          Using a default monitor configuration.
    [   931.241] (==) Automatically adding devices
    [   931.241] (==) Automatically enabling devices
    [   931.241] (==) Automatically adding GPU devices
    
    . . .
    
    [   931.242] (II) config/udev: Adding drm device (/dev/dri/card0)
    [   931.244] (--) PCI:*(0:0:2:0) 8086:0166:17aa:3800 rev 9, Mem @ 0xd8000000/4194304, 0xc0000000/268435456, I/O @ 0x00004000/64
    [   931.244] (--) PCI: (0:1:0:0) 1002:6600:17aa:3800 rev 0, Mem @ 0xd0000000/134217728, 0xd8600000/262144, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
    [   931.244] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    
    . . . 
    
    [   931.244] (II) "glx" will be loaded by default.
    [   931.244] (II) LoadModule: "dri2"
    [   931.244] (II) Module "dri2" already built-in
    [   931.244] (II) LoadModule: "glamoregl"
    [   931.244] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [   931.245] (II) Module glamoregl: vendor="X.Org Foundation"
    [   931.245]      compiled for 1.13.2, module version = 0.5.0
    [   931.245]      ABI class: X.Org ANSI C Emulation, version 0.4
    [   931.245] (II) LoadModule: "glx"
    [   931.245] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    [   931.279] (II) Module glx: vendor="Advanced Micro Devices, Inc."
    [   931.279]      compiled for 6.9.0, module version = 1.0.0
    [   931.279] Loading extension GLX
    [   931.279] (==) Matched intel as autoconfigured driver 0
    [   931.279] (==) Matched intel as autoconfigured driver 1
    [   931.279] (==) Matched modesetting as autoconfigured driver 2
    [   931.279] (==) Matched fbdev as autoconfigured driver 3
    [   931.279] (==) Matched vesa as autoconfigured driver 4
    [   931.279] (==) Assigned the driver to the xf86ConfigLayout
    [   931.279] (II) LoadModule: "intel"
    [   931.280] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [   931.281] (II) Module intel: vendor="X.Org Foundation"
    [   931.281]      compiled for 1.13.1, module version = 2.20.19
    [   931.281]      Module class: X.Org Video Driver
    [   931.281]      ABI class: X.Org Video Driver, version 13.1
    [   931.281] (II) LoadModule: "modesetting"
    
    . . . 
    
    [   931.342] (II) Loading sub module "glamoregl"
    [   931.342] (II) LoadModule: "glamoregl"
    [   931.342] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [   931.342] (II) Module glamoregl: vendor="X.Org Foundation"
    [   931.342]      compiled for 1.13.2, module version = 0.5.0
    [   931.342]      ABI class: X.Org ANSI C Emulation, version 0.4
    [   931.342] (II) glamor: OpenGL accelerated X.org driver based.
    [   931.347] (II) glamor: EGL version 1.4 (DRI2):
    [   931.349] (II) intel(0): glamor detected, initialising egl layer.
    [   931.349] (II) Loading sub module "dri2"
    [   931.349] (II) LoadModule: "dri2"
    [   931.349] (II) Module "dri2" already built-in
    [   931.349] (II) UnloadModule: "modesetting"
    [   931.349] (II) Unloading modesetting
    
    . . . 
    
    [   931.373] (EE) GLX error: Can not get required symbols.
    
    . . .

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •