Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: openSUSE 13.1: Lots of character encoding issues

  1. #1

    Angry openSUSE 13.1: Lots of character encoding issues

    Hello,

    I have a newly installed openSUSE 13.1 with many character encoding issues.

    Example 1 - Console:
    linux@vm-os131:~/test> mkdir öäüßÖÄÜ
    linux@vm-os131:~/test> ls
    ???????

    Example 2 - Dolphin under KDE: the folder from Example 1 is displayed correctly, but when I e.g. create a file inside it and want to delete it again, I get "the file or folder xyz does not exist"

    Example 3 - Windows-Share: On a share mounted with mount.cifs even in Dolphin the special characters are not displayed, whether or not I use the paramter "iocharset=utf8".

    My Config:

    linux@vm-os131:~/test> uname -a
    Linux vm-os131 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux

    linux@vm-os131:~/test> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=

    Setting LANG to de_DE.UTF-8 makes no difference.

    Greetings
    SH

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 13.1: Lots of character encoding issues

    On 2014-03-31 13:06, SheriffHobbes wrote:
    >
    > Hello,
    >
    > I have a newly installed openSUSE 13.1 with many character encoding
    > issues.
    >
    > Example 1 - Console:
    > linux@vm-os131:~/test> mkdir öäüßÖÄÜ
    > linux@vm-os131:~/test> ls
    > ???????


    Please use code tags for printouts and commands (the '#' button in the
    forum editor). See photo

    It makes things easier to read, and some times it is critical, the forum
    software can make important alterations to the text otherwise.

    Code:
    Example 1 - Console:
    linux@vm-os131:~/test> mkdir öäüßÖÄÜ
    linux@vm-os131:~/test> ls
    ???????
    Are you using a virtual machine? If so, what type, what host?

    What filesystem are you using on Linux, on that "test" directory?

    What options did you choose for the installation?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3

    Default Re: openSUSE 13.1: Lots of character encoding issues

    Sorry for not using the code tags.

    Are you using a virtual machine? If so, what type, what host?
    Yes. I've seen the same issue on Win2012R2 Hyper-V and VMware Workstation 8. What do you mean by host? I don't think the underlying hardware the VM runs on can make any difference.

    What filesystem are you using on Linux, on that "test" directory?
    The default that was offered during installation: ext4.

    What options did you choose for the installation?
    I chose a standard installation with KDE (no Gnome), German keyboard, everything else en_US.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 13.1: Lots of character encoding issues

    On 2014-03-31 14:06, SheriffHobbes wrote:
    >
    > Sorry for not using the code tags.


    No, it is common for newcommers not to know about this, so we have to
    tell them :-)


    >> Are you using a virtual machine? If so, what type, what host?

    >
    > Yes. I've seen the same issue on Win2012R2 Hyper-V and VMware
    > Workstation 8. What do you mean by host? I don't think the underlying
    > hardware the VM runs on can make any difference.


    It should not, but maybe it does. Yours is a strange problem, I don't
    know (yet?) what could cause it.

    On vmware, the default is autoinstallation controlled by vmware. I
    recommend to deselect that, when creating the virtual machine, and tell
    it you will do the installation yourself, later. The problem is that it
    uses what I think is an obsolete or wrong autoyast profile.


    >> What filesystem are you using on Linux, on that "test" directory?

    >
    > The default that was offered during installation: ext4.


    Then that's not the cause.

    >> What options did you choose for the installation?

    >
    > I chose a standard installation with KDE (no Gnome), German keyboard,
    > everything else en_US.


    Did you verify the checksum of the installation ISO image you downloaded?

    As you are using a virtual machine, did you do the installation using
    the ISO file directly, or did you burn the DVD? In the second case, boot
    the DVD and select the entry for media self verification. If you used an
    USB stick, then you can not.

    Did you deselect packages?

    Did the installation report problems with any package?

    Did you add extra repositories?

    Did you run "yast online update"? If not, please do and allow it to
    complete all the updates it wants.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,798

    Default Re: openSUSE 13.1: Lots of character encoding issues

    Code:
    henk@boven:~/test> mkdir öäüßÖÄÜ
    henk@boven:~/test> l
    totaal 120
    drwxr-xr-x  5 henk wij  4096 31 mrt 17:29 ./
    drwxr-xr-x 84 henk wij  4096 31 mrt 17:24 ../
    drwxr--r--  2 henk wij  4096 13 jul  2013 bestanden/
    -rw-r--r--  1 henk wij    21  8 jul  2013 file
    drwxr-xr-x  2 henk wij  4096 31 mrt 17:29 öäüßÖÄÜ/
    -rw-------  1 henk wij     3 31 mrt  2013 spsp
    -rw-r--r--  1 henk wij   805 10 dec 11:50 stderr
    -rw-r--r--  1 henk wij 87874 10 dec 11:50 stdout
    drwxr-xr-x  2 henk wij  4096  8 jul  2013 wdir/
    henk@boven:~/test> cd öäüßÖÄÜ/
    henk@boven:~/test/öäüßÖÄÜ> touch aap
    henk@boven:~/test/öäüßÖÄÜ> l
    totaal 8
    drwxr-xr-x 2 henk wij 4096 31 mrt 17:30 ./
    drwxr-xr-x 5 henk wij 4096 31 mrt 17:29 ../
    -rw-r--r-- 1 henk wij    0 31 mrt 17:30 aap
    henk@boven:~/test/öäüßÖÄÜ>
    So, works correct here.
    Henk van Velden

  6. #6
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: openSUSE 13.1: Lots of character encoding issues

    Quote Originally Posted by SheriffHobbes View Post
    Code:
    linux@vm-os131:~/test> uname -a
    Linux vm-os131 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux
    
    linux@vm-os131:~/test> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    This locale does not exist. It should be en_US.utf8.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,798

    Default Re: openSUSE 13.1: Lots of character encoding issues

    Quote Originally Posted by arvidjaar View Post
    This locale does not exist. It should be en_US.utf8.
    ????

    As root
    Code:
    boven:~ # locale
    LANG=POSIX
    LC_CTYPE=en_US.UTF-8
    LC_NUMERIC="POSIX"
    LC_TIME="POSIX"
    LC_COLLATE="POSIX"
    LC_MONETARY="POSIX"
    LC_MESSAGES="POSIX"
    LC_PAPER="POSIX"
    LC_NAME="POSIX"
    LC_ADDRESS="POSIX"
    LC_TELEPHONE="POSIX"
    LC_MEASUREMENT="POSIX"
    LC_IDENTIFICATION="POSIX"
    LC_ALL=
    boven:~ #
    as user:
    Code:
    henk@boven:~> locale
    LANG=nl_NL.UTF-8
    LC_CTYPE="nl_NL.UTF-8"
    LC_NUMERIC="nl_NL.UTF-8"
    LC_TIME="nl_NL.UTF-8"
    LC_COLLATE="nl_NL.UTF-8"
    LC_MONETARY="nl_NL.UTF-8"
    LC_MESSAGES="nl_NL.UTF-8"
    LC_PAPER="nl_NL.UTF-8"
    LC_NAME="nl_NL.UTF-8"
    LC_ADDRESS="nl_NL.UTF-8"
    LC_TELEPHONE="nl_NL.UTF-8"
    LC_MEASUREMENT="nl_NL.UTF-8"
    LC_IDENTIFICATION="nl_NL.UTF-8"
    LC_ALL=
    henk@boven:~>
    Full of UTF-8. And I did not do anything imho to change it to this manualy.
    Henk van Velden

  8. #8
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: openSUSE 13.1: Lots of character encoding issues

    Quote Originally Posted by hcvv View Post
    ????
    You are right, I made a typo when testing (there is no locale directory with this name but IIRC it is mapped internally).

    Still symptoms are similar - may be looking under /usr/lib/locale and using one of exact names for a test?

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 13.1: Lots of character encoding issues

    On 2014-03-31 18:46, arvidjaar wrote:
    >
    > SheriffHobbes;2634147 Wrote:
    >>>

    > Code:
    > --------------------
    > > >

    > > linux@vm-os131:~/test> uname -a
    > > Linux vm-os131 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux
    > >
    > > linux@vm-os131:~/test> locale
    > > LANG=en_US.UTF-8
    > > LC_CTYPE="en_US.UTF-8"

    > --------------------
    >>>

    >
    > This locale does not exist. It should be en_US.utf8.


    Code:
    cer@Telcontar:~> mkdir öäüßÖÄÜ
    cer@Telcontar:~> cd öäüßÖÄÜ
    cer@Telcontar:~/öäüßÖÄÜ> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC=es_ES@euro
    LC_TIME=en_DK.UTF-8
    LC_COLLATE=POSIX
    LC_MONETARY=es_ES@euro
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER=es_ES@euro
    LC_NAME=es_ES@euro
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE=es_ES@euro
    LC_MEASUREMENT=es_ES@euro
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    cer@Telcontar:~/öäüßÖÄÜ>
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  10. #10

    Default Re: openSUSE 13.1: Lots of character encoding issues

    @Carlos: I always do manual installation, never auto. I installed from ISO, but checked for correct md5sum first. I didn't deselect packages, only added a few. No errors from the installer. I ran zypper update, it upgraded several hundred packages - no change.

    @Henk: I have the same locals for root, the same as user if you change nl_NL for en_US (or de_DE, which makes no difference).

    Another strange thing:
    Code:
    linux@vm-os131:~/test> cd öäüßÖÄÜ/
    linux@vm-os131:~/test/öäüßÖÄÜ> ls ..
    ???????

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •