Results 1 to 6 of 6

Thread: Updates that i don't need on software that doesn't exist

  1. #1
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    393

    Default Updates that i don't need on software that doesn't exist

    Hi!
    I'm ask to install new updates for software that is NOT installed.
    - openSUSE-2014-256 - MozillaFirefox: Update to version 28.0
    - virtualbox-guest-kmp-desktop - 4.2.18_k3.11.10_7-2.9.1
    - virtualbox-host-kmp-desktop - 4.2.18_k3.11.10_7-2.9.1

    Software that IS installed is:
    - firefox-esr - 24.4.0-1.1
    - virtualbox-guest-kmp-desktop - 4.3.8-111.1
    - virtualbox-host-kmp-desktop - 4.3.8-111.1

    How can i remove updates to software that is not installed?

    OpenSUSE 13.1 64bits KDE

  2. #2

    Default Re: Updates that i don't need on software that doesn't exist

    Quote Originally Posted by ronnys View Post
    How can i remove updates to software that is not installed?
    Enter YaST->Online Updates, right-click on the corresponding updates on the left side and choose "Taboo - Never install".

    Btw, you don't need virtualbox-guest-kmp-desktop at all. You could just uninstall that completely, it is only used when openSUSE is running as guest in VirtualBox (as the name implies).

  3. #3
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    393

    Default Re: Updates that i don't need on software that doesn't exist

    Ok thanks!
    Just one problem; The virtualbox 4.2.xxx don't exist in Yast Online Updates. It don't exist at all. I'm think maybe this version was installed from downloaded rpm-file and not from the repository.
    How do i scan and remove in terminal?

    RS

    Quote Originally Posted by wolfi323 View Post
    Enter YaST->Online Updates, right-click on the corresponding updates on the left side and choose "Taboo - Never install".

    Btw, you don't need virtualbox-guest-kmp-desktop at all. You could just uninstall that completely, it is only used when openSUSE is running as guest in VirtualBox (as the name implies).

  4. #4

    Default Re: Updates that i don't need on software that doesn't exist

    Quote Originally Posted by ronnys View Post
    Ok thanks!
    Just one problem; The virtualbox 4.2.xxx don't exist in Yast Online Updates. It don't exist at all. I'm think maybe this version was installed from downloaded rpm-file and not from the repository.
    How do i scan and remove in terminal?
    But if vitualbox 4.2.18 is offered you as online update, it _has_ to exist somewhere in your repos.

    And in fact openSUSE 13.1 comes with virtualbox-4.2.18 and has an update available, which should show in YaST->Online Update (maybe you have to switch to "All Updates" to see it).

    OTOH, if you have virtualbox-4.3.8 installed, this update shouldn't be shown at all.
    Maybe you should just add the Virtualization repo (this contains virtualbox-4.3.8)?
    You can find it in YaST->Software Repositories->Add->Community Repositories.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates that i don't need on software that doesn't exist

    On 2014-03-31 08:56, ronnys wrote:
    >
    > Hi!
    > I'm ask to install new updates for software that is NOT installed.


    Probably because you have installed previously a pattern that includes
    those things. Even if you remove some component, the pattern still lists
    all.

    That's one reason.

    Another reason can be that you installed things from an extra repo for
    things that are on the official channels with different versions. Online
    update will offer updates to the versions it sees, even if lower than
    the ones you have installed, because the update channel has higher
    priority (no, I don't mean repo priority. I mean because they are
    "patches").

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Updates that i don't need on software that doesn't exist

    Quote Originally Posted by ronnys View Post
    Hi!
    I'm ask to install new updates for software that is NOT installed.
    - openSUSE-2014-256 - MozillaFirefox: Update to version 28.0
    Check that again, and check the components. Although it said MozillaFirefox 28.0, I think it was actually offering you the latest NSS (Network Security Services) and CA certificates, not actually Firefox 28.0, as it implies.

    I also run the ESRs, and I saw the same updates, checked them, and they were as I just stated. I installed the updates, still running the ESR for Firefox & Thunderbird.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •