Results 1 to 8 of 8

Thread: apcupsd configuring

  1. #1

    Default apcupsd configuring

    Hello,

    Trying to get the apcupsd working on 13.1 and Back-UPS NS 1080 with a USb connection. Looked at the manual on Source Forge and found that the manual there does not match what SuSE 13.1 has in the way of directories. Is there another configuration manual I should be using?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,262
    Blog Entries
    1

    Default Re: apcupsd configuring

    Quote Originally Posted by svetter88 View Post
    Hello,

    Trying to get the apcupsd working on 13.1 and Back-UPS NS 1080 with a USb connection. Looked at the manual on Source Forge and found that the manual there does not match what SuSE 13.1 has in the way of directories. Is there another configuration manual I should be using?
    This of any help?

    https://forums.opensuse.org/showthre...or-not-working

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,480
    Blog Entries
    3

    Default Re: apcupsd configuring

    Quote Originally Posted by svetter88 View Post
    Hello,

    Trying to get the apcupsd working on 13.1 and Back-UPS NS 1080 with a USb connection. Looked at the manual on Source Forge and found that the manual there does not match what SuSE 13.1 has in the way of directories. Is there another configuration manual I should be using?
    In directory "/etc/apcupsd", I edited the file "apcupsd.conf"

    Here are my changes ("diff -u" format):
    Code:
    @@ -26,7 +26,7 @@
     #     940-1524C, 940-0024G, 940-0095A, 940-0095B,
     #     940-0095C, M-04-02-2000
     #
    -UPSCABLE smart
    +UPSCABLE usb
     
     # To get apcupsd to work, in addition to defining the cable
     # above, you must also define a UPSTYPE, which corresponds to
    @@ -76,8 +76,8 @@
     #                            3052. If this parameter is empty or missing, the 
     #                            default of 3052 will be used.
     #
    -UPSTYPE apcsmart
    -DEVICE /dev/ttyS0
    +UPSTYPE usb
    +#DEVICE /dev/ttyS0
     
     # POLLTIME <int>
     #   Interval (in seconds) at which apcupsd polls the UPS for status. This
    And then, as best I can recall, I used:
    Code:
    # systemctl enable apcupsd.service
    # systemctl start aptcupsd.service
    and everything has been working fine. I do have to start the GUI (via KDE startup & shutdown)
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: apcupsd configuring

    Quote Originally Posted by deano_ferrari View Post


    A good start! Thank you.

  5. #5

    Default Re: apcupsd configuring

    Thank you for this. Got the service started and now on to see what happens on the display. All this would have been nice if I had the replaced UPS unit connected but alas it's relegated to someone else.

    Scott

  6. #6

    Default Re: apcupsd configuring

    OK I think we are getting there. The active monitors display shows the UPS. Under preferences it shows the following which I don't think is right:

    (I would post a snapshot but can't figure out how to do it) So, on the gapcmon display, under Preferenceses, I have a line that states:

    Enabled (Checked), Use TrayIcon (Unchecked), Network Refreash (8.0), Port (3551), graph Refreash (30), Rated Wattage (600), Host Name or IP Address (lolcalhost).

    Would think that the Port and Host Name should be different. Correct?

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,480
    Blog Entries
    3

    Default Re: apcupsd configuring

    Quote Originally Posted by svetter88 View Post
    OK I think we are getting there. The active monitors display shows the UPS. Under preferences it shows the following which I don't think is right:

    (I would post a snapshot but can't figure out how to do it) So, on the gapcmon display, under Preferenceses, I have a line that states:

    Enabled (Checked), Use TrayIcon (Unchecked), Network Refreash (8.0), Port (3551), graph Refreash (30), Rated Wattage (600), Host Name or IP Address (lolcalhost).

    Would think that the Port and Host Name should be different. Correct?
    That's almost exactly what I have, except "Use TrayIcon" is checked. And I also checked the box "Use Tray Icon" lower on that screen.

    With that, I have two tray icons. One is for the general monitor, and the other for the specific APC that is being monitored. The "apcupsd" daemon is listening on localhost, and the GUI monitor is periodically connecting to get info. That's where the "localhost" comes in.

    Clicking on the tray icon either opens or closes a window. The close button on the window should be avoided, as that shuts down the gui monitor. So hide it in the tray by clicking the tray icon.

    Mostly, I position the mouse over the tray icon to get info in a popup.

    Additionally, the KDE power manager seems to recognize the UPS. And I think you don't need to run either "apcupsd" or the GUI monitor for KDE to recognize it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: apcupsd configuring

    OK cool! I'm happy now. Thank you for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •