Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: No sound in 13.2 milestone 0 KDE 32-bit on X41

  1. #1
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    502

    Default No sound in 13.2 milestone 0 KDE 32-bit on X41

    I installed openSUSE 13.2 milestone 0 KDE 32-bit, DVD iso burned to a USB stick. Formatted /, reused /home from 13.1. So far, I cannot get sound working correctly. This test system is an IBM ThinkPad X41. Multimedia works well on this system with openSUSE 13.1 running from a different partition. Integrated sound is identified as:
    Code:
    82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
    Configured as sound card number 0
    Driver snd-intel8x0
    The sound card was not configured automatically during installation. I did that manually. While in the YaST Sound Configuration module, right after configuring the card, the test sound is audible. If I exit the YaST Sound Configuration module then start it again, test sound is not heard. KDE Mixer shows "No playback devices".

    In the KDE Audio and Video Settings, Audio Hardware Setup shows no sound card or sound device. Pavu Output Devices tab shows only "Dummy Output".

    I tried playing test sounds, mp3 and midi files, and streaming audio. Nothing is heard. I set up multimedia using the same procedure as 13.1, but with Factory repositories.

    Any ideas what is happening?
    Thanks,
    Howard

  2. #2

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    On Sun, 30 Mar 2014 05:06:01 GMT
    crmrhm <crmrhm@no-mx.forums.opensuse.org> wrote:

    > The sound card was not configured automatically during installation. I
    > did that manually. While in the YaST Sound Configuration module, right
    > after configuring the card, the test sound is audible. If I exit the
    > YaST Sound Configuration module then start it again, test sound is not
    > heard. KDE Mixer shows "No playback devices".


    I had the same trouble on this machine. However, after rebooting, it
    worked again and the fault hasn't reappeared. Yet. Mind you, I have to
    adjust the volume for the two input channels even though one is not
    physically connected. Curious.


    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 13.2-m0 (64-bit); KDE 4.12.2; AMD Phenom II X2 550 Processor;
    Kernel: 3.14.0-rc5; Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA)

  3. #3
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    502

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by Cloddy View Post
    after rebooting, it worked again and the fault hasn't reappeared. Yet.
    Rebooting did not noticeably accomplish anything. Oddly, in pavu "Input Devices" tab, Built-in Analog Audio Stereo is shown, and the input meter responds to sound at the microphone. Yet "Output Devices" tab still shows only Dummy Output.
    Howard

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by crmrhm View Post
    While in the YaST Sound Configuration module, right after configuring the card, the test sound is audible. If I exit the YaST Sound Configuration module then start it again, test sound is not heard.
    This could be the symptom of a permissions issue.

    Try adding your regular user to group audio, and then reboot and test.

  5. #5
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    502

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by oldcpu View Post
    This could be the symptom of a permissions issue.

    Try adding your regular user to group audio, and then reboot and test.
    I did that, but it made no difference.

    In the YaST Sound Configuration module, when I delete the card then add it again, the test sound is audible. If I exit the YaST Sound Configuration module then start it again, test sound is not heard. KDE Mixer shows "No playback devices". No sound from any application.

    Again, for pavu "Input Devices" tab, Built-in Analog Audio Stereo is shown, and the input meter responds to sound at the microphone. Yet "Output Devices" tab still shows only Dummy Output.

    Howard

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by crmrhm View Post
    Again, for pavu "Input Devices" tab, Built-in Analog Audio Stereo is shown, and the input meter responds to sound at the microphone. Yet "Output Devices" tab still shows only Dummy Output.
    What is selected in the pavucontrol configuration tab ? Is there a selection in the pavucontrol configuration tab for analog stereo (or something other than dummy output).

    Assuming you followed same systemic approach for installing 13.2 m0 as you did for 13.1, I would recommend you write a bug report on 13.2 m0.

  7. #7
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    502

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by oldcpu View Post
    What is selected in the pavucontrol configuration tab? Is there a selection in the pavucontrol configuration tab for analog stereo (or something other than dummy output)?
    The pavucontrol configuration tab shows Built-in Audio, no other options. Profile is Analog Stereo Duplex. Input Devices tab has Built-in Audio Analog Stereo. Output Devices tab has Dummy Output.

    Assuming you followed same systemic approach for installing 13.2 m0 as you did for 13.1, I would recommend you write a bug report on 13.2 m0.
    Bug report is at https://bugzilla.novell.com/show_bug.cgi?id=871288

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by crmrhm View Post
    Thanks for reporting.

    I haven't usually done much with multimedia testing this early in the cycle. But, after seeing your post, I took a look.

    I used Yast to look at the sound configuration. It was unconfigured. So I told it to use the defaults. Then I asked it to play a test sound. The sound was fine.

    Next, I rebooted. I started Yast again. It now showed the sound as configured. But a test sound gave silence.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Quote Originally Posted by crmrhm View Post
    The pavucontrol configuration tab shows Built-in Audio, no other options. Profile is Analog Stereo Duplex. Input Devices tab has Built-in Audio Analog Stereo. Output Devices tab has Dummy Output.

    Bug report is at https://bugzilla.novell.com/show_bug.cgi?id=871288
    Thanks for raising the bug report. Please note there is an answer to your bug report there, with a request for more information to be provided by you.

    As an aside - you are getting top notch attention in that bug report. The person replying is one of the alsa sound driver developers.

    Good luck, and thank you for participating in our forum.

  10. #10
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    502

    Default Re: No sound in 13.2 milestone 0 KDE 32-bit on X41

    Takashi Iwai identified the problem.
    13.2M0 contains the old alsa package that includes a known bug. Maybe you hit it. Try to upgrade libasound2.rpm from FACTORY.
    That fixed it. I upgraded libasound2 from 1.0.27.2-10.1 to 1.0.27.2-12.1 using repository http://download.opensuse.org/factory/repo/oss/.

    Now, there is sound from YaST and KMix test sounds, mp3 files with Kaffeine and VLC, and streaming audio in Firefox. KMix shows Built-in Audio Analog Stereo as Playback Device, rather than Dummy Output.

    There is still no sound from audacious playing midi files (works in 13.1), but that may be some setting in audacious that needs adjusting.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •