Hello everyone,

I've just installed hostapd on my openSUSE 13.1 x64 laptop. But it won't start:

Code:
~# hostapd ./hostapd.conf
Configuration file: /home/<my name>/hostapd.conf
nl80211: Failed to set interface wlp3s0 into AP mode
nl80211 driver initialization failed.
I found somewhere else that the driver initialization failure was due to NetworkManager, so I killed that process then ran hostapd again. Then it seems hostapd has launched successfully:

Code:
~# hostapd ./hostapd.conf
Configuration file: /home/<my name>/hostapd.conf
Using interface wlp3s0 with hwaddr <WiFi MAC Address> and ssid "hostapd"
But when I tried to connect my Android 4.3 smartphone, it simply won't get an IP address, just showing "Obtaining IP Address ...". And my laptop ended showing

Code:
wlp3s0: STA b4:52:7e:67:d6:93 WPA: pairwise key handshake completed (RSN)
then after a while
Code:
wlp3s0: AP-STA-DISCONNECTED b4:52:7e:67:d6:93
wlp3s0: STA b4:52:7e:67:d6:93 IEEE 802.11: disassociated
wlp3s0: STA b4:52:7e:67:d6:93 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
(PS: There is no problem with authentication, because when I enter wrong key, the smartphone shows that it gets "Authentication problem".)

The following is my hostapd.conf

PHP Code:
interface=wlp3s0
driver
=nl80211
ssid
=hostapd
channel
=11
hw_mode
=g
auth_algs
=1
ignore_broadcast_ssid
=0
wpa
=2
wpa_passphrase
=11223344
wpa_key_mgmt
=WPA-PSK
wpa_pairwise
=TKIP
rsn_pairwise
=CCMP 
I'd appreciate it if anyone can help me with a solution. Thanks in advance!