Results 1 to 8 of 8

Thread: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhan clone DVB-S PCI card

  1. #1

    Default no boot after live upgrade 12.3->13.1 - bttv hang on Twinhan clone DVB-S PCI card

    Did a live upgrade from an up-to-date 12.3 to 13.1 following the instructions here

    http://en.opensuse.org/SDB:System_upgrade

    exactly.

    On first re-boot, it hangs on Plymouth screen.

    On a recovery re-boot, dmesg output stops on a bttv line after finding my Twinhan DVB-S CI clone card (Skystar 1 CI 113).


    Seems bttv is broken in 13.1 - is that right ? Do I have to remove the card ?


    My system is AMD x86_64 Athlon X2 64. I was using Gnome desktop in 12.3.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhanclone DVB-S PCI card

    On 2014-03-28 21:56, bergrat wrote:

    > Seems bttv is broken in 13.1 - is that right ?


    Dunno.

    > Do I have to remove the
    > card ?


    Or block that module from loading.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhanclone DVB-S PCI card

    Quote Originally Posted by robin_listas View Post
    On 2014-03-28 21:56, bergrat wrote:

    > Do I have to remove the
    > card ?


    Or block that module from loading.
    Even in the recovery mode offered in the boot menu, the machine no longer boots to a prompt or desktop, so how you alter files in the filesystem to achieve this workaround is not obvious to a non-expert user.

    I used to know how to boot it single-user and then mount the filesystem, but I forgot that over a year ago - the last time I needed to know all that sysadmin stuff.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhanclone DVB-S PCI card

    On 2014-03-29 00:26, bergrat wrote:

    > Even in the recovery mode offered in the boot menu, the machine no
    > longer boots to a prompt or desktop, so how you alter files in the
    > filesystem to achieve this workaround is not obvious to a non-expert
    > user.



    You could try "nomodule" in the kernel boot line, which you access on
    grub2 by pressing "e".

    Hum, no, it is not "nomodule", that blocks every module :-?

    I think it is "brokenmodules=...", but I can't locate the doc.

    Try that. If the module is "bttv", try "brokenmodules=bttv"


    You should have a live cd or usb for rescue work, too.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhan clone DVB-S PCI card

    many thanks Carlos.

    I took the card out and have moved on to the next fault which prevents my upgraded 13.1 from booting

    So much for live upgrades being officially supported

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhanclone DVB-S PCI card

    On 2014-03-29 13:36, bergrat wrote:
    >
    > many thanks Carlos.
    >
    > I took the card out and have moved on to the next fault which prevents
    > my upgraded 13.1 from booting


    what is that new problem?

    > So much for live upgrades being officially supported


    Well, they are, but it is a best effort. Did you test your machine with
    13.1 before upgrading? I always do. I have a small partition where I
    install the new system to try out if things work. Only when it works, I
    attempt the upgrade of the main system.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhanclone DVB-S PCI card

    Quote Originally Posted by robin_listas View Post
    On 2014-03-29 13:36, bergrat wrote:
    >
    > many thanks Carlos.
    >
    > I took the card out and have moved on to the next fault which prevents
    > my upgraded 13.1 from booting


    what is that new problem?
    I have kept it as a separate post. It looks like the upgrade has trashed my Gnome config.

    Quote Originally Posted by robin_listas View Post
    On 2014-03-29 13:36, bergrat wrote:

    So much for live upgrades being officially supported
    Quote Originally Posted by robin_listas View Post


    Quote Originally Posted by robin_listas View Post

    Well, they are, but it is a best effort. Did you test your machine with
    13.1 before upgrading?
    No. I read "officially supported", followed the instructions and expected it to work with only minor reconfiguration. My disaster plan was to boot a really dead system from another medium and mount /home to get my valuable stuff back.

    FWIW, there are bugs filed on 13.1 about bttv, so it has problems.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: no boot after live upgrade 12.3->13.1 - bttv hang on Twinhanclone DVB-S PCI card

    On 2014-03-29 14:26, bergrat wrote:
    >
    > robin_listas;2633783 Wrote:



    >> what is that new problem?
    >>

    >
    > I have kept it as a separate post. It looks like the upgrade has trashed
    > my Gnome config.


    Yes, found it after posting this, and answered there.


    >>> Well, they are, but it is a best effort. Did you test your machine with
    >>> 13.1 before upgrading? > >

    >
    > No. I read "officially supported", followed the instructions and
    > expected it to work with only minor reconfiguration. My disaster plan
    > was to boot a really dead system from another medium and mount /home to
    > get my valuable stuff back.


    It is officially supported. But somewhere it says or said that "it was a
    best effort". There are no guarantees, it can fail. The support means
    that they work on it, expect it to work, and if it fails, they will
    listen to bug reports.

    > FWIW, there are bugs filed on 13.1 about bttv, so it has problems.


    I thought so. I don't have currently any similar hardware, so I don't
    track it, but I thought I had heard of some problems.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •