Results 1 to 5 of 5

Thread: update keuze

  1. #1

    Default update keuze

    Soms is de keuze wel te maken en ook wel eens niet.bv dit update conflict

    libavfilter3-2.1.4-1.3.x86_64 vereist libavutil52 = 2.1.4, Maar aan deze eis kan niet voldaan worden
    verwijderde leveranciers: libavutil52-2.1.4-1.3.x86_64
    [ ] deïnstallatie van libavfilter3-2.1.4-1.3.x86_64


    [ ] De volgende acties zullen uitgevoerd worden:
    libavutil52-2.2-1.1.x86_64 niet installeren
    libavdevice55-2.2-1.1.x86_64 niet installeren
    libavcodec55-2.2-1.1.x86_64 niet installeren
    libswresample0-2.2-1.1.x86_64 niet installeren
    libswscale2-2.2-1.1.x86_64 niet installeren


    [ ] breek libavfilter3-2.1.4-1.3.x86_64 door enige van zijn afhankelijkheden te negeren

    Geen idee welke keuze hier het beste is kan wel een gok doen maar wil wel graag weten wat ik doe dus wie weet raad?
    Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz Systeem -Totaal aan geheugen (RAM):7,7 GiB

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: update keuze

    Quote Originally Posted by pieter1602 View Post
    Soms is de keuze wel te maken en ook wel eens niet.bv dit update conflict

    libavfilter3-2.1.4-1.3.x86_64 vereist libavutil52 = 2.1.4, Maar aan deze eis kan niet voldaan worden
    verwijderde leveranciers: libavutil52-2.1.4-1.3.x86_64
    [ ] deïnstallatie van libavfilter3-2.1.4-1.3.x86_64


    [ ] De volgende acties zullen uitgevoerd worden:
    libavutil52-2.2-1.1.x86_64 niet installeren
    libavdevice55-2.2-1.1.x86_64 niet installeren
    libavcodec55-2.2-1.1.x86_64 niet installeren
    libswresample0-2.2-1.1.x86_64 niet installeren
    libswscale2-2.2-1.1.x86_64 niet installeren


    [ ] breek libavfilter3-2.1.4-1.3.x86_64 door enige van zijn afhankelijkheden te negeren

    Geen idee welke keuze hier het beste is kan wel een gok doen maar wil wel graag weten wat ik doe dus wie weet raad?
    Dit zijn volgens mij allemaal ffmpeg afhankelijkheden. Wat wel eens gebeurt is dat het bouwen, m.n. het publiceren van alle afhankelijke pakketten nog niet helemaal klaar is. Als je 't dan een paar uur later weer probeert is de missende versie ook gebouwd en gepubliceerd, en verdwijnt het conflict.
    Maar, wat in het geval van de libav* pakketten ook nog wel eens voorkomt, is dat er bijv. nog een update beschikbaar is voor libavutil52, terwijl je eigenlijk zou moeten overstappen naar libavutil54. En dat is dan niet iets wat ik uit documentatie/publicaties haal, maar meer iets dat ik geconstateerd heb / meen te hebben.
    Kun je 's output posten van
    Code:
    rpm -qa | grep libav
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: update keuze

    Code:
    pieter1602@linux-rj1b:~> rpm -qa | grep libav
    libavahi-core7-0.6.31-16.6.1.x86_64
    libavcodec55-2.1.4-1.3.x86_64
    libavfilter2-1.0.9-1.3.x86_64
    libavfilter1-0.7.16-3.2.x86_64
    libavresample1-2.1.4-1.3.x86_64
    libavahi-client3-0.6.31-16.6.1.x86_64
    libavutil50-0.7.16-3.2.x86_64
    libavformat55-2.1.4-1.3.x86_64
    libavdevice55-2.1.4-1.3.x86_64
    libavutil52-2.1.4-1.3.x86_64
    libavcodec54-1.0.9-1.3.x86_64
    libavahi-glib1-0.6.31-16.6.1.x86_64
    libavresample0-1.0.9-1.3.x86_64
    libavfilter3-2.1.4-1.3.x86_64
    libavutil51-1.0.9-1.3.x86_64
    libavformat54-1.0.9-1.3.x86_64
    libavcodec52-0.7.16-3.2.x86_64
    libavahi-common3-0.6.31-16.6.1.x86_64
    libavformat52-0.7.16-3.2.x86_64
    pieter1602@linux-rj1b:~>
    verstappen naar libavutil54
    Die zou dus in het rijtje moeten staan?
    Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz Systeem -Totaal aan geheugen (RAM):7,7 GiB

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: update keuze

    [ ] deïnstallatie van libavfilter3-2.1.4-1.3.x86_64 moet je hebben. Kwam dezelfde tegen op de laptop van wederhelft.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: update keuze

    Gedaaan bedankt!.
    Wat trouwens wel opviel is als je
    Code:
    zypper ref && zypper up
    dan word er wel gewoon geupdate zonder conflict melding.
    En als je dan in yast weer goed updaten kom je dit conflict weer tegen.
    Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz Systeem -Totaal aan geheugen (RAM):7,7 GiB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •