Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: How do I disable automatic updates?

  1. #11

    Default Re: [SOLVED] How do I disable automatic updates?

    Quote Originally Posted by jimoe666 View Post
    That is not my experience.

    The updates are downloaded which is the reason for my quest to disable this update app. We have only a basic DSL connection and having each computer retrieving multi-megabyte updates whenever they feel like it impacts our actual work. I can use zypper to check and perform updates at off-peak times; I cannot control the PackageKit apps this way.
    As I said, I don't use GNOME.
    But on my KDE Apper/PackageKit has NEVER downloaded a package by itself.
    It does of course refresh the repos (and therefore downloads the repo metadata) periodically.

    There _is_ a setting to automatically install updates, or automatically download (but not install) updates, but those are OFF by default.

    I don't think that gnome-packagekit behaves different regarding this, but I don't know for sure.
    So I just ran gpk-update-viewer, and it really did NOT download any package, it just showed me that an update was available. And I don't find any setting for automatic downloading/installing there either.

  2. #12
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How do I disable automatic updates?

    Am 25.03.2014 20:16, schrieb wolfi323:
    > There _is_ a setting to automatically install updates, or automatically
    > download (but not install) updates, but those are OFF by default.


    That is simply not true for Gnome. It downloads automatically by default
    (though it does not perform the update).
    I see that on two Gnome systems, myself using KDE where it is different.

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500

  3. #13
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How do I disable automatic updates?

    Looks as if one can disable auto download with dconf-editor
    http://worldofgnome.org/fedora-20-gn...ps-and-tricks/

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500

  4. #14

    Default Re: How do I disable automatic updates?

    Quote Originally Posted by martin_helm View Post
    Am 25.03.2014 20:16, schrieb wolfi323:
    > There _is_ a setting to automatically install updates, or automatically
    > download (but not install) updates, but those are OFF by default.


    That is simply not true for Gnome. It downloads automatically by default
    (though it does not perform the update).
    I see that on two Gnome systems, myself using KDE where it is different.
    Yes, that was about Apper, I know there's no such setting in gpk-prefs.

    Hm, does GNOME then have a different update applet built-in (like with NetworkManager)?
    As I said, I ran gpk-update-viewer (from gnome-packagekit), and it didn't download packages either until I clicked on "Install Updates".

  5. #15
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How do I disable automatic updates?

    Am 25.03.2014 20:46, schrieb wolfi323:
    > Hm, does GNOME then have a different update applet built-in (like
    > with NetworkManager)? As I said, I ran gpk-update-viewer (from
    > gnome-packagekit), and it didn't download packages either until I
    > clicked on "Install Updates".
    >

    That shows exactly nothing as you started it manually, looking
    dconf-editor now it is set to enable the auto download and that is the
    default it came with.
    Let's see how it behaves I set now all to 1 week (4 settings) and
    disable automatic download.

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500

  6. #16
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How do I disable automatic updates?

    On 2014-03-25 19:16, wolfi323 wrote:
    >
    > jimoe666;2632943 Wrote:
    >> I looked into this. If I tag PackageKit for removal, a large number of
    >> Gnome utilities are also removed. (Why would gnome-tweak-tool,
    >> gnome-session, gnome-color-manager be removed, for instance?)
    >>

    > No idea, maybe they use PackageKit to automatically install certain
    > packages.


    Package kit triggers removal of all that, because all those packages say
    they need packagekit. For instance, they link to a library of package
    kit. Others packages that say the need the library that in turn says
    they need package kit, are removed as well... long list and disaster if
    you go ahead.

    > You should be able to uninstall "gnome-packagekit", i.e. the actual
    > update applet, though.


    Yes, that works.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #17
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How do I disable automatic updates?

    On 2014-03-25 19:36, jimoe666 wrote:
    >
    > wolfi323;2632944 Wrote:
    >>
    >> I guess what you mean is "update notifications".
    >> The updates only get installed when you tell the update applet to
    >> install them.

    > Correct. The updates are retrieved but not installed.


    No.

    Updates are not even retrieved automatically.

    What the update applet does is download the data necessary to calculate
    what updates are available - and this data can be large, several megabytes.

    It does not download any update at all.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  8. #18

    Default Re: How do I disable automatic updates?

    Quote Originally Posted by martin_helm View Post
    Am 25.03.2014 20:46, schrieb wolfi323:
    > Hm, does GNOME then have a different update applet built-in (like
    > with NetworkManager)? As I said, I ran gpk-update-viewer (from
    > gnome-packagekit), and it didn't download packages either until I
    > clicked on "Install Updates".
    >

    That shows exactly nothing as you started it manually, looking
    dconf-editor now it is set to enable the auto download and that is the
    default it came with.
    What does that mean?
    There are two different settings? One for starting it manually, and one for using it inside GNOME?
    Or is GNOME's update applet a completely different thing than gpk-update-viewer? (that was my question)

    I just had a look in dconf-editor, and I don't find anything in there regarding automatic download or install either (and also nothin about the check interval).
    Should this be in org/gnome/packagekit, or am I looking in the wrong place?
    Or do I have to login to GNOME to get the _real_ default settings?

    Ah, ok. Found it now. It's in org/gnome/settings-daemon/plugins/updates. So there is a daemon running when you login to GNOME apparently, which is different from gpk-update-viewer, and has "auto-download-updates" set to true.
    Didn't know that, sorry. But thanks for the clarification.

    Btw, @jimoe666, there's also a setting in there (dconf-editor) to de-activate that updater completely in addition to the "auto-download-updates".

  9. #19
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How do I disable automatic updates?

    On 2014-03-25 20:46, wolfi323 wrote:

    > Yes, that was about Apper, I know there's no such setting in gpk-prefs.
    >
    > Hm, does GNOME then have a different update applet built-in (like with
    > NetworkManager)?
    > As I said, I ran gpk-update-viewer (from gnome-packagekit), and it
    > didn't download packages either until I clicked on "Install Updates".


    I started "pk-update-icon -d 0" in a terminal on XFCE. This starts
    immediately the check for updates, and it does just that, check. The
    check itself is several megabytes heavy. When it ends, I get a prompt to
    install or dismiss. If I say "install", then I get a large dialog, where
    I can accept or reject individual updates. Some are marked "security",
    some "important", some "other" (the last come mainly from packman).

    But no update is downloaded till I accept them.

    I see no possible configuration.

    In the XFCE setting manager, under "session and startup", tab
    "application autostart", two of the entries are labelled the same,
    "PackageKit Update Applet". But one starts pk-update-icon and another
    gpk-update-icon, which is not installed on my system. I have
    gpk-update-viewer, though.

    Simply unticking those two disables all checking for updates - for this
    user, that is.

    Starting "gpk-update-viewer" does the same thing as "pk-update-icon -d
    0", it checks for updates immediately. The resulting window is the same
    as before, and no configuration is possible. Again, no updates are
    downloaded till I accept, if I do.

    If I start "gpk-prefs" I see options to adjust frequency of checks, and
    whether to do the check while on battery or when using mobile broadband.
    Nowhere it says anything about downloading updates.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  10. #20
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How do I disable automatic updates?

    read the link I posted, settings are in
    org.gnome.settings-daemon.plugins.updates

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •