Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Grub2 Question

  1. #1
    Join Date
    Jan 2014
    Location
    United States
    Posts
    150

    Default Grub2 Question

    I'm trying to help my friend install openSUSE 13.1 x64. He has an issue where Grub2 is not giving the option to write the MBR to the hard drive that he wants openSUSE on. He has multiple hard drives in his machine, and Winblows is on one of those drives. Grub2 is writing the MBR to the Windows drive, and this isn't the behavior that is desired. How do you get Grub2 to not write the MBR to the wrong drive?

    Secondly, this install was on a drive that had FreeBSD on it, and the YaST Partioner had an issue erasing the MBR from the FreeBSD install, leaving an unbootable system. Does Grub2 sometimes have problems overwriting an existing MBR? He also tried having Grub2 write to the root partition, and that left the system unbootable.

  2. #2
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Grub2 Question

    Hi.

    You can set drive priority in the BIOS, choose the one to install openSUSE onto as the first drive, I suppose this isn't UEFI? Besides, by default GRUB will boot from 'root'(/boot) not MBR, choose whichever you like but to launch GRUB you need to set the oS drive at top.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  3. #3
    Join Date
    Jan 2014
    Location
    United States
    Posts
    150

    Default Re: Grub2 Question

    Quote Originally Posted by F_Sauce View Post
    Hi.

    You can set drive priority in the BIOS, choose the one to install openSUSE onto as the first drive, I suppose this isn't UEFI? Besides, by default GRUB will boot from 'root'(/boot) not MBR, choose whichever you like but to launch GRUB you need to set the oS drive at top.
    It is not UEFI. He already did set the OS drive as the top drive and Grub2 writes an MBR to the Windows drive, which is the wrong drive.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Grub2 Question

    At the scheme check screen all the things planed to happen are listed click the grub entry and change it.

    Not Gurb does not have to be in the MBR if you use generic MBR code and put grub code on the boot partition (root usually) then the system will boot to the partition that is flagged to boot

    If you need more info show use the output

    fdisk -l
    note that is lower case L not a one

    You can use any live Linux to get that

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Grub2 Question

    Quote Originally Posted by pirithous View Post
    I'm trying to help my friend install openSUSE 13.1 x64. He has an issue where Grub2 is not giving the option to write the MBR to the hard drive that he wants openSUSE on. He has multiple hard drives in his machine, and Winblows is on one of those drives. Grub2 is writing the MBR to the Windows drive, and this isn't the behavior that is desired. How do you get Grub2 to not write the MBR to the wrong drive?

    Secondly, this install was on a drive that had FreeBSD on it, and the YaST Partioner had an issue erasing the MBR from the FreeBSD install, leaving an unbootable system. Does Grub2 sometimes have problems overwriting an existing MBR? He also tried having Grub2 write to the root partition, and that left the system unbootable.
    During install, at the install summary proposal
    https://dl.dropboxusercontent.com/u/.../grub2-set.png
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Sep 2012
    Posts
    7,096

    Default Re: Grub2 Question

    Quote Originally Posted by pirithous View Post
    Grub2 writes an MBR to the Windows drive, which is the wrong drive.
    GRUB2 writes to whatever device it is told to write. You probably mean YaST bootloader configuration which is something different. Please show /etc/default/grub_installdevice and /boot/grub2/device.map.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Grub2 Question

    Quote Originally Posted by pirithous View Post
    I'm trying to help my friend install openSUSE 13.1 x64. He has an issue where Grub2 is not giving the option to write the MBR to the hard drive that he wants openSUSE on.
    On the boot install screen, there's a long button at the bottom "Boot Loader Installation Details".

    Click on that. There will be a list of drives, and up/down buttons. Arrange the list so that the first is the one where grub is to be installed. Then click "OK". The summary screen should now show the MBR of the desired disk for installation.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8
    Join Date
    Sep 2012
    Posts
    7,096

    Default Re: Grub2 Question

    Quote Originally Posted by nrickert View Post
    There will be a list of drives, and up/down buttons. Arrange the list so that the first is the one where grub is to be installed.
    I'm not sure whether it still works. It worked in the past by using legacy (hd0) as install device and changing mapping in device.map; but today yast does not use legacy drive names anymore and simply refers to OS device name (/dev/...).

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Grub2 Question

    Quote Originally Posted by arvidjaar View Post
    I'm not sure whether it still works. It worked in the past by using legacy (hd0) as install device and changing mapping in device.map; but today yast does not use legacy drive names anymore and simply refers to OS device name (/dev/...).
    It worked for me, installing 13.1 to an external drive and booting from the MBR of that external drive.

    The ordered list of drives did use "/dev/sda" etc. And that was a bit awkward, because I had to make sure which device name the installer was associating with which physical device. So it is more confusing than I indicated in my earlier comment.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  10. #10
    Join Date
    Jan 2014
    Location
    United States
    Posts
    150

    Default Re: Grub2 Question

    Quote Originally Posted by nrickert View Post
    On the boot install screen, there's a long button at the bottom "Boot Loader Installation Details".

    Click on that. There will be a list of drives, and up/down buttons. Arrange the list so that the first is the one where grub is to be installed. Then click "OK". The summary screen should now show the MBR of the desired disk for installation.
    He says he did this but it didn't work. YaST puts the MBR on the wrong drive. Is there a bug here?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •