Results 1 to 8 of 8

Thread: Cannot get virtual machine to connect to internet

  1. #1
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    374

    Default Cannot get virtual machine to connect to internet

    I'm using Oracle Virtual Box on OpenSuSE 13.1. The virtual machine is Windows 7. I can't seem to get the Windows machine to connect to the internet.
    My latest attempt was to setup a Samba Server. Still no luck. Any help will be appreciated.
    The greatest obstacle to discovery is not ignorance, it is the illusion of knowledge.
    Daniel J. Boorstin US Patent Office

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Cannot get virtual machine to connect to internet

    Typically...

    - Verify Host connectivity to the Internet
    - Configure the Guest network settings for NAT (if a single machine), NAT network (if you intend to run multiple Guest at once). You can also choose bridging if you want, but that configuration requires more knowledge and configuration. One of the NAT settings is recommended when setting up, you can change later if you wish.
    - When you fire up your Guest, you should check whether it gets its IP address (If you chose one of the NAT settings, DHCP should be enabled automatically). Since your Guest is Win7 run
    Code:
    ipconfig
    Note that your Guest network adapter should <always> be a wired connection regardless what kind of physical network connection your Host is using to connect to the Internet.
    - If your Guest gets an IP address, ping its gateway to verify it can communicate with the Host.
    - Then ping something beyond the Host (like your Host's DG).

    Don't even attempt to connect to or setup network services like SAMBA until you've established basic network connectivity.

    HTH,
    TSU

  3. #3
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    374

    Default Re: Cannot get virtual machine to connect to internet

    Here are the results running cmd, ipconfig

    ip configuration
    Tunnel adapter Local Area Connection* 11:

    media state...........................-..: media disonnected
    Connection-specific DNS Suffix:
    The greatest obstacle to discovery is not ignorance, it is the illusion of knowledge.
    Daniel J. Boorstin US Patent Office

  4. #4

    Default Re: Cannot get virtual machine to connect to internet

    Quote Originally Posted by Parthenolide View Post
    Here are the results running cmd, ipconfig

    ip configuration
    Tunnel adapter Local Area Connection* 11:

    media state...........................-..: media disonnected
    Connection-specific DNS Suffix:
    Check the Network configuration in the VM's settings. Especially verify that "Cable Connected" is enabled under "Advanced".

    By default a "Intel PRO/1000" network card is emulated. I don't know whether Windows 7 includes a driver for that (but I guess it does).

    Have you installed the guest additions inside Windows 7?
    Try to do that, just select "Install Guest Additions..." in the VM's "Devices" menu.

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Cannot get virtual machine to connect to internet

    On Sat, 22 Mar 2014 20:56:01 +0000, Parthenolide wrote:

    > Here are the results running cmd, ipconfig
    >
    > ip configuration Tunnel adapter Local Area Connection* 11:
    >
    > media state...........................-..: media disonnected
    > Connection-specific DNS Suffix:


    The tunnel adapter isn't what you should be using - that's not a
    traditional ethernet driver.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Cannot get virtual machine to connect to internet

    Quote Originally Posted by hendersj View Post
    On Sat, 22 Mar 2014 20:56:01 +0000, Parthenolide wrote:

    > Here are the results running cmd, ipconfig
    >
    > ip configuration Tunnel adapter Local Area Connection* 11:
    >
    > media state...........................-..: media disonnected
    > Connection-specific DNS Suffix:


    The tunnel adapter isn't what you should be using - that's not a
    traditional ethernet driver.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    Been awhile since I've deployed Windows in VMware, but "in the old days" I remember Windows installing a tunnel adapter.

    The tunnel adapter is simply another layer of virtualization that needs to be configured. If your machine is multi-homed, make sure it's bound to the correct "physical" adapter. Make sure the underlying physical adapter is properly configured and connected to the Host's virtual network. Verify this by pinging the <physical> IP address from the Host. If successful, then ping the other direction.

    Once the Guest physical network adapter is verified working, if you still have a problem start looking at both the physical and tunnel adapters' properties, turn off anything that's unnecessary (or enable if you find that disabling doesn't work). IIRC in general I enabled Microsoft Networking, IPv4 settings.

    Sorry, been so long since I've configured/troubleshoot these settings because I no longer deploy Windows in VMware I can't give you more guidance aside from the fact I did sometimes fiddle with the settings to get networking working... But, once I figured out what worked it was pretty simple to understand in hind sight.

    I respect that Microsoft Guests on VMware may still be setting up tunnel adapters in the Guest, but it really is generally unnecessary. An alternative try might be to simply un-install the tunnel adapters, then restart networking and see what happens. Be sure you have a source to re-install to undo (or a backup. I don't know if VSS will return you to before a device un-install).

    BTW - This issue about configuring a Windows Guest using a Tunnel adapter in the Guest is not an issue specific to deploying VMware on a Linux host so you should be able to do a general Google search for solutions, and if necessary ask your question in a VMware forum regardless of the underlying Host. Just make sure your Guest network settings are set properly.

    HTH,
    TSu

  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Cannot get virtual machine to connect to internet

    On Mon, 24 Mar 2014 18:26:01 +0000, tsu2 wrote:

    > Been awhile since I've deployed Windows in VMware, but "in the old days"
    > I remember Windows installing a tunnel adapter.


    I've used most versions of VMware since version 2, and never remember
    seeing the tunnel adapter used - it was always the AMD pcnet ethernet
    driver on a properly configured system.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    374

    Default Re: Cannot get virtual machine to connect to internet

    It is working now.
    Thanks for everyone's help.
    I had to do two things:
    1. Somehow "use secure file permissions" in "security center and hardening" utility in yast got changed from "easy" to "secure", so I switched it back to easy.
    2. I switched the VM network setting to Intel PRO/1000 MT Desktop (NAT).

    Thanks again.
    The greatest obstacle to discovery is not ignorance, it is the illusion of knowledge.
    Daniel J. Boorstin US Patent Office

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •