Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Can't adjust brightness using battery icon / through settings

  1. #1

    Unhappy Can't adjust brightness using battery icon / through settings

    I have an Acer 4736 laptop (OpenSuse 13.1) and I cannot adjust brightness through settings and battery icon... the only thing that worked was doing "echo xxxx > /sys/class/backlight/intel_backlight/brightness"

    Display also indicates decrease in brightness but in reality brightness does not change.

    Is there a way to make this work?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,328
    Blog Entries
    15

    Default Re: Can't adjust brightness using battery icon / through settings

    On Thu 20 Mar 2014 09:06:01 PM CDT, oliber wrote:


    I have an Acer 4736 laptop (OpenSuse 13.1) and I cannot adjust
    brightness through settings and battery icon... the only thing that
    worked was doing "echo xxxx >
    /sys/class/backlight/intel_backlight/brightness"

    Display also indicates decrease in brightness but in reality brightness
    does not change.

    Is there a way to make this work?


    Hi
    You could try adding one or the other the acpi option to the grub menu
    via YaST bootloader;
    [CODE]
    Code:
    acpi_backlight=vendor
    
    or
    
    acpi_osi=\"!Windows 2012\"
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: Can't adjust brightness using battery icon / through settings

    Hello

    Thanks for your reply.

    How do I access the Yast bootloader?


    Anyway, I tried adding either of the 2 suggestions via /etc/default/grub but did not work... appears like these:


    GRUB_CMDLINE_LINUX_DEFAULT=" quiet quiet liveinstall resume=/dev/disk/by-id/ata-Hitachi_HTS545032B9A300_090718PB5300Q6C59BAG-part5 splash=silent quiet showopts acpi_backlight=vendor"

    - this line did nothing


    GRUB_CMDLINE_LINUX_DEFAULT=" quiet quiet liveinstall resume=/dev/disk/by-id/ata-Hitachi_HTS545032B9A300_090718PB5300Q6C59BAG-part5 splash=silent quiet showopts acpi_osi=\"!Windows 2012\""

    - this flashed a fail message while booting... something like "failed configuring....."

  4. #4

    Default Re: Can't adjust brightness using battery icon / through settings

    Quote Originally Posted by oliber View Post
    How do I access the Yast bootloader?
    Run YaST and click on "Boot Loader" in the System category. To change the boot options, you have to click on "Boot Loader Options" then.


    Anyway, I tried adding either of the 2 suggestions via /etc/default/grub but did not work... appears like these:
    Did you run grub2-mkconfig after changing that file (as instructed there)?

    You could also edit /boot/grub2/grub.cfg directly for a test (or press 'e' at the boot menu and append the options to the "linux" line), but those changes will get lost.

    You could also try acpi_osi="Linux" or acpi_osi="Windows".

  5. #5

    Default Re: Can't adjust brightness using battery icon / through settings

    Quote Originally Posted by wolfi323 View Post
    Run YaST and click on "Boot Loader" in the System category. To change the boot options, you have to click on "Boot Loader Options" then.
    I tried opening the YaST boot loader but its giving me a loading sign and just stops without opening any window / doing anything.



    Quote Originally Posted by wolfi323 View Post
    Did you run grub2-mkconfig after changing that file (as instructed there)?

    You could also edit /boot/grub2/grub.cfg directly for a test (or press 'e' at the boot menu and append the options to the "linux" line), but those changes will get lost.

    You could also try acpi_osi="Linux" or acpi_osi="Windows".
    Yes I ran the command on top of the grub file.

    and adding:

    acpi_osi="Linux" => Did not do anything still full brightness on boot
    acpi_osi="Windows" => Decreased brightness on boot

    but still cannot adjust brightness through settings though

  6. #6

    Default Re: Can't adjust brightness using battery icon / through settings

    Quote Originally Posted by oliber View Post
    I tried opening the YaST boot loader but its giving me a loading sign and just stops without opening any window / doing anything.
    That's strange.
    Do other YaST modules work?

    Could you post the last lines of /var/log/YaST2/y2log after YaST crashes?

    Yes I ran the command on top of the grub file.
    Good.

    and adding:

    acpi_osi="Linux" => Did not do anything still full brightness on boot
    acpi_osi="Windows" => Decreased brightness on boot

    but still cannot adjust brightness through settings though
    According to https://wiki.ubuntu.com/Kernel/Debugging/Backlight, this would be another option you could try:
    Code:
    video.use_bios_initial_backlight=0
    Or:
    Intel HD Graphic Controllers

    With an Intel HD Graphic Controller if passing kernel parameter acpi_backlight does not work, or it freezes and/or crashes, one may try adjusting which backlight interface is used by creating a new file in /usr/share/X11/xorg.conf.d/80-backlight.conf and paste into it the following code:
    Code:
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"     "sna"
       Option      "Backlight"       "intel_backlight" # use your backlight that works here
       BusID       "PCI:0:2:0"
    EndSection
    Last edited by wolfi323; 21-Mar-2014 at 17:30.

  7. #7

    Default Re: Can't adjust brightness using battery icon / through settings

    Quote Originally Posted by wolfi323 View Post
    That's strange.
    Do other YaST modules work?

    Could you post the last lines of /var/log/YaST2/y2log after YaST crashes?
    Other modules dont work and so far no crashes but it wont open.. one click install does not open...

    /var/log/YaST2/y2log does not display anything

    and there are new updates for Yast but havent installed them yet

    Ill try updating and give a feedback later


    Quote Originally Posted by wolfi323 View Post
    Intel HD Graphic Controllers
    Quote Originally Posted by wolfi323 View Post
    With an Intel HD Graphic Controller if passing kernel parameter acpi_backlight does not work, or it freezes and/or crashes, one may try adjusting which backlight interface is used by creating a new file in /usr/share/X11/xorg.conf.d/80-backlight.conf and paste into it the following code:
    Code:
    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"     "sna"
        Option      "Backlight"       "intel_backlight" # use your backlight that works here
        BusID       "PCI:0:2:0"
    EndSection
    This worked for me but I accidentally set brightness to "0" using setting and the screen blacked out (cant use keyboard since my fn key isnt working)
    So I deleted the "80-backlight.conf" file and redo the process

    Glad to see its working now

  8. #8

    Default Re: Can't adjust brightness using battery icon / through settings

    Update: So far Yast isnt working after most recent update

  9. #9

    Default Re: Can't adjust brightness using battery icon / through settings

    Quote Originally Posted by oliber View Post
    Update: So far Yast isnt working after most recent update
    Could you please post the last lines of /var/log/YaST2/y2log? You have to be root to access it though.

    Do you maybe have some manually installed ruby on your hard disk (via RVM maybe)?

  10. #10

    Default Re: Can't adjust brightness using battery icon / through settings

    Quote Originally Posted by wolfi323 View Post
    Could you please post the last lines of /var/log/YaST2/y2log? You have to be root to access it though.

    Do you maybe have some manually installed ruby on your hard disk (via RVM maybe)?
    Checked my Open suse version and it says 13.2.... somehow i installed the updgrade... i reinstalled 13.1.. and its working now - my bad

    Thank you so much

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •