Results 1 to 5 of 5

Thread: XFCE doesn't display Wine Icons

  1. #1
    Join Date
    Jun 2011
    Location
    Brazil - São Paulo
    Posts
    21

    Default XFCE doesn't display Wine Icons

    Hi,

    I think that is a bug. This is the second computer with OpenSUSE 13.1 that I'm installing Wine.

    The problem is that in menu, the Wine icons do not appear. Even if I try to change from "Main Menu" application.

    I copied the directory /usr/share/icons/hicolor to my ~/.local/share restart and then the icons appeared.

    The other problem is, even if I remove Wine, the menu still there, and I can't remove from "Main Menu". I saw a post talking about it in version 12.

    This is a bug? Or I'm messed the system?

    Thanks

  2. #2
    Join Date
    Jun 2011
    Location
    Brazil - São Paulo
    Posts
    21

    Question Re: XFCE doesn't display Wine Icons

    Ok, I tried this.

    I open wine-winecfg.desktop file:
    Code:
    [Desktop Entry]
    X-SuSE-translate=false
    Name=Configure Wine
    GenericName=Configure Wine
    Name[sv]=Konfigurera Wine
    Name[de]=Konfiguriere Wine
    Name[fi]=Winen asetukset
    Name[pl]=Konfiguracja Wine
    Name[ca]=Configureu el Wine
    Comment=Change application-specific and general Wine options
    Comment[sv]=Ändra programspecifika och allmänna Wine-alternativ
    Comment[de]=Ändere Wine Optionen und Applikations-spezifische Einstellungen
    Comment[fi]=Muuta yleisiä ja sovelluskohtaisia Winen asetuksia
    Comment[pl]=Konfigurowanie ustawień aplikacji i ogólnych opcji Wine
    Comment[ca]=Canvieu la configuració general del Wine i especifiqueu opcions per a programes concrets
    Exec=winecfg
    Terminal=false
    Icon=wine-winecfg
    Type=Application
    Categories=Wine;Emulator;
    If, I change the Icon entry to the absolute patch of the icon... /usr/share/icons/hicolor/scalable/apps/wine-winecfg.svg the icon appear on menu.
    Code:
    Icon=/usr/share/icons/hicolor/scalable/apps/wine-winecfg.svg
    This name "wine-winecfg" is a implementation of freedesktop.org right? How can I update the system, to find or recognize this new wine icons alias?

    The command gtk-update-icon-cache, 2 and 3 doesn't fix it.

  3. #3
    Join Date
    Jun 2011
    Location
    Brazil - São Paulo
    Posts
    21

    Talking Now the Icons appear!

    Please, someone?

    I discover a important thing, I installed here a new program, galculator. And then, with my modifications of wine menu entries, after the installation of this program, the menu update it self.

    I tested in another computer without this modifications, and it work!

    Please, what is the command to update the menus? gcalculator execute this command, xcalc and wine no.

  4. #4

    Default Re: Now the Icons appear!

    Quote Originally Posted by l2mago View Post
    Please, someone?

    I discover a important thing, I installed here a new program, galculator. And then, with my modifications of wine menu entries, after the installation of this program, the menu update it self.

    I tested in another computer without this modifications, and it work!

    Please, what is the command to update the menus? gcalculator execute this command, xcalc and wine no.
    So the menu entries appear, but only the icons are missing?

    galculator executes this on installation, this should make the icons appear:
    Code:
    /usr/bin/gtk-update-icon-cache --force "/usr/share/icons/hicolor"
    For the menu entries itself, this should do:
    Code:
    /usr/bin/update-desktop-database "/usr/share/applications"
    Then galculator also calls this, but that's only for associating default applications to file types I think:
    Code:
    /usr/bin/suse-update-mime-defaults
    But note that I don't use XFCE myself, so cannot help you further.

  5. #5
    Join Date
    Jun 2011
    Location
    Brazil - São Paulo
    Posts
    21

    Thumbs up Re: Now the Icons appear!

    Quote Originally Posted by wolfi323 View Post
    So the menu entries appear, but only the icons are missing?

    galculator executes this on installation, this should make the icons appear:
    Code:
    /usr/bin/gtk-update-icon-cache --force "/usr/share/icons/hicolor"
    For the menu entries itself, this should do:
    Code:
    /usr/bin/update-desktop-database "/usr/share/applications"
    Then galculator also calls this, but that's only for associating default applications to file types I think:
    Code:
    /usr/bin/suse-update-mime-defaults
    But note that I don't use XFCE myself, so cannot help you further.
    Thanks wolfi!!!

    The first command work, but I have to logoff and back. I didn't test the others.

    Maybe, the second command fix it without logoff/login.

    Really thanks.

    But, is there a way to put it on package installation?
    This is not important, but is annoyng. I think that it will help other users that use XFCE insted KDE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •