Results 1 to 9 of 9

Thread: AMD Radeon HD 8240 Graphics Driver Problem

  1. #1

    Default AMD Radeon HD 8240 Graphics Driver Problem

    Dear Staff,

    I am trying to install AMD Radeon HD 8420 Graphics driver but i am continue getting this error. i tried many many procedures but no luck yet... Please Advice Thanks



    Code:
    "Log file for your consideration"
    Supported adapter detected.
    Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    Dryrun uninstall succeeded continuing with installation.
    Check if system has the tools required for installation.
    fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.11.6-4-desktop/build/include/generated/uapi/linux/version.h cannot be found on this system.
    One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
    Optionally, run the installer with --force option to install without the tools.
    Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

  2. #2

    Default AW: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by ecrudragon View Post
    Dear Staff,

    I am trying to install AMD Radeon HD 8420 Graphics driver but i am continue getting this error. i tried many many procedures but no luck yet... Please Advice Thanks

    Code:
    "Log file for your consideration"
    Supported adapter detected.
    Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    Dryrun uninstall succeeded continuing with installation.
    Check if system has the tools required for installation.
    fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.11.6-4-desktop/build/include/generated/uapi/linux/version.h cannot be found on this system.
    One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
    Optionally, run the installer with --force option to install without the tools.
    Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
    Well, as the message says, you're missing the kernel headers for the 3.11.6 kernel. Try to install the kernel_devel pattern.
    In particular, you need the package "kernel-desktop-devel-3.11.6" to get rid of that error.
    Code:
    zypper in kernel-desktop-devel-3.11.6
    But why not use the openSUSE packages? They should just work:
    https://en.opensuse.org/SDB:AMD_fglrx

    As I can see in your screenshot, you actually already downloaded the driver RPM. You can install that with:
    Code:
    rpm -i fglrx64_xpic_SUSE131-13.251-3.x86_64.rpm
    But I would recommend to add the repo in YaST->Software Repositories (or just use the 1-click install above), so you would get automatic updates.

  3. #3

    Default Re : AMD Radeon HD 8240 Graphics Driver Problem

    Hi

    Quote Originally Posted by ecrudragon View Post
    Code:
    Supported adapter detected.
    Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    Dryrun uninstall succeeded continuing with installation.
    Check if system has the tools required for installation.
    fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.11.6-4-desktop/build/include/generated/uapi/linux/version.h cannot be found on this system.
    One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
    Optionally, run the installer with --force option to install without the tools.
    Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
    This version requires kernel-devel 3.7.

    Have you tried to install the fglrx rpms packaged by Bruno Friedmann instead?



    EDIT - didn't see your post wolfi, sorry…

  4. #4

    Default Re: AW: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by wolfi323 View Post
    Well, as the message says, you're missing the kernel headers for the 3.11.6 kernel. Try to install the kernel_devel pattern.
    In particular, you need the package "kernel-desktop-devel-3.11.6" to get rid of that error.
    Code:
    zypper in kernel-desktop-devel-3.11.6
    But why not use the openSUSE packages? They should just work:
    https://en.opensuse.org/SDB:AMD_fglrx

    As I can see in your screenshot, you actually already downloaded the driver RPM. You can install that with:
    Code:
    rpm -i fglrx64_xpic_SUSE131-13.251-3.x86_64.rpm
    But I would recommend to add the repo in YaST->Software Repositories (or just use the 1-click install above), so you would get automatic updates.
    Thanks @Wolfi323,

    Code:
    linux-ab03:/home/ecrudragon/Downloads # zypper in kernel-desktop-devel-3.11.6
    Loading repository data...
    Reading installed packages...
    The selected package 'kernel-desktop-devel-3.11.6-4.1.x86_64' from repository 'openSUSE-13.1-1.10' has lower version than the installed one. Use 'zypper install --oldpackage kernel-desktop-devel-3.11.6-4.1.x86_64' to force installation of the package.
    Resolving package dependencies...
    
    Nothing to do.
    linux-ab03:/home/ecrudragon/Downloads # zypper install --oldpackage kernel-desktop-devel-3.11.6-4.1.x86_64
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW packages are going to be installed:
      kernel-desktop-devel-3.11.6-4.1 kernel-devel-3.11.6-4.1 
    
    2 new packages to install.
    Overall download size: 11.7 MiB. After the operation, additional 49.8 MiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package kernel-devel-3.11.6-4.1.noarch                                                        (1/2),   9.5 MiB ( 46.9 MiB unpacked)
    Retrieving package kernel-desktop-devel-3.11.6-4.1.x86_64                                                (2/2),   2.2 MiB (  2.9 MiB unpacked)
    (1/2) Installing: kernel-devel-3.11.6-4.1 ..............................................................................................[done]
    (2/2) Installing: kernel-desktop-devel-3.11.6-4.1 ......................................................................................[done]
    Additional rpm output:
    Changing symlink /usr/src/linux-obj/x86_64/desktop from ../../linux-3.11.10-7-obj/x86_64/desktop to ../../linux-3.11.6-4-obj/x86_64/desktop
    This thing worked for me, LOVE YOU... Take Care

  5. #5

    Default Re: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by ecrudragon View Post
    This thing worked for me, LOVE YOU... Take Care
    Ah ok. So you had kernel-desktop-devel-3.11.10 installed, but still used kernel-desktop-3.11.6.
    3.11.10 is available in the update repo (that's where you have kernel-desktop-devel-3.11.10 from). So installing all updates and rebooting should have helped as well...

    Please note, that you have to re-install the driver whenever there is a kernel update, when you installed it manually like this.
    That's one of the advantages in using the openSUSE packages, they take care of that themselves.
    Last edited by wolfi323; 19-Mar-2014 at 04:19.

  6. #6

    Default Re: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by wolfi323 View Post
    Ah ok. So you had kernel-desktop-devel-3.11.10 installed, but still used kernel-desktop-3.11.6.
    3.11.10 is available in the update repo (that's where you have kernel-desktop-devel-3.11.10 from). So installing all updates and rebooting should have helped as well...

    Please note, that you have to re-install the driver whenever there is a kernel update, when you installed it manually like this.
    That's one of the advantages in using the openSUSE packages, they take care of that themselves.
    Dear @wolfie323,

    I updated my openSUSE last night took me around 1 n half hour to update all the packages but now i can't boot into normal mode again i am in recovery mode typing is msg.
    Now again i have graphics problem now again i am trying to install graphics drivers and getting this error.

    Code:
    Supported adapter detected.Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    
    
    [Error]A previous installation of fglrx driver detected.
    User must uninstall using /usr/share/ati/amd-uninstall.sh with force 
    or run install with force option. 
    Forcing the installation is not recommended.
    Please Advice

  7. #7

    Default AW: Re: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by ecrudragon View Post
    Dear @wolfie323,

    I updated my openSUSE last night took me around 1 n half hour to update all the packages but now i can't boot into normal mode again i am in recovery mode typing is msg.
    Now again i have graphics problem now again i am trying to install graphics drivers and getting this error.

    Code:
    Supported adapter detected.Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    
    
    [Error]A previous installation of fglrx driver detected.
    User must uninstall using /usr/share/ati/amd-uninstall.sh with force 
    or run install with force option. 
    Forcing the installation is not recommended.
    Please Advice
    Try to use the "--force" option when running the installer or uninstall the driver first as suggested by that message.

    Is there any specific reason why you don't just install the rpm package or add the repo? This should still work after kernel updates.
    You should uninstall the manually installed driver first though, if you would do that.
    Last edited by wolfi323; 20-Mar-2014 at 13:52.

  8. #8

    Default Re: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by ecrudragon View Post
    Dear @wolfie323,

    I updated my openSUSE last night took me around 1 n half hour to update all the packages but now i can't boot into normal mode again i am in recovery mode typing is msg.
    Now again i have graphics problem now again i am trying to install graphics drivers and getting this error.

    Code:
    Supported adapter detected.Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    
    
    [Error]A previous installation of fglrx driver detected.
    User must uninstall using /usr/share/ati/amd-uninstall.sh with force 
    or run install with force option. 
    Forcing the installation is not recommended.
    Please Advice
    Problem Solved

    1) re-installed fglrx64_xpic_SUSE131-13.251-3.x86_64.rpm
    2) re-installed graphic drivers

  9. #9

    Default Re: AMD Radeon HD 8240 Graphics Driver Problem

    Quote Originally Posted by ecrudragon View Post
    Problem Solved

    1) re-installed fglrx64_xpic_SUSE131-13.251-3.x86_64.rpm
    2) re-installed graphic drivers
    Do I understand you correctly?
    You installed fglrx64_xpic_SUSE131-13.251-3.x86_64.rpm _and_ ran the amd-driver-installer?

    You should NOT do that. Either install the one or the other.
    fglrx64_xpic_SUSE131-13.251-3.x86_64.rpm _is_ the amd graphic driver, it's just a different version (the current stable one, whereas that .run file is a beta version).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •