Results 1 to 4 of 4

Thread: LibreOffice Calc finding USB stick

  1. #1

    Default LibreOffice Calc finding USB stick

    Feeling very dumb here but how can I find my USB stick from Calc open file dialogue. Have been used to seeing it in Dolphin under "Devices" but how do I navigate to it in file menu from Calc?
    Sorry to be so stupid and I should know. Blame it fatigue!

  2. #2

    Default Re: LibreOffice Calc finding USB stick

    Quote Originally Posted by Budgie2 View Post
    Feeling very dumb here but how can I find my USB stick from Calc open file dialogue. Have been used to seeing it in Dolphin under "Devices" but how do I navigate to it in file menu from Calc?
    Sorry to be so stupid and I should know. Blame it fatigue!
    If you use LibreOffice's KDE4 integretion (package "libreoffice-kde4"), you should get KDE's file dialog, which would allow you to open the USB stick just like dolphin does. Make sure that "Use LibreOffice dialogs" is NOT enabled in LibreOffice's "General" settings.

    If you do have "libreoffice-kde4" installed and don't get the KDe file dialog, then most likely you have "ibus" installed which forces LibreOffice to use the GNOME integration even on KDE4.
    In this case, either uninstall "ibus" (this is only needed for inputting asian characters), or install "libreoffice-gnome" as well to get GNOME's file dialog, which should also allow you to choose the USB stick on the left panel.

    If none of that works, mount the stick with dolphin or the device notifier and navigate to /var/run/media/username/ (that's where it gets mounted to by default), and you should find your stick there.

  3. #3

    Default Re: LibreOffice Calc finding USB stick

    Quote Originally Posted by wolfi323 View Post
    If you use LibreOffice's KDE4 integretion (package "libreoffice-kde4"), you should get KDE's file dialog, which would allow you to open the USB stick just like dolphin does. Make sure that "Use LibreOffice dialogs" is NOT enabled in LibreOffice's "General" settings.

    If you do have "libreoffice-kde4" installed and don't get the KDe file dialog, then most likely you have "ibus" installed which forces LibreOffice to use the GNOME integration even on KDE4.
    In this case, either uninstall "ibus" (this is only needed for inputting asian characters), or install "libreoffice-gnome" as well to get GNOME's file dialog, which should also allow you to choose the USB stick on the left panel.

    If none of that works, mount the stick with dolphin or the device notifier and navigate to /var/run/media/username/ (that's where it gets mounted to by default), and you should find your stick there.
    Hi Wolfi323,
    Very many thanks for detailed info.
    I cannot find the "Use LibreOffice dialogues" in "General" settings. Can you be more precise please when you have time.
    I do have ibus installed so have installed GNOME's file dialogue which, as you say shows, the stick. Problem Solved.
    Meanwhile I used dolphin and "open with."
    Great reply, gave me all I needed and more. Many thanks once more.
    Budgie

  4. #4

    Default Re: LibreOffice Calc finding USB stick

    Quote Originally Posted by Budgie2 View Post
    I cannot find the "Use LibreOffice dialogues" in "General" settings. Can you be more precise please when you have time.
    In LibreOffice's menu select "Extras"->"Options"->"General".
    But you must have it disabled anyway, otherwise you wouldn't get the GNOME dialog now.

    I do have ibus installed
    Well, if you don't use ibus, you could just uninstall it. You would get the KDE dialogs and full KDE integration then.

    PS, to clarify: If you want to do this, only uninstall the package "ibus" and its dependencies. "libibus" is required and doesn't affect LibreOffice anyway.
    Last edited by wolfi323; 17-Mar-2014 at 05:27.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •