Results 1 to 4 of 4

Thread: Weird switch from KDE to Gnome

  1. #1

    Default Weird switch from KDE to Gnome

    I'm running OpenSuse 13.1 - I had just customized my installation of KDE approximately a week ago. For some reason, my computer boots up to a login screen now where it didn't before. An xconsole window pops up and makes reference to "martian source" and is actively doing something. When I login, Gnome loads up. *scratching my head* I hadn't changed anything to warrant this odd switch from KDE to Gnome. Anybody else having this experience?

    I enjoyed Gnome 2, but Gnome 3 has me wanting to stay with KDE. The thought of the system switching for me is unsettling. Any help is appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Weird switch from KDE to Gnome

    Exactly what customizations do you mean?

    When you say it didn't boot to a login screen before - do you mean it was set to auto login?

    At the login screen there is a option to toggle the session. Please make sure to choose the kde plasma workspace
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Weird switch from KDE to Gnome

    I think if you install more then one DE then auto login may be turned off. to allow the choice to which DE you want to boot too. There should be a menu at the bottom of the login screen to choice the default desktop. Then you can turn autolog back on if you want that. Personally I think it can cause difficulties in diagnosing problems but to each his own

  4. #4

    Default Re: Weird switch from KDE to Gnome

    Quote Originally Posted by gogalthorp View Post
    I think if you install more then one DE then auto login may be turned off. to allow the choice to which DE you want to boot too.
    No, it should not.

    Quote Originally Posted by dancing_penguins View Post
    An xconsole window pops up and makes reference to "martian source" and is actively doing something.
    That would indicate that something else is wrong.
    How does your login screen look like?

    KDM shouldn't show such a xconsole window with the kernel messages. But I think xdm does.
    So maybe you uninstalled kdm by mistake (xdm is the fallback then) and therefore auto-login is not working any more?
    Please verify that and re-install kdm if necessary.

    Btw, you can set the default desktop session in /etc/sysconfig/windowmanager.
    For KDE this should be:
    Code:
    DEFAULT_WM="kde-plasma"
    Last edited by wolfi323; 15-Mar-2014 at 04:41.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •