Results 1 to 5 of 5

Thread: Firefox; chewing CPU while in background

  1. #1

    Default Firefox; chewing CPU while in background

    Hi,

    I've recently installed openSUSE 13.1 on a dual boot system with Windows XP. I noticed earlier this evening, trying to post to the forum, that the echo from keys was taking quite a time to appear on the screen. I looked at the System Monitor and Firefox was using as much of the CPU as it could - 90 to 95%. I rebooted and when Firefox started up I closed most of the tabs, and with CTRL ESC looked at the Top System Activity; FIrefox was running at between 60 and 80%. Doing what? Memory usage was going steadily up while I was just watching the System Activity window; reaching 180MB before it sank back down to 150MB, only to start climbing again. With Firefox running, the system is almost unusable. The delays while typing are a real pain in the posterior! Any suggestions as to where to go with this one?

    Thanks

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,641
    Blog Entries
    3

    Default Re: Firefox; chewing CPU while in background

    Quote Originally Posted by Gazzamo View Post
    I looked at the System Monitor and Firefox was using as much of the CPU as it could - 90 to 95%.
    I am seeing firefox using 1% of cpu, and around 180M of memory. That's with 3 tabs open.

    I currently use the "noscript" extension and the "flashblock" extension.

    In my experience, some pages can be very heavy on flash use, which drives up the cpu use. And occasionally there is a page with looping javascript.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Firefox; chewing CPU while in background

    Hello.

    Try to clear the history: History > Clear Recent History, select everything.
    If that does not help you could try to remove the .mozilla directory from home; note: this will clear your saved passwords, remove extensions etc, so instead of deleting it you might save it at another location for back-up if you want to keep anything in there.

    You could also provide an output from the top command showing Firefox running, someone might spot some irregularity.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  4. #4

    Default Re: Firefox; chewing CPU while in background

    Thanks for the tips. But I've just booted up the system, opened up Firefox with 2 tabs, and it's now behaving itself, with between 5 and 11% cpu and 150MB. This I can live with! I'll keep an eye on it and see if I can figure out what sends it haywire.

  5. #5

    Default Re: Firefox; chewing CPU while in background

    On Fri, 14 Mar 2014 23:16:02 GMT
    Gazzamo <Gazzamo@no-mx.forums.opensuse.org> wrote:


    > the screen. I looked at the System Monitor and Firefox was using as
    > much of the CPU as it could - 90 to 95%. I rebooted and when Firefox
    > started up I closed most of the tabs,


    If you look at preferences ==> tabs you'll see an option "don't load
    tabs until selected". Not sure what the default is but if you'd ticked
    this box there would have been no need to close tabs after restart as
    only one tab per window would have been activated.

    Whilst "Flash" might be a contributor to your problem, the CPU used by
    that is usually registered against "plugin-container" - at least it is
    on my system - and killing that process can ease the overall CPU problem
    a little but I don't think it will affect FF's usage.



    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 13.1 (64-bit); KDE 4.12.3; AMD Phenom II X2 550 Processor;
    Kernel: 3.11.10; Video: nVidia GeForce 210 (using nVidia driver);
    Sound: ATI SBx00 Azalia (Intel HDA)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •