Results 1 to 4 of 4

Thread: yii framework object not found

  1. #1
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default yii framework object not found

    I've installed yii framework for php in /srv/www/yiii folowing this tutorial http://www.unixmen.com/install-yii-p...ubuntu-debian/ (I changed /var/www with /srv/www) does it means I've to put yii in /srv/www/htdocs ?
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  2. #2

    Default Re: yii framework object not found

    Quote Originally Posted by roberto68 View Post
    I've installed yii framework for php in /srv/www/yiii folowing this tutorial http://www.unixmen.com/install-yii-p...ubuntu-debian/ (I changed /var/www with /srv/www) does it means I've to put yii in /srv/www/htdocs ?
    Yes.
    On openSUSE apache2 expects its documents in /srv/www/htdocs/ by default. (~/public_html/ should work as well, but then you would have to type an URL like "http://localhost/~username/" into your browser)

  3. #3
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: yii framework object not found

    currently I'm having 2 issues on http://ip-address/yii/unixmen/index.php?r=gii
    Code:
      	 		Error 403   You are not allowed to access this page.
    I've configured yii main.php user, password and the same combination in phpmyadmin ( so it should match) and when I'm trying to login at http://localhost/yii/unixmen/index.php?r=site/login I can't login (wrong user / password) combination
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  4. #4

    Default Re: yii framework object not found

    [QUOTE=roberto68;2630946]currently I'm having 2 issues on http://ip-address/yii/unixmen/index.php?r=gii
    Code:
                   Error 403
    
       You are not allowed to access this page.
    Well, seems to be a permissions issue.
    Try to run:
    Code:
    sudo chown -R wwwrun: /srv/www/htdocs/yii/
    and/or:
    Code:
    sudo chmod -R a+rwx /srv/www/htdocs/yii/
    I've configured yii main.php user, password and the same combination in phpmyadmin ( so it should match) and when I'm trying to login at http://localhost/yii/unixmen/index.php?r=site/login I can't login (wrong user / password) combination
    The above maybe could help here as well.

    I take it you setup the username/password as described in that article, right?
    I have no experience with setting up that framework myself, but could have a try to see whether it would get it to work here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •