Results 1 to 5 of 5

Thread: failed to start openssh daemon on suse gnome 13.1

  1. #1

    Default failed to start openssh daemon on suse gnome 13.1

    Hi, everybody

    I'm trying to start my sshd server because i need to connect to my ssh server from a network device (switch) and download a new firmware with sftp connection.
    I've followed this wiki: https://en.opensuse.org/SDB:SFTP_server_with_Chroot but i'm not able to configure the sshd server.
    This is the systemctl status sshd.service:

    systemctl status sshd.service
    sshd.service - OpenSSH Daemon
    Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled)
    Active: failed (Result: start-limit) since mar 2014-03-11 15:03:14 CET; 52min ago
    Process: 3525 ExecStart=/usr/sbin/sshd -D $SSHD_OPTS (code=exited,
    status=255)
    Process: 3521 ExecStartPre=/usr/sbin/sshd-gen-keys-start (code=exited,
    status=0/SUCCESS)
    Main PID: 3525 (code=exited, status=255)
    CGroup: /system.slice/sshd.service

    : sshd.service: main process exited, code=exited, status=255/n/a
    : Unit sshd.service entered failed state.
    : sshd.service holdoff time over, scheduling restart.
    : Stopping OpenSSH Daemon...
    : Starting OpenSSH Daemon...
    : sshd.service start request repeated too quickly, refusing to start.
    : Failed to start OpenSSH Daemon.
    : Unit sshd.service entered failed state.

    Any help will be appreciated
    Regards
    Max

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: failed to start openssh daemon on suse gnome 13.1

    What if you do
    Code:
    systemctl restart sshd.service
    ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: failed to start openssh daemon on suse gnome 13.1

    On 2014-03-11 16:06, matti67 wrote:
    >
    > Hi, everybody
    >
    > I'm trying to start my sshd server because i need to connect to my ssh
    > server from a network device (switch) and download a new firmware with
    > sftp connection.
    > I've followed this wiki:


    sshd works out of the box in openSUSE. You don't need to do anything,
    just enable it in YaST during the system installation.

    But I never tried to do it with a chroot. Isn't that excessive?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,187

    Default Re: failed to start openssh daemon on suse gnome 13.1

    I just tested the instructions on the web page you linked to create a chrooted sftp on 13.1 and it worked fine in a VM.

    Perhaps /var/log/messages could shed some light on why sshd won't start?
    .: miuku @ #opensuse @ irc.libera.chat

  5. #5

    Default Re: failed to start openssh daemon on suse gnome 13.1

    On 03/11/2014 01:36 PM, Miuku pecked at the keyboard and wrote:
    > I just tested the instructions on the web page you linked to create a
    > chrooted sftp on 13.1 and it worked fine in a VM.
    >
    > Perhaps /var/log/messages could shed some light on why sshd won't start?
    >
    >


    Go to YaST Control Center and click on System Services. Scroll down to
    sshd, highlight it and click on the enable and start buttons. If you
    running the firewall enable port 22 (ssh) for inbound connections.

    Ken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •