Results 1 to 4 of 4

Thread: unresolved package dependency "sm"

  1. #1

    Default unresolved package dependency "sm"

    so , i was trying to build atril ( the MATE document viewer ) from source , as in with autogen.sh , while doing so i had the following unresolved dependency :

    checking for ZLIB... yes
    checking which smclient backend to use... xsmp
    checking for SMCLIENT... no
    configure: error: Package requirements (gtk+-2.0 gthread-2.0 sm >= 1.0.0) were not met:


    No package 'sm' found


    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.


    Alternatively, you may set the environment variables SMCLIENT_CFLAGS
    and SMCLIENT_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    so my question in , does sm as i have been researching stand for "send-mail" client ?? and also what package do i download to resolve this dependency ?
    also my rpm does not seem to work properly so please suggest a zypper alternative .

    im using opensuse-13.1 inside of vmware-workstation .

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,023

    Default Re: unresolved package dependency "sm"

    exim should provide it (if it really wants sendmail)

    zypper in exim
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,172
    Blog Entries
    15

    Default Re: unresolved package dependency "sm"

    On Mon 10 Mar 2014 05:26:01 PM CDT, Miuku wrote:


    exim should provide it (if it really wants sendmail)

    *zypper in exim*


    Hi
    No, that's not correct

    @OP, you need to install libSM-devel for the -lsm linker.

    pkg-config looks in /usr/lib{64}/pkgconfig for a <some_package>.pc
    files which contain all the relevant flags, links etc for the
    development files.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,023

    Default Re: unresolved package dependency "sm"

    Never reply to threads when you're tired I guess, should have noticed it myself.

    My bad.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •