Results 1 to 3 of 3

Thread: Wine: no Greek accented characters in wine 1.17.x

  1. #1

    Default Wine: no Greek accented characters in wine 1.17.x

    I upgraded to opensuse 13.1 and continued to use wine for two programs: Yeah Write (simple word processor, non unicode) and Atlantis (wordprocessor). For the wine version in opensuse, I cannot get to type accented Greek charactes (eg: ά, έ, ή, ό, ύ, ί, ώ etc). If a word has an accented character, and I type it via the deadkey (; in Greek keyboard layout), then it simply doesn't show, in the word I type. To make things more complicated, this problem doesn't exist in wine native programs, eg. notepad.exe or wordpad.exe. There I can type accented characters. The problem was non-existent in previous opensuse version, with wine 1.4.x or 1.6.x (can't remember which). I have no such problem in other distros installed on my harddisks (debian, linuxmint, lubuntu, archlinux, fedora) with current version of wine, 1.17.14.

    Is there any way to solve this or at least to downgrade wine to 1.4 or 1.6?

    (it seems tha the problem relates to non-unicode programs of windows, but I have not encountered any such behaviour in the other distros I mentioned)
    Last edited by anamesa; 09-Mar-2014 at 12:45. Reason: more info

  2. #2
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Wine: no Greek accented characters in wine 1.17.x

    On 03/09/2014 03:46 PM, anamesa wrote:
    >
    > I upgraded to opensuse 13.1 and continued to use wine for two programs:
    > -Yeah Write- (simple word processor, non unicode) and -Atlantis-
    > (wordprocessor). For the wine version in opensuse, I cannot get to type
    > accented Greek charactes (eg: ά, έ, ή, ό, ύ, ί, ώ etc). If a word
    > has an accented character, and I type it via the deadkey (; in Greek
    > keyboard layout), then it simply doesn't show, in the word I type. To
    > make things more complicated, this problem doesn't exist in wine native
    > programs, eg. notepad.exe or wordpad.exe. There I can type accented
    > characters. The problem was non-existent in previous opensuse version,
    > with wine 1.4.x or 1.6.x (can't remember which). I have no such problem
    > in other distros installed on my harddisks (debian, linuxmint, lubuntu,
    > archlinux, fedora) with current version of wine, 1.17.14.
    >
    > Is there any way to solve this or at least to downgrade wine to 1.4 or
    > 1.6?
    >
    > (it seems tha the problem relates to non-unicode programs of windows,
    > but I have not encountered any such behaviour in the other distros I
    > mentioned)
    >


    How are you starting the application? You can try telling WINE you want
    to run it as if it were using Greek. Here is an example:

    LANG="el_GR" wine program.exe

    Also check the font you are using, maybe it is causing the issue!

    As for changing versions, just add a repo from software.opensuse.org (using 1-click install) and then open YaST Software Management and search for WINE, then click the versions tab and change it over to the version you want.
    --
    Bring the Penguins Back! https://features.opensuse.org/316767
    openSUSE 13.1
    KDE 4.11.4

  3. #3

    Default Re: Wine: no Greek accented characters in wine 1.17.x

    Quote Originally Posted by alanbortu View Post
    How are you starting the application? You can try telling WINE you want
    to run it as if it were using Greek. Here is an example:

    LANG="el_GR" wine program.exe

    Also check the font you are using, maybe it is causing the issue!

    As for changing versions, just add a repo from software.opensuse.org (using 1-click install) and then open YaST Software Management and search for WINE, then click the versions tab and change it over to the version you want.
    --
    Bring the Penguins Back! https://features.opensuse.org/316767
    openSUSE 13.1
    KDE 4.11.4
    Thank you for answering.

    I have used the proposed LANG="el_GR" and LC_ALL="el_GR" and of course also with "el_GR.UTF-8" as well (both versions). Greek is visible, copy-paste from notepad renders the accents, the fonts are OK. There must be something else here, and since I cannot find it, I'll just follow your advice and install a previous version the way you suggest (like 1.4 or 1.6) the one that worked in opensuse 12.3 I think. If it doesn't work, then I'll have to compile the program by myself, something I wish to avoid (it takes rather long to compile wine).

    Anyway, thank you for your help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •