Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: YaST stop working

  1. #1

    Angry YaST stop working

    When i start YaST and then i click in something (Ex: Install Software option) i get this error:

    Code:
    Run command: /sbin/yast2 online_update &
    <main>: [BUG] Segmentation fault at 0x00000000000050
    ruby 2.1.1p76 (2014-02-24 revision 45161) [x86_64-linux-gnu]
    
    -- Control frame information -----------------------------------------------
    c:0001 p:0000 s:0002 E:001d68 TOP    [FINISH]
    
    
    -- C level backtrace information -------------------------------------------
    /usr/lib64/libruby.so.2.1(+0x189817) [0x7f6f14593817]
    /usr/lib64/libruby.so.2.1(+0x1898e3) [0x7f6f145938e3]
    /usr/lib64/libruby.so.2.1(+0x6e923) [0x7f6f14478923]
    /usr/lib64/libruby.so.2.1(rb_bug+0xb3) [0x7f6f14478f93]
    /usr/lib64/libruby.so.2.1(+0x12212e) [0x7f6f1452c12e]
    /lib64/libpthread.so.0(+0xfa00) [0x7f6f15e34a00]
    /lib64/libc.so.6(__longjmp_chk+0x10) [0x7f6f1514f020]
    /usr/lib64/libruby.so.2.1(+0x7353b) [0x7f6f1447d53b]
    /usr/lib64/libruby.so.2.1(+0x73a24) [0x7f6f1447da24]
    /usr/lib64/libruby.so.2.1(+0x6f71a) [0x7f6f1447971a]
    /usr/lib64/libruby.so.2.1(+0x70ffe) [0x7f6f1447affe]
    /usr/lib64/libruby.so.2.1(+0x77cbe) [0x7f6f14481cbe]
    /usr/lib64/YaST2/plugin/libpy2lang_ruby.so(_ZN5YRubyC1Ev+0xfe) [0x7f6f14893fbe]
    /usr/lib64/YaST2/plugin/libpy2lang_ruby.so(_ZN5YRuby5yRubyEv+0x41) [0x7f6f148941d1]
    /usr/lib64/YaST2/plugin/libpy2lang_ruby.so(_ZN8Y2CCRubyC2Ev+0x2b) [0x7f6f1488e95b]
    /usr/lib64/YaST2/plugin/libpy2lang_ruby.so(+0xbad6) [0x7f6f1488dad6]
    /lib64/ld-linux-x86-64.so.2(+0xe92a) [0x7f6f176de92a]
    /lib64/ld-linux-x86-64.so.2(+0xea13) [0x7f6f176dea13]
    /lib64/ld-linux-x86-64.so.2(+0x12b68) [0x7f6f176e2b68]
    /lib64/ld-linux-x86-64.so.2(+0xe7e4) [0x7f6f176de7e4]
    /lib64/ld-linux-x86-64.so.2(+0x1235b) [0x7f6f176e235b]
    /lib64/libdl.so.2(+0x102b) [0x7f6f1604402b]
    /lib64/ld-linux-x86-64.so.2(+0xe7e4) [0x7f6f176de7e4]
    /lib64/libdl.so.2(+0x15dd) [0x7f6f160445dd]
    /lib64/libdl.so.2(dlopen+0x31) [0x7f6f160440c1]
    /usr/lib64/liby2.so.4(_ZN16Y2LanguageLoaderC1Ev+0x38f) [0x7f6f16d3876f]
    /usr/lib64/liby2.so.4(+0xdde6) [0x7f6f16d32de6]
    /lib64/ld-linux-x86-64.so.2(+0xe92a) [0x7f6f176de92a]
    /lib64/ld-linux-x86-64.so.2(+0xea13) [0x7f6f176dea13]
    /lib64/ld-linux-x86-64.so.2(+0x11ca) [0x7f6f176d11ca]
    
    -- Other runtime information -----------------------------------------------
    
    /sbin/yast2: line 429:  4972 Segmentation fault      $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Run command: /sbin/yast2 sw_single &
    <main>: [BUG] Segmentation fault at 0x00000000000050
    ruby 2.1.1p76 (2014-02-24 revision 45161) [x86_64-linux-gnu]
    In the GUI nothing happen... I had to execute from the console to get this insane error.

    ¿Why this does not work? and what i have to do to make it work...

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YaST stop working

    On 2014-03-09 15:26, berserkerjmb wrote:
    >
    > When i start YaST and then i click in something (Ex: Install Software
    > option) i get this error:


    What is your repo list? Please post the output of "zypper lr --details"

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3

    Default Re: YaST stop working

    I did this update ruby:

    Code:
    inux-d98d:/home/jesus # zypper update ruby
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: ruby-2.1.1-1.1.x86_64 conflicts with ruby20 provided by ruby20-2.0.0.p247-3.11.1.x86_64
     Solution 1: deinstallation of ruby20-2.0.0.p247-3.11.1.x86_64
     Solution 2: do not install ruby-2.1.1-1.1.x86_64
    
    Choose from above solutions by number or cancel [1/2/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    The following 2 NEW packages are going to be installed:
      ruby-devel ruby-stdlib 
    
    The following package is going to be REMOVED:
      ruby20 
    
    The following 3 packages are going to be upgraded:
      ruby rubygem-fast_gettext rubygem-ruby-dbus 
    
    3 packages to upgrade, 2 new, 1 to remove.
    Overall download size: 6.0 MiB. After the operation, additional 14.2 MiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package ruby-stdlib-2.1.1-1.1.x86_64                                          (1/5),   2.3 MiB ( 11.2 MiB unpacked)
    Retrieving: ruby-stdlib-2.1.1-1.1.x86_64.rpm ...............................................................[done (1.1 MiB/s)]
    Retrieving package ruby-2.1.1-1.1.x86_64                                                 (2/5), 219.3 KiB (850.3 KiB unpacked)
    Retrieving: ruby-2.1.1-1.1.x86_64.rpm ..................................................................................[done]
    Retrieving package rubygem-ruby-dbus-0.11.0-1.2.x86_64                                   (3/5), 132.2 KiB (253.0 KiB unpacked)
    Retrieving: rubygem-ruby-dbus-0.11.0-1.2.x86_64.rpm ....................................................................[done]
    Retrieving package rubygem-fast_gettext-0.8.1-1.3.x86_64                                 (4/5), 156.1 KiB (283.5 KiB unpacked)
    Retrieving: rubygem-fast_gettext-0.8.1-1.3.x86_64.rpm ..................................................................[done]
    Retrieving package ruby-devel-2.1.1-1.1.x86_64                                           (5/5),   3.1 MiB ( 20.1 MiB unpacked)
    Retrieving: ruby-devel-2.1.1-1.1.x86_64.rpm ................................................................[done (1.2 MiB/s)]
    (1/6) Installing: ruby-stdlib-2.1.1-1.1 ................................................................................[done]
    (2/6) Installing: ruby-2.1.1-1.1 .......................................................................................[done]
    (3/6) Removing ruby20-2.0.0.p247-3.11.1 ................................................................................[done]
    (4/6) Installing: rubygem-ruby-dbus-0.11.0-1.2 .........................................................................[done]
    (5/6) Installing: rubygem-fast_gettext-0.8.1-1.3 .......................................................................[done]
    (6/6) Installing: ruby-devel-2.1.1-1.1 .................................................................................[done]
    and now i get this error:

    Code:
    linux-d98d:/home/jesus # yast2
    "Qt Warning - invalid keysym: dead_actute" 
    Run command: /sbin/yast2 sw_single &
    terminate called after throwing an instance of 'YUIPluginException'
      what():  Couldn't load plug-in qt
    YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:803
    /sbin/yast2: line 429: 19101 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

  4. #4

    Default Re: YaST stop working

    when i execute yast (not yast2) from console i get this error when i try to open any module:
    Code:
            UI Syntax Error         
    Couldn't load plug-in ncurses-pkg
           Check the log file!
    LOG:
    Code:
    2014-03-09 16:22:34 <1> linux-d98d.site(21291) [Ruby] clients/online_update_select.rb:115 All preselected patches: 0
    2014-03-09 16:22:34 <2> linux-d98d.site(21291) [ui] YWidget.cc(setKeyboardFocus):596 YPushButton "Next" at 0x7fa0f00062c0 cannot accept the keyboard focus.
    2014-03-09 16:22:34 <2> linux-d98d.site(21291) [Interpreter] modules/ProductFeatures.rb:158 Scripting agent sweeping
    2014-03-09 16:22:34 <2> linux-d98d.site(21291) [scr] ScriptingAgent.cc(parseSingleConfigFile):165 Ignoring re-registration of path '.target'
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPath.cc(YPath):49 Given filename: libyui-ncurses-pkg.so.6
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YSettings.cc(progDir):73 progDir: "/usr/share/YaST2"
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPath.cc(YPath):65 Preferring subdir: /usr/share/YaST2
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPath.cc(YPath):66 Subdir given with filename: 
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPath.cc(YPath):67 Looking for: libyui-ncurses-pkg.so.6
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPath.cc(lsDir):138 Looking in /usr/lib64/yui
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPath.cc(YPath):121 Could NOT find libyui-ncurses-pkg.so.6 by looking recursive inside /usr/lib64/yui
    2014-03-09 16:22:35 <3> linux-d98d.site(21291) [ui] YUIPlugin.cc(YUIPlugin):50 Could not load UI plugin "ncurses-pkg": libyui-ncurses-pkg.so.6: cannot open shared object file: No such file or directory
    2014-03-09 16:22:35 <2> linux-d98d.site(21291) [ui] NCPackageSelectorPluginStub.cc(NCPackageSelectorPluginStub):53     THROW:    Couldn't load plug-in ncurses-pkg
    2014-03-09 16:22:35 <2> linux-d98d.site(21291) [ui] YCP_UI.cc(OpenDialog):583     CAUGHT:   Couldn't load plug-in ncurses-pkg
    2014-03-09 16:22:35 <3> linux-d98d.site(21291) [libycp] clients/online_update_select.rb:138 UI::OpenDialog() failed
    2014-03-09 16:22:35 <1> linux-d98d.site(21291) [ui] YPushButton.cc(setFunctionKey):202 Guessing button role YOKButton for YPushButton "Close" at 0x7fa0f002ba80 from function key F10

  5. #5

    Default Re: YaST stop working

    Quote Originally Posted by robin_listas View Post
    On 2014-03-09 15:26, berserkerjmb wrote:
    >
    > When i start YaST and then i click in something (Ex: Install Software
    > option) i get this error:


    What is your repo list? Please post the output of "zypper lr --details"

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)
    Code:
    #  | Alias                     | Name                                   | Enabled | Refresh | Priority | Type   | URI                                                                                   | Service                                                                                                                                                                               
    ---+---------------------------+----------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------+--------                                                                                                                                                                               
     1 | ADDED-SUSE_SECURITY       | ADDED-SUSE SECURITY                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/security/openSUSE_13.1/                     |                                                                                                                                                                                       
     2 | AMD/ATI-FGLRX             | AMD/ATI-FGLRX                          | Yes     | Yes     |   99     | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/                                 |                                                                                                                                                                                       
     3 | Emulators_Wine            | Wine (openSUSE_13.1)                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.1/              |                                                                                                                                                                                       
     4 | Packman Repository        | Packman Repository                     | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                              |                                                                                                                                                                                       
     5 | VLC                       | VLC                                    | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/12.3                               |                                                                                                                                                                                       
     6 | devel:languages:R:patched | devel:languages:R:patched              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/R:/patched/openSUSE_13.1/ |                                                                                                                                                                                       
     7 | dvd                       | dvd                                    | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                                  |                                                                                                                                                                                       
     8 | libdvdcss                 | DVD Repository                         | Yes     | No      |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                                  |        
     9 | mozilla                   | Mozilla based projects (openSUSE_13.1) | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.1/                      |        
    10 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                     | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-hp_DVD_A_DS8A5LH_108160024173,/dev/sr0             |        
    11 | openSUSE:Factory          | openSUSE:Factory                       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/oss/                                        |        
    12 | packman                   | packman                                | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/13.1/                                       |        
    13 | repo-debug                | openSUSE-13.1-Debug                    | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                        |        
    14 | repo-debug-update         | openSUSE-13.1-Update-Debug             | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                                       |        
    15 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                               |        
    16 | repo-non-oss              | openSUSE-13.1-Non-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                          |        
    17 | repo-oss                  | openSUSE-13.1-Oss                      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                              |        
    18 | repo-source               | openSUSE-13.1-Source                   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/                       |        
    19 | repo-update               | openSUSE-13.1-Update                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                             |        
    20 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                     |

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YaST stop working

    On 2014-03-09 16:26, berserkerjmb wrote:

    > Code:
    > --------------------
    >
    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > ---+---------------------------+----------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
    > 1 | ADDED-SUSE_SECURITY | ADDED-SUSE SECURITY | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 2 | AMD/ATI-FGLRX | AMD/ATI-FGLRX | Yes | Yes | 99 | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/ |
    > 3 | Emulators_Wine | Wine (openSUSE_13.1) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 4 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.1/ |
    > 5 | VLC | VLC | Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/12.3 |
    > 6 | devel:languages:Ratched | devel:languages:Ratched | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 7 | dvd | dvd | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
    > 8 | libdvdcss | DVD Repository | Yes | No | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
    > 9 | mozilla | Mozilla based projects (openSUSE_13.1) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 10 | openSUSE-13.1-1.10 | openSUSE-13.1-1.10 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-hp_DVD_A_DS8A5LH_108160024173,/dev/sr0 |
    > 11 | openSUSE:Factory | openSUSE:Factory | Yes | Yes | 99 | yast2 | http://download.opensuse.org/factory/repo/oss/ |
    > 12 | packman | packman | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/13.1/ |
    > 13 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |
    > 14 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    > 15 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    > 16 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    > 17 | repo-oss | openSUSE-13.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    > 18 | repo-source | openSUSE-13.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    > 19 | repo-update | openSUSE-13.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    > 20 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/ |
    >
    > --------------------


    Remove the factory repository (number 11), and roll back all the
    packages that came from it. This is not an option.

    You have two packman repos: choose one.

    Packman and videolan have conflicting packages. Use one or the other -
    unless you know what you are doing.

    If that does not help, you will have to consider removing the R repo and
    revert what you took from it. Ruby is now a system critical component,
    touching it is not advisable unless you know what you are doing.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7

    Default Re: YaST stop working

    Quote Originally Posted by robin_listas View Post
    Remove the factory repository (number 11), and roll back all the packages that came from it. This is not an option. You have two packman repos: choose one. Packman and videolan have conflicting packages. Use one or the other - unless you know what you are doing. If that does not help, you will have to consider removing the R repo and revert what you took from it. Ruby is now a system critical component, touching it is not advisable unless you know what you are doing. -- Cheers / Saludos, Carlos E. R. (from 13.1 x86_64 "Bottle" at Telcontar)
    i did "zypper rm yast2" and 2000 packages were removed" i destoyed everything T_T then i installed everything again but there is a lot of conflics

  8. #8

    Default Re: YaST stop working

    Quote Originally Posted by berserkerjmb View Post
    i did "zypper rm yast2" and 2000 packages were removed" i destoyed everything T_T then i installed everything again but there is a lot of conflics
    How i revert what i toke from those repos ?


    EDIT: I have done zypper dup

  9. #9

    Default Re: YaST stop working

    i think the problem was that factory repo, i dont know how it managed to get there...

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YaST stop working

    On 2014-03-09 17:56, berserkerjmb wrote:
    >
    > i think the problem was that factory repo, i dont know how it managed to
    > get there...


    Yes. indeed, installing a factory repo on a normal system, and
    installing things from it, breaks the system.

    Yes, a "zypper dup" is one of the ways to do the reversion, but it is
    very aggressive. As YaST did not work, it was probably the only way to
    do it.

    With "zypper install" it may be also possible, but you have to name
    every package to change, and perhaps tell it to force the issue.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •