Results 1 to 8 of 8

Thread: How to make Lid Closed event ignored and disable to "suspend" event

  1. #1

    Default How to make Lid Closed event ignored and disable to "suspend" event

    Hi,
    I've been struggling with this since some time and wasn't able to find a working solution till now. What I want to do is to disable the "suspend" event once the lid of the laptop is closed.
    I can do this once I'm logged in through the KDE Powermanagement setup.
    But I also want to prevent the suspend just when the laptop boots, nobody is logged in and I close the lid. (I just want to SSH to the laptop and keep it running).
    I've tried to set the "HandleLidSwitch=ignore" under /etc/systemd/logind.conf but it didn't make any change.
    Where can I set this, so that it also works when nobody is logged in?
    Many thanks

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to make Lid Closed event ignored and disable to "suspend"event

    On 2014-03-08 18:36, dubak1 wrote:
    > I can do this once I'm logged in through the KDE Powermanagement setup.
    > But I also want to prevent the suspend just when the laptop boots,
    > nobody is logged in and I close the lid. (I just want to SSH to the
    > laptop and keep it running).


    Some laptops overheat in this situation. Either the fan intake or the
    exhaust is on the lid side: closing it blocks the ventilation. Also,
    often the keyboard is made of aluminum underneath for heat dissipation.

    I leave mine open.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3

    Default Re: How to make Lid Closed event ignored and disable to "suspend"event

    Hi,
    the problem has nothing to do with oveheating. The laptop is cool (it's the eee PC) and the suspend happens in the very same second when I close the lid.
    And I'm also monitoring the temperature of the laptop through Nagios ;-)

    Quote Originally Posted by robin_listas View Post
    On 2014-03-08 18:36, dubak1 wrote:
    > I can do this once I'm logged in through the KDE Powermanagement setup.
    > But I also want to prevent the suspend just when the laptop boots,
    > nobody is logged in and I close the lid. (I just want to SSH to the
    > laptop and keep it running).


    Some laptops overheat in this situation. Either the fan intake or the
    exhaust is on the lid side: closing it blocks the ventilation. Also,
    often the keyboard is made of aluminum underneath for heat dissipation.

    I leave mine open.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to make Lid Closed event ignored and disable to "suspend"event

    On 2014-03-08 19:36, dubak1 wrote:
    >
    > Hi,
    > the problem has nothing to do with oveheating. The laptop is cool (it's
    > the eee PC) and the suspend happens in the very same second when I close
    > the lid.
    > And I'm also monitoring the temperature of the laptop through Nagios ;-)


    You misunderstood me.

    I meant that suspend maybe forced and intentional by the system because
    it thinks that it will overheat if you close the lid. So, to avoid that
    problem, it suspends immediately the instant you close the lid. Not
    because it overheats, but to avoid it overheating.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5
    Join Date
    Jan 2014
    Location
    Florida
    Posts
    95

    Default Re: How to make Lid Closed event ignored and disable to "suspend" event

    Do you have the laptop kernel packages installed? You might need something in those to access the acpi.

  6. #6

    Default Re: How to make Lid Closed event ignored and disable to "suspend" event

    What do you mean by the laptop kernel packages? I've tryied to install everything I found in YAST that includes "laptop" and still without success.

    By the way - if I close the laptop lid just right after it starts booting (e.g. still before GRUB), then everything is OK, because the close lid event never comes. But it would be nice to have the possibility to open the lid if needed and close it again ;-)

    Quote Originally Posted by J_Andrew View Post
    Do you have the laptop kernel packages installed? You might need something in those to access the acpi.

  7. #7
    Join Date
    Jan 2014
    Location
    Florida
    Posts
    95

    Default Re: How to make Lid Closed event ignored and disable to "suspend" event

    In addition to setting "HandleLidSwitch=ignore" under /etc/systemd/logind.conf have you also tried adding "LidSwitchIgnoreInhibited=off" ?

  8. #8

    Default Re: How to make Lid Closed event ignored and disable to "suspend" event

    Quote Originally Posted by J_Andrew View Post
    In addition to setting "HandleLidSwitch=ignore" under /etc/systemd/logind.conf have you also tried adding "LidSwitchIgnoreInhibited=off" ?
    Bit of an old thread, I know, but I just wanted to say that this solution worked for me. My HP laptop has an unsupported dual graphics card setup, and I disabled one of the cards at boot, but resuming from suspend would result in the screen staying black. This solution made it so that I can close the lid for a few minutes without any problems.

    Thanks for posting!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •