Results 1 to 4 of 4

Thread: Kaffeine not working on OpenSUSE 13.1 (64bit)

  1. #1
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    298

    Default Kaffeine not working on OpenSUSE 13.1 (64bit)

    Hello,

    I recently did a fresh install of OpenSUSE 13.1 (64bit) and, for some reason, Kaffeine is not working. When I attempt to play any video then I simply get a black screen and no video. I have tried a number of formats including .avi, .flv, .mov, .mpg, .mp4 and .ac3 but nothing works. I have installed the multimedia codecs from the 1-click install at http://opensuse-community.org/ which is referred by the "Multimedia In One Click" sticky thread (first thread in this forum) and I have verified that the following programs were successfully installed:

    libxine2-codecs
    k3b-codecs
    ffmpeg
    lame
    gstreamer-0_10-plugins-bad
    gstreamer-0_10-plugins-ugly
    gstreamer-0_10-plugins-ugly-orig-addon
    gstreamer-0_10-plugins-ffmpeg
    libdvdcss2

    In fact, I have reinstalled all of these in addition to Kaffeine itself several times but no joy.

    All the while, the following programs work just fine:

    Dragon Player
    KPlayer
    SMPlayer
    MPlayer
    VLC Media Player
    Amarok

    I would blame the problem on the KDE codecs except Dragon Player and Kplayer use the same KDE codecs as Kaffeine.

    At the same time, I have another OpenSUSE 13.1 (64bit) installation where Kaffeine is working fine. In any event, I am stumped. So, if anyone has any ideas, then please let me know.

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.2 (x86_64) | HP ZBook Fury 17 G7 (17")
    Laptop #2: OpenSUSE Leap 15.2 (x86_64) | System76 Darter (14")

  2. #2
    Join Date
    Jun 2011
    Location
    Brazil - São Paulo
    Posts
    21

    Default Re: Kaffeine not working on OpenSUSE 13.1 (64bit)

    Hi Gordon,

    I was having problems with recent installations of KDE and XFCE in OpenSUSE. All fresh installation and "One-Click Install" don't worked for me.

    So... a guy help me in this Thread: https://forums.opensuse.org/showthre...-Totem-on-XFCE

    Off course, Kaffeine use Xine codecs, but I think that will resolve.

    1 - First I added the repositories in Yast -> Software Manager -> Configuration -> Repositories -> Add -> Community Repositories and checked Packman and libdvdcss (if you want to play DVDs)
    2 - Install plugins
    3 - Full repository Vendor change update to Packman -> http://en.opensuse.org/SDB:Vendor_ch..._Vendor_change
    But here, I cannot do it in Yast, because the displayed options doesn't exist for me. The zypper repos will print the repositories, I get the second column for the next command.
    Code:
    sudo zypper repos
    sudo zypper dup --from ftp.gwdg.de-suse
    4 - Remove .cache folder on my Home directory:
    Code:
    rm -rf .cache/
    You must have read that VLC and Packman repositories will mess all multimedia codecs. So, don't enable these two.

    Another think, VLC and Mplayer, for what I remember use they own codecs, this is why most of time they work.

    Try that!

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Kaffeine not working on OpenSUSE 13.1 (64bit)

    Quote Originally Posted by gldickens3 View Post
    Hello,

    I recently did a fresh install of OpenSUSE 13.1 (64bit) and, for some reason, Kaffeine is not working. When I attempt to play any video then I simply get a black screen and no video. I have tried a number of formats including .avi, .flv, .mov, .mpg, .mp4 and .ac3 but nothing works. I have installed the multimedia codecs from the 1-click install at http://opensuse-community.org/ which is referred by the "Multimedia In One Click" sticky thread (first thread in this forum) and I have verified that the following programs were successfully installed:

    libxine2-codecs
    k3b-codecs
    ffmpeg
    lame
    gstreamer-0_10-plugins-bad
    gstreamer-0_10-plugins-ugly
    gstreamer-0_10-plugins-ugly-orig-addon
    gstreamer-0_10-plugins-ffmpeg
    libdvdcss2

    In fact, I have reinstalled all of these in addition to Kaffeine itself several times but no joy.

    All the while, the following programs work just fine:

    Dragon Player
    KPlayer
    SMPlayer
    MPlayer
    VLC Media Player
    Amarok

    I would blame the problem on the KDE codecs except Dragon Player and Kplayer use the same KDE codecs as Kaffeine.

    At the same time, I have another OpenSUSE 13.1 (64bit) installation where Kaffeine is working fine. In any event, I am stumped. So, if anyone has any ideas, then please let me know.

    Thanks,

    Gordon
    Ideas?
    See if the problem exists for a test user.
    Start kaffeine from a terminal window. It will throw output in the terminal. Try to play a video and check the output in the terminal.
    Meanwhile, post output from
    Code:
    zypper lr -d
    between CODE tags, the # in the editor
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Kaffeine not working on OpenSUSE 13.1 (64bit)

    This does not sound like a codec problem to me, more like a video output problem.

    What video card do you have? What driver do you use?

    What output do you get when you run kaffeine in a terminal window?

    Make sure you have libxine2 from Packman. That one uses vdpau by default, which should be the best choice for nvidia cards. The openSUSE package doesn't include vdpau support and uses VA-API which doesn't work with nvidia cards, unless you install vdpau-video.

    Try to set a different video.driver in ~/.kde4/share/apps/kaffeine/xine-config. Does it work with "xshm" for example? That one should work in any case, but doesn't use any hardware acceleration whatsoever.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •