Results 1 to 7 of 7

Thread: [opensuse 12.2] cups won't start at boot

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    490

    Default [opensuse 12.2] cups won't start at boot

    Greetings !!

    I checked if the symlinks in /etc/systemd/system/multi-user.target.wants, /etc/systemd/system/printer.target.wants and /etc/systemd/system/socket.target.wants were set and they are.
    Funny thing some of them have ///lib/systemd/system/... target instead of /lib/systemd/system/...

    I have to run the cupsd using init.d.

    Is there a way to have the cupsstarted up at boot as chkconfig -l asks.

    Code:
    cups                      0:off  1:off  2:on   3:on   4:off  5:on   6:off
            cups-lpd:           off
    For information; I tried with cups-lpd on but it's the same behavior, cups is dead when calling cupsd status as I just get a console on X after login.Lot of things have changed I jumpedfrom 11.4 to 12.2 and I have to retrieve my marks ^^

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: [opensuse 12.2] cups won't start at boot

    Try
    Code:
    systemctl enable cups.service
    then
    Code:
    systemctl start cups.service
    After a reboot, cupsd should be running. Check via systemd with
    Code:
    systemctl status cups.service

  3. #3
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    490

    Default Re: [opensuse 12.2] cups won't start at boot

    Code:
    antares:/var/log # systemctl status cups.service
    cups.service - CUPS Printing Service
              Loaded: loaded (/lib/systemd/system/cups.service; enabled)
              Active: inactive (dead)
              CGroup: name=systemd:/system/cups.service
    
    Mar 07 20:13:07 antares cupsd[5775]: No SubscriptionPrivateValues defined in policy allowallforanybody - using defaults.
    Mar 08 15:49:02 antares cupsd[5657]: No limit for Validate-Job defined in policy allowallforanybody and no suitable template found.
    Mar 08 15:49:02 antares cupsd[5657]: No limit for Cancel-Jobs defined in policy allowallforanybody and no suitable template found.
    Mar 08 15:49:02 antares cupsd[5657]: No limit for Cancel-My-Jobs defined in policy allowallforanybody and no suitable template found.
    Mar 08 15:49:02 antares cupsd[5657]: No limit for Close-Job defined in policy allowallforanybody and no suitable template found.
    Mar 08 15:49:02 antares cupsd[5657]: No limit for CUPS-Get-Document defined in policy allowallforanybody and no suitable template found.
    Mar 08 15:49:02 antares cupsd[5657]: No JobPrivateAccess defined in policy allowallforanybody - using defaults.
    Mar 08 15:49:02 antares cupsd[5657]: No JobPrivateValues defined in policy allowallforanybody - using defaults.
    Mar 08 15:49:02 antares cupsd[5657]: No SubscriptionPrivateAccess defined in policy allowallforanybody - using defaults.
    Mar 08 15:49:02 antares cupsd[5657]: No SubscriptionPrivateValues defined in policy allowallforanybody - using defaults.
    That's all I have...
    lpq shows nothing and firefox http://localhost:631 shows nothing (address not found -- 404)

    /var/log/cups/error_log

    E [08/Mar/2014:15:49:02 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [08/Mar/2014:15:49:02 +0100] Unable to bind socket for address 127.0.0.1:631 - Address already in use.

    I opened 'custom rule" the udp/tcp port 631 in iptables for all networks (0.0.0.0)

    Are these informations could explain what is going on ?
    Last edited by soundlord; 08-Mar-2014 at 08:24. Reason: mis spelling

  4. #4
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    490

    Default Re: [opensuse 12.2] cups won't start at boot

    It is said that newer versions of cups activates the daemon if only one printer is connected... as a "hotplug".
    I just plugged on my printer... and cups is activated.

    That's what I said: jumping from 11.4 to 12.2 has it's bunch of surprises ^^

    This thread is now closed/solved.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: [opensuse 12.2] cups won't start at boot

    On 2014-03-08 16:26, soundlord wrote:


    > E [08/Mar/2014:15:49:02 +0100] Unable to bind socket for address
    > 127.0.0.1:631 - Address already in use.


    Try google for that message. It rings a bell.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: [opensuse 12.2] cups won't start at boot

    Quote Originally Posted by soundlord View Post
    It is said that newer versions of cups activates the daemon if only one printer is connected... as a "hotplug".
    I just plugged on my printer... and cups is activated.
    Sounds like you're still playing catch up. Services are now managed by systemd, and a move was made to socket-activation (some time back), although there has been recent developer debate about whether it should be used or not. (FWIW, I have cups.service configured to start up without using socket-activation, so that it is running at boot.)

  7. #7
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    490

    Default Re: [opensuse 12.2] cups won't start at boot

    Did what adviced here: https://forums.opensuse.org/showthread.php/494878

    It works for me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •