Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KDM Causes Black Screen

  1. #1

    Default KDM Causes Black Screen

    During bootup, when 'kdm' is selected as the default manager in /etc/sysconfig/displaymanger, I am left with a black screen -- no kde desktop.

    If I then type" Ctrl-Alt-f1" I can get a console prompt. I then login, and can run 'sudo startx', and I get to a kde desktop as root, not exactly what I want.

    (As an aside, How can I run startx as my non-root user without getting permissions errors, etc?)

    If change /etc/sysconfig/displaymanger to use "xdm" or "gdm" for example as the default, I get an xwindows screen with a login box. Not very useful, but at least it shows different behavior.

    Any ideas on what I can do to recover from this?

    I already have remove .kde4 from my home directory.

    I am running 13.1 in Vbox 4.3.8. I don't think this is a Vbox issue. I have tried moving this 'clone' in on other physical machines with the same results.

    Thanks for your help -- spent a ridiculous amount of time on this already.

  2. #2

    Default Re: KDM Causes Black Screen

    Update on my third sentence above. From text mode I did "sudo chmod 4711 /usr/sbin/Xorg" (the path may differ). After that, I was/am able to run "startx" as a non-root user, successfully.

    Still trying to learn how to fix things so I can boot into KDE again.

  3. #3

    Default Re: KDM Causes Black Screen

    For some strange reason there recently has been a number of "startx by user" questions. For some answers, see:
    - https://forums.opensuse.org/showthre...87#post2628587
    - https://forums.opensuse.org/showthre...38#post2628838

  4. #4

    Default Re: KDM Causes Black Screen

    Thanks for the response. Any idea how to diagnose/fix whatever is causing the black screen while at the same time startx from text mode will start kde?

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: KDM Causes Black Screen

    To be honest you probably should not use startx any more it is being phased out. I always used init 5 and that still works if run as root. Will bring up the KDM or if autologin is set start KDE. In fact it may be where the problem is. so try as root init 5 see what error messages may be generated. Might give a clue

  6. #6

    Default Re: KDM Causes Black Screen

    root>init 5 hangs at a small green chameleon screen.
    startx will get KDE going successfully.

    I want to fix my system so it boots successfully into KDE.
    I don't want to have to 'startx' or 'init 5' from text mode.
    I am only doing that now in an effort to troubleshoot this situation.

    Any ideas? Thanks.

  7. #7

    Default Re: KDM Causes Black Screen

    On 03/07/2014 03:06 PM, steve98177 pecked at the keyboard and wrote:
    > root>init 5 hangs at a small green chameleon screen.
    > startx will get KDE going successfully.
    >
    > I want to fix my system so it boots successfully into KDE.
    > I don't want to have to 'startx' or 'init 5' from text mode.
    > I am only doing that now in an effort to troubleshoot this situation.
    >
    > Any ideas? Thanks.
    >
    >


    As root or using sudo:

    Code:
    systemctl enable runlevel5.target
    Should get you booting to the KDE login screen after a reboot.

    Ken

  8. #8

    Default Re: KDM Causes Black Screen

    Ken, what would "target" be? Doesn't work as stated. Thanks

  9. #9

    Default Re: KDM Causes Black Screen

    On 03/08/2014 01:06 PM, steve98177 pecked at the keyboard and wrote:
    > Ken, what would "target" be? Doesn't work as stated. Thanks
    >
    >


    Sorry still getting used to systemd. Should be:

    Code:
    systemctl set-default runlevel5.target
    man systemctrl is your friend.

    Ken

  10. #10

    Default Re: KDM Causes Black Screen

    I'm also having this issue.
    It happens every 3 or 4 weeks, usually when I have an important project due.

    I'm running openSuse 13.1 64bit natively, not in a virtual machine
    I turn my machine on and it just gets to a a black screen with the mouse pointer.
    Every thing is normal including the 5 icons fading in on the boot/splash screen, and everything fades out just before the desktop background fades in, but the desktop never fades in, it just stays black.

    I can move the mouse around, have no right click menu. I can press the power button and I get the logout/restart/turn off menu.
    I can logout, then log in again but I just get the same black screen with the mouse pointer.
    I can get to text mode with Ctrl Alt F1.
    I shut down my machine every night.

    Is there any error log I should check?

    Usually I press the power button, login, turn off auto login, restart, turn on auto login and it's fine for a while, but then I do some updates and it breaks again.

    Right now that's not working and I can't workout how to get to the desktop.

    13.1 is not one of the reliable versions of openSUSE 11.2 or 11.4 was better than this. I've been a user since 9.2 and the quality is deteriorating.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •