Results 1 to 4 of 4

Thread: How to disable keyboard sleep/hibernate key?

  1. #1
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    215

    Default How to disable keyboard sleep/hibernate key?

    Having spilt a glass of wine into my old keyboard I rushed out and bought a cheapo replacement Genius KB-06XE keyboard which comes with a sleep/hibernate key.

    Is there any way of disabling this key under KDE because it's starting to drive me up the wall. It's just too easy to press by mistake and put the PC into hibernation.

    The key has no effect on console screens (tty1 etc), nor in TWM or IceWM (I don't use Gnome) so it's just KDE I want to sort out.

    The old keyboard was configured as a Generic 104 Key - I've tried both that, Generic 105 Key and a few others in the hope that the Advance tab in Keyboard System Settings might show a new configuration option but nothing so far.

    I've got some info from showkey but I don't know where to go forward from here
    showkey -a
    0xe00 0x5f 0x5f 0xe0 0xdf
    showkey -k
    keycode 142 press
    keycode 142 release
    showkey -a
    ^@ 0 0000 0x00


    Anyone know how to solve this or do I need to resort to screwdriver and wire cutters or superglue

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: How to disable keyboard sleep/hibernate key?

    You seem to use KDE (as I found out somnewhere halfway down your post), but I never found which version of openSUSE

    I can not find anything in KDE Systyem Settings > Hardware > Input devices > Keyboard.

    Maybe jamming with some papersheet is the best.

    BTW, You tried to make your computer output better radable, which is very nice. But next time it is better (and easier, I hope) to use CODE tags around it. It is the # button in the tool bar.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    215

    Default Re: How to disable keyboard sleep/hibernate key?

    Quote Originally Posted by hcvv View Post
    You seem to use KDE (as I found out somnewhere halfway down your post), but I never found which version of openSUSE

    I can not find anything in KDE Systyem Settings > Hardware > Input devices > Keyboard.

    Maybe jamming with some papersheet is the best.

    BTW, You tried to make your computer output better radable, which is very nice. But next time it is better (and easier, I hope) to use CODE tags around it. It is the # button in the tool bar.
    FYI - OpenSUSE 12.3, KDE 4.12 -I tried the CODE tags but though the switch to simple courier font looked neater.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: How to disable keyboard sleep/hibernate key?

    Quote Originally Posted by fudokai View Post
    FYI - OpenSUSE 12.3, KDE 4.12 -I tried the CODE tags but though the switch to simple courier font looked neater.
    Thsi has nothig to do wth your version of opeSUSE, or with your operating system at all (some people do post using MS Windos). It is a forums software feature. and we ask you to please use it. It does much more then only changing to a fixed font. To many to quote here.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •