Results 1 to 6 of 6

Thread: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support - disconnect

  1. #1

    Default AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support - disconnect

    Hi, I'm a new on linux, openSUSE.

    I tried installing Fedora 20, Ubuntu 13.10, and finally openSUSE 13.1.

    But, I stucked in a problem. The wireless.

    I use wireless in some places, almost are connected well and rapidly but an AP don't connect in my dormitory.

    dmesg shows

    [ 110.357449] wlp4s0: AP 00:26:66:1a:e3:b8 changed bandwidth, new config is 2447 MHz, width 1 (2447/0 MHz)
    [ 110.357463] wlp4s0: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support - disconnect
    [ 110.368571] cfg80211: Calling CRDA to update world regulatory domain
    [ 110.370905] cfg80211: World regulatory domain updated:
    [ 110.370909] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 110.370911] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 110.370913] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 110.370915] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 110.370916] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 110.370918] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 110.902208] wlp4s0: authenticate with 00:26:66:1a:e3:b8
    [ 110.914825] wlp4s0: send auth to 00:26:66:1a:e3:b8 (try 1/3)
    [ 110.960507] wlp4s0: authenticated
    [ 110.961740] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    [ 111.066821] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 2/3)
    [ 111.095570] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=0 aid=1)
    [ 111.098560] wlp4s0: associated
    [ 111.098652] cfg80211: Calling CRDA for country: KR
    [ 111.101369] cfg80211: Regulatory domain changed to country: KR
    [ 111.101373] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 111.101376] cfg80211: (2402000 KHz - 2482000 KHz @ 20000 KHz), (N/A, 2000 mBm)
    [ 111.101378] cfg80211: (5170000 KHz - 5250000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 111.101379] cfg80211: (5250000 KHz - 5330000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 111.101381] cfg80211: (5490000 KHz - 5630000 KHz @ 20000 KHz), (300 mBi, 3000 mBm)
    [ 111.101383] cfg80211: (5735000 KHz - 5815000 KHz @ 20000 KHz), (300 mBi, 3000 mBm)
    [ 111.175643] wlp4s0: AP 00:26:66:1a:e3:b8 changed bandwidth, new config is 2447 MHz, width 1 (2447/0 MHz)
    [ 111.175648] wlp4s0: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support - disconnect
    [ 111.188723] cfg80211: Calling CRDA to update world regulatory domain
    [ 111.191467] cfg80211: World regulatory domain updated:
    [ 111.191471] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 111.191474] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 111.191476] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 111.191477] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 111.191479] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 111.191481] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 111.721949] wlp4s0: authenticate with 00:26:66:1a:e3:b8
    [ 111.733637] wlp4s0: send auth to 00:26:66:1a:e3:b8 (try 1/3)
    [ 111.767485] wlp4s0: authenticated
    [ 111.768262] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    [ 111.780912] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=0 aid=1)
    [ 111.788073] wlp4s0: associated
    [ 111.788377] cfg80211: Calling CRDA for country: KR
    [ 111.790889] cfg80211: Regulatory domain changed to country: KR
    [ 111.790893] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 111.790896] cfg80211: (2402000 KHz - 2482000 KHz @ 20000 KHz), (N/A, 2000 mBm)
    [ 111.790898] cfg80211: (5170000 KHz - 5250000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 111.790900] cfg80211: (5250000 KHz - 5330000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 111.790901] cfg80211: (5490000 KHz - 5630000 KHz @ 20000 KHz), (300 mBi, 3000 mBm)
    [ 111.790903] cfg80211: (5735000 KHz - 5815000 KHz @ 20000 KHz), (300 mBi, 3000 mBm)
    [ 116.878781] IPv4: martian source 255.255.255.255 from 192.168.1.1, on dev wlp4s0
    [ 116.878786] ll header: 00000000: ff ff ff ff ff ff 00 26 66 1a e3 b9 08 00 .......&f.....
    [ 154.615239] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
    [ 172.713596] SFW2-INext-DROP-DEFLT IN=wlp4s0 OUT= MAC= SRC=fe80:0000:0000:0000:6a17:29ff:fe49:4995 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
    [ 300.854633] SFW2-INext-DROP-DEFLT IN=wlp4s0 OUT= MAC= SRC=fe80:0000:0000:0000:6a17:29ff:fe49:4995 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44

    It sometimes connected rapidly, and always connect rapidly on my Windows 7.


    I don't write English well, but I written this message because I want to solve this problem. I hope you can understand my English.

    Here is my linux info (uname -a)
    ubsystem: Intel Corporation Centrino Wireless-N 2230 BGN [8086:4262]
    Flags: bus master, fast devsel, latency 0, IRQ 47
    Memory at e3500000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: <access denied>
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi





    Linux linux-0mc3.site 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux
    Thanks for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,775

    Default Re: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support - disconnect

    Hello, I see you are new here: Welcome.

    I hope some Wireless gurus will soon tune in here, but in the meantime allow me to tell you about a feature in the forums software hat is not easy to find, but very important. Whenever you want to post computer code (as you did above), please use CODE tags (and not the QUOTE tags you used). You get the by clicking on the # button in the tool bar.

    Also please, when applicable post the prompt, the command, the output and the next prompt between the tags. That spares you the effort of telling: "Here is my linux info (uname -a)",, because it is all there execatly as you did it.
    Henk van Velden

  3. #3

    Default Re: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support - disconnect

    Quote Originally Posted by hcvv View Post
    Hello, I see you are new here: Welcome.

    I hope some Wireless gurus will soon tune in here, but in the meantime allow me to tell you about a feature in the forums software hat is not easy to find, but very important. Whenever you want to post computer code (as you did above), please use CODE tags (and not the QUOTE tags you used). You get the by clicking on the # button in the tool bar.

    Also please, when applicable post the prompt, the command, the output and the next prompt between the tags. That spares you the effort of telling: "Here is my linux info (uname -a)",, because it is all there execatly as you did it.

    Thank you for your helpful tips and kindness. I'll follow these rules after this time.

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support- disconnect

    This problem is very interesting. When your driver is first loaded, the
    regulatory rule for 2.4 GHz says

    Code:
    cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300mBi, 2000 mBm)
    After you load the regulations for KR (South Korea), that rule is changed to

    Code:
    cfg80211:   (2402000 KHz - 2482000 KHz @ 20000 KHz), (N/A, 2000 mBm)
    The difference is that the first rule allows the usage of of 802.11n HT
    capability with a bandwidth of 40 MHz, but the second says that the bandwidth is
    restricted to 20000 KHz, thus only 802.11g is supported. I do not understand why
    this change triggers this message. I suspect a bug in the MAC layer, and I plan
    to question this in the wireless mailing list.

    To test a possible workaround, do the following:

    Code:
    sudo /sbin/modprobe -rv iwlwifi
    sudo /sbin/modprobe -v iwlwifi 11n_disable=1
    That change will be lost when you reboot. If it fixes the problem, the following
    command will make it permanent:

    Code:
    su -c "echo \"options iwlwifi 11n_disable=1\" > /etc/modprobe.d/50-iwlwifi.conf"
    That command is a little tricky. Copy and paste it if possible.



  5. #5

    Default Re: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support- disconnect

    Quote Originally Posted by lwfinger View Post
    This problem is very interesting. When your driver is first loaded, the
    regulatory rule for 2.4 GHz says

    Code:
    cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300mBi, 2000 mBm)
    After you load the regulations for KR (South Korea), that rule is changed to

    Code:
    cfg80211:   (2402000 KHz - 2482000 KHz @ 20000 KHz), (N/A, 2000 mBm)
    The difference is that the first rule allows the usage of of 802.11n HT
    capability with a bandwidth of 40 MHz, but the second says that the bandwidth is
    restricted to 20000 KHz, thus only 802.11g is supported. I do not understand why
    this change triggers this message. I suspect a bug in the MAC layer, and I plan
    to question this in the wireless mailing list.

    To test a possible workaround, do the following:

    Code:
    sudo /sbin/modprobe -rv iwlwifi
    sudo /sbin/modprobe -v iwlwifi 11n_disable=1
    That change will be lost when you reboot. If it fixes the problem, the following
    command will make it permanent:

    Code:
    su -c "echo \"options iwlwifi 11n_disable=1\" > /etc/modprobe.d/50-iwlwifi.conf"
    That command is a little tricky. Copy and paste it if possible.

    Thank you for your answer, but now I'm stuck on another problem.
    I was run your instruction following and was reboot,
    Code:
    su -c "echo \"options iwlwifi 11n_disable=1\" > /etc/modprobe.d/50-iwlwifi.conf"
    then these message shown up on dmesg :

    Code:
    
    [  908.223178] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    [  908.224542] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=18 aid=8672)
    [  908.224546] wlp4s0: 00:26:66:1a:e3:b8 denied association (code=18)
    [  908.239834] wlp4s0: deauthenticating from 00:26:66:1a:e3:b8 by local choice (reason=3)
    [  918.790207] wlp4s0: authenticate with 00:26:66:1a:e3:b8
    [  918.818763] wlp4s0: send auth to 00:26:66:1a:e3:b8 (try 1/3)
    [  918.877191] wlp4s0: authenticated
    [  918.878232] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    [  918.880167] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=18 aid=8672)
    [  918.880205] wlp4s0: 00:26:66:1a:e3:b8 denied association (code=18)
    [  918.893888] wlp4s0: deauthenticating from 00:26:66:1a:e3:b8 by local choice (reason=3)
    [  977.075389] wlp4s0: authenticate with 00:26:66:1a:e3:b8
    [  977.079037] wlp4s0: send auth to 00:26:66:1a:e3:b8 (try 1/3)
    [  977.080175] wlp4s0: authenticated
    [  977.080458] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    [  977.082376] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=18 aid=8672)
    [  977.082380] wlp4s0: 00:26:66:1a:e3:b8 denied association (code=18)
    [  977.088847] wlp4s0: deauthenticating from 00:26:66:1a:e3:b8 by local choice (reason=3)
    It seems getting worse. What means "denied association" ?


    P.S. My laptop is "Lenovo Thinkpad e431 6277-2wk".

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: AP 00:26:66:1a:e3:b8 changed bandwidth in a way we can't support- disconnect

    On 03/08/2014 06:46 AM, dfkaruna wrote:
    >
    > lwfinger;2628781 Wrote:
    >> This problem is very interesting. When your driver is first loaded, the
    >> regulatory rule for 2.4 GHz says
    >>
    >>>

    > Code:
    > --------------------
    > > >

    > > cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300mBi, 2000 mBm)
    > >

    > --------------------
    >>>

    >>
    >> After you load the regulations for KR (South Korea), that rule is
    >> changed to
    >>
    >>>

    > Code:
    > --------------------
    > > >

    > > cfg80211: (2402000 KHz - 2482000 KHz @ 20000 KHz), (N/A, 2000 mBm)
    > >

    > --------------------
    >>>

    >>
    >> The difference is that the first rule allows the usage of of 802.11n
    >> HT
    >> capability with a bandwidth of 40 MHz, but the second says that the
    >> bandwidth is
    >> restricted to 20000 KHz, thus only 802.11g is supported. I do not
    >> understand why
    >> this change triggers this message. I suspect a bug in the MAC layer,
    >> and I plan
    >> to question this in the wireless mailing list.
    >>
    >> To test a possible workaround, do the following:
    >>
    >>>

    > Code:
    > --------------------
    > > >

    > > sudo /sbin/modprobe -rv iwlwifi
    > > sudo /sbin/modprobe -v iwlwifi 11n_disable=1
    > >

    > --------------------
    >>>

    >>
    >> That change will be lost when you reboot. If it fixes the problem, the
    >> following
    >> command will make it permanent:
    >>
    >>>

    > Code:
    > --------------------
    > > >

    > > su -c "echo \"options iwlwifi 11n_disable=1\" > /etc/modprobe.d/50-iwlwifi.conf"
    > >

    > --------------------
    >>>

    >>
    >> That command is a little tricky. Copy and paste it if possible.

    >
    >
    > Thank you for your answer, but now I'm stuck on another problem.
    > I was run your instruction following and was reboot,
    >
    > Code:
    > --------------------
    >
    > su -c "echo \"options iwlwifi 11n_disable=1\" > /etc/modprobe.d/50-iwlwifi.conf"
    >
    > --------------------
    >
    >
    > then these message shown up on dmesg :
    >
    >
    > Code:
    > --------------------
    >
    >
    >
    > [ 908.223178] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    > [ 908.224542] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=18 aid=8672)
    > [ 908.224546] wlp4s0: 00:26:66:1a:e3:b8 denied association (code=18)
    > [ 908.239834] wlp4s0: deauthenticating from 00:26:66:1a:e3:b8 by local choice (reason=3)
    > [ 918.790207] wlp4s0: authenticate with 00:26:66:1a:e3:b8
    > [ 918.818763] wlp4s0: send auth to 00:26:66:1a:e3:b8 (try 1/3)
    > [ 918.877191] wlp4s0: authenticated
    > [ 918.878232] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    > [ 918.880167] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=18 aid=8672)
    > [ 918.880205] wlp4s0: 00:26:66:1a:e3:b8 denied association (code=18)
    > [ 918.893888] wlp4s0: deauthenticating from 00:26:66:1a:e3:b8 by local choice (reason=3)
    > [ 977.075389] wlp4s0: authenticate with 00:26:66:1a:e3:b8
    > [ 977.079037] wlp4s0: send auth to 00:26:66:1a:e3:b8 (try 1/3)
    > [ 977.080175] wlp4s0: authenticated
    > [ 977.080458] wlp4s0: associate with 00:26:66:1a:e3:b8 (try 1/3)
    > [ 977.082376] wlp4s0: RX AssocResp from 00:26:66:1a:e3:b8 (capab=0xc11 status=18 aid=8672)
    > [ 977.082380] wlp4s0: 00:26:66:1a:e3:b8 denied association (code=18)
    > [ 977.088847] wlp4s0: deauthenticating from 00:26:66:1a:e3:b8 by local choice (reason=3)
    >
    > --------------------
    >
    >
    > It seems getting worse. What means "denied association" ?


    Reason 18 is "Multicast cipher is not valid." You have something messed up in
    your WPA secret.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •