Results 1 to 9 of 9

Thread: KDE Desktop boots to a black screen

  1. #1

    Default KDE Desktop boots to a black screen

    Earlier today I installed KDE on my machine that had LXDE running using

    Code:
    zypper install -t pattern kde4 kde4_basis
    And then I proceeded to remove LXDE via terminal. Now When I boot up, it shows the KDE loading screen and then shows a black screen with only a mouse. I rebooted and went into advanced options and it loads in safe mode but its extremely slow.. any help would be great that would avoid reinstalling

    Thanks in advance!

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: KDE Desktop boots to a black screen

    Quote Originally Posted by Zach1928 View Post
    Earlier today I installed KDE on my machine that had LXDE running using

    Code:
    zypper install -t pattern kde4 kde4_basis
    And then I proceeded to remove LXDE via terminal. Now When I boot up, it shows the KDE loading screen and then shows a black screen with only a mouse. I rebooted and went into advanced options and it loads in safe mode but its extremely slow.. any help would be great that would avoid reinstalling

    Thanks in advance!
    Please let us know version of openSUSE, etc.

    This sounds like a graphic driver problem, so also let us know what graphic card you have.

    You probably need to install the correct driver, but we can't guess which one without more information.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  3. #3

    Default Re: KDE Desktop boots to a black screen

    Quote Originally Posted by Fraser_Bell View Post
    Please let us know version of openSUSE, etc.

    This sounds like a graphic driver problem, so also let us know what graphic card you have.

    You probably need to install the correct driver, but we can't guess which one without more information.
    Okay so it's openSUSE 13.1, KDE 4 and the card is a Mobility Radeon X300. And like I said it was working fine before I messed with it so it's definitely something I broke..

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: KDE Desktop boots to a black screen

    At login
    Change the session to lxde
    Is there still a problem?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: KDE Desktop boots to a black screen

    Quote Originally Posted by caf4926 View Post
    At login
    Change the session to lxde
    Is there still a problem?
    It doesn't let me do anything. It loads up normally, and then I guess it is set to auto-login because it shows that square and starts to fade in with the HDD picture, wrench and screw driver, the globe, the desktop image and then the KDE logo and then it comes up black.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: KDE Desktop boots to a black screen

    Either disable auto login (you said you can load safe mode, which would give you access to yast to do this)
    or
    As kde loads to where the screen goes black- try pressing Alt+SHIFT+F12
    This toggles desktop effects off/on
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    84

    Default Re: KDE Desktop boots to a black screen

    Two things I can think of:

    • when KDE is started (so black), try Alt+F2. If you get a prompt type "kwin --replace". Maybe this gives you a GUI
    • if not (and I understood this is your first KDE-install - so you don't have any personal settings): open a terminal (like Alt+Ctrl+F1), login in with your username and type "mv ~/.kde4 ~/.kde4.backup". Log into KDE and see if it's working. if not redo it in the terminal with "rm -R ~/.kde4" and "mv ~/.kde4.backup ~/.kde4"

  8. #8

    Default Re: KDE Desktop boots to a black screen

    Quote Originally Posted by SimonHeimbach View Post
    Two things I can think of:

    • when KDE is started (so black), try Alt+F2. If you get a prompt type "kwin --replace". Maybe this gives you a GUI
    • if not (and I understood this is your first KDE-install - so you don't have any personal settings): open a terminal (like Alt+Ctrl+F1), login in with your username and type "mv ~/.kde4 ~/.kde4.backup". Log into KDE and see if it's working. if not redo it in the terminal with "rm -R ~/.kde4" and "mv ~/.kde4.backup ~/.kde4"
    I couldnt get it to work, I even booted into IceWM and removed and reinstalled KDE through the terminal and nothing was working so I just reinstalled it..

    Thanks for the assistance though!

  9. #9
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    84

    Default Re: KDE Desktop boots to a black screen

    Do you have a running KDE-installation now?
    If so, what did you do? Maybe someone else finds this threat and can benefit from your experiences.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •