Results 1 to 3 of 3

Thread: Nvidia GLX extension loaded but failed to initialize

  1. #1
    Join Date
    Jun 2008
    Location
    Luleå, Sweden
    Posts
    39

    Default Nvidia GLX extension loaded but failed to initialize

    Hi Forum !

    I have an OPTIMUS technology laptop with an NVIDIA / INTEL graphics cars combination. I use bumblebee to switch. So far, switching to the nvidia driver seems to work.
    The problem is that glx-related programs (glxgears, glxinfo) fail to run:
    Code:
    mimis@goldberg:~$ glxinfo
    name of display: :0
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Segmentation fault
    but

    Code:
    mimis@goldberg:~$ optirun glxgears
    3409 frames in 5.0 seconds = 681.616 FPS
    3751 frames in 5.0 seconds = 749.982 FPS
    In my /var/log/Xorg.0.log I found the following (I believe it is related) :

    [CODE][ 80 [ 15.696] (II) "glx" will be loaded by default.
    88 [ 15.704] (II) LoadModule: "glx"
    89 [ 15.704] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    90 [ 15.751] (II) Module glx: vendor="NVIDIA Corporation"
    93 [ 15.751] (II) NVIDIA GLX Module 331.49 Wed Feb 12 20:17:10 PST 2014
    94 [ 15.752] Loading extension GLX
    368 [ 15.794] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    /CODE]

    problems also appear with the dassault/draftsight vector drawing package (I get a "dead" window)

    Any help will be greatly appreciated

    mimis

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Nvidia GLX extension loaded but failed to initialize

    Did you get the NVIDIA driver from the same place as bumblebee? ou can not use the generic NVIDIA driver you most use a patched one

  3. #3
    Join Date
    Jun 2008
    Location
    Luleå, Sweden
    Posts
    39

    Default Re: Nvidia GLX extension loaded but failed to initialize

    Thanks for taking the time to look into this problem of mine.

    The situation is as following:

    Code:
    mimis@goldberg:~$ zypper se -v nvidia | grep ^i
    i | dkms-nvidia                   | package    | 331.49-1.1                 | x86_64 | Overman79-12.3         
    i | dkms-nvidia                   | package    | 331.49-1.1                 | x86_64 | (System Packages)      
    i | nvidia-computeG03             | package    | 331.49-29.1                | x86_64 | nVidia Graphics Drivers
    i | nvidia-computeG03             | package    | 331.49-29.1                | x86_64 | (System Packages)      
    i | nvidia-gfxG03-kmp-desktop     | package    | 331.49_k3.7.10_1.1-29.1    | x86_64 | nVidia Graphics Drivers
    i | nvidia-gfxG03-kmp-desktop     | package    | 331.38_k3.7.10_1.1-23.1    | x86_64 | (System Packages)      
    i | nvidia-gfxG03-kmp-desktop     | package    | 331.49_k3.7.10_1.1-29.1    | x86_64 | (System Packages)      
    i | nvidia-glG03                  | package    | 331.49-29.1                | x86_64 | nVidia Graphics Drivers
    i | nvidia-glG03                  | package    | 331.49-29.1                | x86_64 | (System Packages)      
    i | nvidia-settings               | package    | 325.15-1.3                 | x86_64 | Packman Repository     
    i | nvidia-settings               | package    | 325.15-1.3                 | x86_64 | (System Packages)      
    i | x11-video-nvidia              | package    | 331.49-1.1                 | x86_64 | Overman79-12.3         
    i | x11-video-nvidia              | package    | 331.49-1.1                 | x86_64 | (System Packages)
    Code:
    $ zypper se -v bumblebee | grep ^i
    i | bumblebee              | package    | 3.2.1-17.1 | x86_64 | Overman79-12.3   
    i | bumblebee              | package    | 3.2.1-17.1 | x86_64 | (System Packages)
    Do you think that looks good?

    mimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •