Results 1 to 4 of 4

Thread: kworker take half of the memory

  1. #1

    Default kworker take half of the memory

    From yesterday, kworker took half of the CPU. How can I solve that?
    The problem seems to appear sometimes when I use Musescore, which is not behaving well (strange sounds appear in the background).

  2. #2

    Default Re: kworker take half of the memory

    Quote Originally Posted by Filipe View Post
    From yesterday, kworker took half of the CPU. How can I solve that?
    The problem seems to appear sometimes when I use Musescore, which is not behaving well (strange sounds appear in the background).
    No idea, sorry.

    But kworker is a kernel thing.
    It's not taking CPU time on its own.

    Maybe this would help, but I haven't read it really:
    http://askubuntu.com/questions/33640...ng-so-much-cpu

    If it's only related to Musescore, I would say Musescore has a bug.
    I don't use it myself, so cannot really comment there either.

  3. #3

    Default Re: kworker take half of the memory

    Quote Originally Posted by wolfi323 View Post

    Maybe this would help, but I haven't read it really:
    http://askubuntu.com/questions/33640...ng-so-much-cpu

    If it's only related to Musescore, I would say Musescore has a bug.
    I don't use it myself, so cannot really comment there either.
    Someone said on that link that setting
    Hand XCHI OFF: disabled
    on the bios would help, but I don't see this line on my bios.

    You are right, the problem is in musescore. But how could I turn of (or something like that) kworker without turning off the computer?

  4. #4

    Default Re: kworker take half of the memory

    Quote Originally Posted by Filipe View Post
    Someone said on that link that setting
    Hand XCHI OFF: disabled
    on the bios would help, but I don't see this line on my bios.
    Well, that's a solution for one particular problem. But there are at least a dozen others.
    Just seeing a kworker thread doesn't tell anything about the actual problem, it could be anything.

    You are right, the problem is in musescore. But how could I turn of (or something like that) kworker without turning off the computer?
    You can't.
    A kworker thread is just a thread that does some work on behalf of the kernel.
    So you would have to find out what the thread is actually doing, see here http://unix.stackexchange.com/questi...er/65270#65270 (there's a link to this on the page I linked to).

    If I were to guess, I would say that maybe Musescore needs too much memory and the system is swapping.
    Maybe have a look at the memory usage, with "top" f.e. (press 'M' to sort the processes by memory usage)
    But that's just a guess, no idea if it makes sense...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •