Page 1 of 12 12311 ... LastLast
Results 1 to 10 of 114

Thread: Dolphin adds a txt extension to ini files

  1. #1

    Default Dolphin adds a txt extension to ini files

    Now every time I want to create a new.ini it creates a new.ini.txt
    Creating new.sh works properly, it only happens with some extensions, not all.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Dolphin adds a txt extension to ini files

    As usual, the only thing I seem to be doing on these forums is asking: Which version of opennSUSE? And that should awaken you, so that you volunteerly add that you use KDE (assumption from me, but not nessecarly true) and the if you use the standard version going with that openSUSE version or not. Thus we get at least an idea about the environment and the Dolphin version you are using.

    And it never hurts to explain what you exactly do. Thus not sayjng you "create a file using Dolphin", but that you clicked on ... and then ........ I, e.g., have no idea how one creates files using Dolphin except using "copy" at a file drag from one place to another. And I also have no idea what some applications think that a file with the suffix .ini on it's name means.
    Henk van Velden

  3. #3

    Default Re: Dolphin adds a txt extension to ini files

    On 2014-03-04, finders <finders@no-mx.forums.opensuse.org> wrote:
    > Now every time I want to create a new.ini it creates a new.ini.txt
    > Creating new.sh works properly, it only happens with some extensions,
    > not all.


    What happens in Dolphin if you press F4, type...

    Code:
    touch new.ini
    .... and this press F4 again?

    On 2014-03-04, hcvv <hcvv@no-mx.forums.opensuse.org> wrote:
    > As usual, the only thing I seem to be doing on these forums is asking:
    > Which version of opennSUSE? And that should awaken you, so that you
    > volunteerly add that you use KDE (assumption from me, but not nessecarly
    > true) and the if you use the standard version going with that openSUSE
    > version or not. Thus we get at least an idea about the environment and
    > the Dolphin version you are using.


    Henk is absolutely right. I've openSUSE 13.1_x86_64 (KDE) and cannot reproduce this problem in Dolphin.

    > And it never hurts to explain what you exactly do. Thus not sayjng you
    > "create a file using Dolphin", but that you clicked on ... and then
    > ........ I, e.g., have no idea how one creates files using Dolphin
    > except using "copy" at a file drag from one place to another.


    Within Dolphin, right click, select `Create New' > `Text File', but I'm guessing that's what the OP did.

    > And I also
    > have no idea what some applications think that a file with the suffix
    > .ini on it's name means.


    IIRC some Windows applications use `ini' extensions for configuration text files that initialise settings for some
    applications (a bit like ~/.*rc) but I've never it used in Linux - although I guess there's no reason why it couldn't be
    used.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Dolphin adds a txt extension to ini files

    Quote Originally Posted by flymail View Post
    Within Dolphin, right click, select `Create New' > `Text File', but I'm guessing that's what the OP did.

    I hate guessing what an OP did
    Henk van Velden

  5. #5

    Default Re: Dolphin adds a txt extension to ini files

    Quote Originally Posted by hcvv View Post
    I hate guessing what an OP did
    Dosbox programs use ini configuration files.
    And yes, it happens on openSUSE 13.1 + KDE 4.12 (works properly on SLED 11)
    Sorry about lack of info, I was in a hurry.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,477
    Blog Entries
    2

    Default Re: Dolphin adds a txt extension to ini files

    To the OP:

    Your Q has a logical answer.
    Like practically any other File Manager, it wants to be able to automatically launch a "viewer" any time you click on that type of file.

    When you created a new file, you almost certainly selected "text" which would mean that the File Manager needs to tag the file somehow so that it knows what type of "viewer" app to launch later on. The most common way to do this is to append a file extension which you have discovered.

    To avoid appending a file extension, you shouldn't create the new file using a File Manager (or any Desktop GUI environment which typically will build on the File Manager's functionality).

    Instead, you should create from a console.

    Here are a few ways you can do this from a console.
    "some text" is the contents of your text file to get started. Of course, you can always re-open and edit later even using a GUI text editor as long as you "Save" and don't "Save As."
    "filename" is exactly what you want the file name to be, without any hidden suffixes.

    Echo some text into a new file
    Code:
    echo "some text" > filename
    Use the Vi console editing app pointing to a filename that doesn't already exist
    Code:
    vi filename
    cat some text into a new file
    Code:
    cat >> filename << EOF
    some text
    some more text
    EOF
    HTH,
    TSU

  7. #7

    Default Re: Dolphin adds a txt extension to ini files

    Look, if I run "mcedit new.ini" and save the file in mcedit, it saves as new.ini, not new.ini.txt.
    If I right click in dolphin 1.3, create new text file, and enter name "new.ini" it also saves new.ini without the txt extension.
    In new dolphin from 4.12 it adds txt extension, which I don't need. Then I manually have to remove it, which is annoying.
    Whatever, I give up on KDE 4.12 anyway, if I could downgrade to 4.4 I would do it right now.

  8. #8

    Default Re: Dolphin adds a txt extension to ini files

    On 2014-03-04, finders <finders@no-mx.forums.opensuse.org> wrote:
    > Look, if I run "mcedit new.ini" and save the file in mcedit, it saves as
    > new.ini, not new.ini.txt.


    Look, if you follow the suggestions people offer you, people might be more inclined to help.

    > If I right click in dolphin 1.3, create new text file, and enter name
    > "new.ini" it also saves new.ini without the txt extension.


    This is aimed at Henk: . But of course Henk is right: we shouldn't have to guess.


  9. #9

    Default Re: Dolphin adds a txt extension to ini files

    Quote Originally Posted by flymail View Post
    On 2014-03-04, finders <finders@no-mx.forums.opensuse.org> wrote:
    > Look, if I run "mcedit new.ini" and save the file in mcedit, it saves as
    > new.ini, not new.ini.txt.


    Look, if you follow the suggestions people offer you, people might be more inclined to help.

    > If I right click in dolphin 1.3, create new text file, and enter name
    > "new.ini" it also saves new.ini without the txt extension.


    This is aimed at Henk: . But of course Henk is right: we shouldn't have to guess.
    Quote the part where I was asking for help.
    You just assume it's my fault the app is doing this and suggest I should get some help?
    Last time I mention any bug on this forum, I'll just keep it shut from now on.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Dolphin adds a txt extension to ini files

    On 2014-03-04 11:28, flymail wrote:
    > IIRC some Windows applications use `ini' extensions for configuration text files that initialise settings for some
    > applications (a bit like ~/.*rc) but I've never it used in Linux - although I guess there's no reason why it couldn't be
    > used.


    I just did a "locate .ini" and found 726 instances. This is a full Linux
    machine.

    For instance: "/usr/share/texmf/tex/latex/latexconfig/latex.ini"

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 12 12311 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •