Results 1 to 2 of 2

Thread: CUPS Does Not Start at Boot

  1. #1

    Default CUPS Does Not Start at Boot

    I have a printer over a wireless connection (a HP Photosmart Insert-fancy-descriptors-here 7520). However, after configuring the printer, I realized that CUPS isn't actually running. In order to access the printer, I have to manually start the service with "rccups start" in root, every time I boot.

    I have the service enabled under systemctl, and I've tried out a solution from this older thread, but that's gotten me nowhere. I'm currently on Tumbleweed. Is there any log file I should be looking at?

    Thanks in advance.

  2. #2

    Default Re: CUPS Does Not Start at Boot

    On 03/03/2014 07:46 PM, TheCube42 pecked at the keyboard and wrote:
    > I have a printer over a wireless connection (a HP Photosmart
    > Insert-fancy-descriptors-here 7520). However, after configuring the
    > printer, I realized that CUPS isn't actually running. In order to access
    > the printer, I have to manually start the service with "rccups start" in
    > root, every time I boot.
    >
    > I have the service enabled under systemctl, and I've tried out a
    > solution from 'this older thread' (http://tinyurl.com/odmvtcp), but
    > that's gotten me nowhere. I'm currently on Tumbleweed. Is there any log
    > file I should be looking at?
    >
    > Thanks in advance.
    >
    >


    Do you have the following file with the indicated content?

    Code:
    /etc/systemd/system/cups.socket
    **********************************
    
    [Unit]
    Description=CUPS Printing Service Sockets
    
    [Socket]
    ListenStream=/var/run/cups/cups.sock
    ListenStream=631
    ListenDatagram=0.0.0.0:631
    BindIPv6Only=ipv6-only
    
    [Install]
    WantedBy=sockets.target
    If not create it and make sure the perms and owner are set.

    Code:
    chown root.root /etc/systemd/system/cups.socket
    chmod 0644 /etc/systemd/system/cups.socket
    Then run:

    Code:
    systemctrl enable cups.socket
    
    and
    
    systemctrl start cups.socket
    Ken

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •