Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Kde Login dialogue only on screen that is off; laptop with external monitor

  1. #1

    Question Kde Login dialogue only on screen that is off; laptop with external monitor

    HI Gang,
    I've been using 13.1 for quite some time with few issues on an HP 8510W laptop in a docking station.

    However, I installed some updates today, including the nVidia proprietary drivers from the nVidia repo, and on restarting I had the KDE login screen, but no login dialogue. After some fiddling, I realized that the dialogue was on the primary display, which was inactive since it is in the docking station. I can login by typing my password, so it's not a horrible handicap, provided I don't mistype it. Is there any way to tell KDE to put the login dialogue on all monitors?
    Cheers,

    Rod Schaffter

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Just to add some background.

    It is of course not KDE that is doing this because at login there is no desktop active.

    It is the display manager, of which you use the one provided by the KDE project, named kdm, to give the whole a KDE look and feel.

    In your case, one should thus check if one can "learn" kdm to do this as you want it.
    Henk van Velden

  3. #3

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Some background:
    - DM starts the display server (X)
    - once X starts, the DM's greeter / login screen starts
    - once login is completed, a particular user session is begun on a particular DE

    The problem described:
    - greeter screen is (to use familiar or popular terminology) in extended mode, and the actual login box is only displayed on the primary monitor

    The analysis:
    - by default, all monitors should be displaying the same thing (i.e. cloned) ... meaning you should have a login box on all monitors
    - consequently, its obvious that some X configuration has been applied such that monitors behave as an extended workspace

    Ordinarily that is actually a nice touch, but in your use case, it is actually undesired.

    I do not know if this is the nvidia stack's default behaviour (to designate the laptop's screen as primary), or whether it set up such config in the xorg.conf (if applicable). In any regard, you should be able to correct for this if you poke around ... at the very least, you can prevent the extension on the DM's greeter screen via a xrandr script in the DM ... and then use a xrandr frontend under the DE to restore the desirable settings

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Quote Originally Posted by Tyler_K View Post
    Some background:
    - DM starts the display server (X)
    - once X starts, the DM's greeter / login screen starts
    - once login is completed, a particular user session is begun on a particular DE

    The problem described:
    - greeter screen is (to use familiar or popular terminology) in extended mode, and the actual login box is only displayed on the primary monitor

    The analysis:
    - by default, all monitors should be displaying the same thing (i.e. cloned) ... meaning you should have a login box on all monitors
    - consequently, its obvious that some X configuration has been applied such that monitors behave as an extended workspace

    Ordinarily that is actually a nice touch, but in your use case, it is actually undesired.

    I do not know if this is the nvidia stack's default behaviour (to designate the laptop's screen as primary), or whether it set up such config in the xorg.conf (if applicable). In any regard, you should be able to correct for this if you poke around ... at the very least, you can prevent the extension on the DM's greeter screen via a xrandr script in the DM ... and then use a xrandr frontend under the DE to restore the desirable settings
    I believe it is the default of the nVidia system, it seems to default to the extended screen spread across the two monitors.

    You will need to pan side-to-side to get to things.

    From the menu, go to System => Configuration => Configure NVIDIA X Server Settings.

    With luck, the configuration panel will pop up on your current screen, or partly on the screen. If it is partly on the screen, drag it to where you can see it.

    I am in the process of moving, so my secondary display is disconnected. As such, it is not detected, and I don't get the dialogue in the panel, so I am going to have to go by (foggy) memory.

    I think in X Server Display Configuration, one of the boxes has a drop-down (you might have to click on the Advanced button there, first) where you can choose between various choices, one of which is "Clones" or similar. Choose that, apply, and you should then have cloned displays instead of side-by-side displays.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Quote Originally Posted by Fraser_Bell View Post
    I believe it is the default of the nVidia system, it seems to default to the extended screen spread across the two monitors.

    You will need to pan side-to-side to get to things.

    From the menu, go to System => Configuration => Configure NVIDIA X Server Settings.

    With luck, the configuration panel will pop up on your current screen, or partly on the screen. If it is partly on the screen, drag it to where you can see it.

    I am in the process of moving, so my secondary display is disconnected. As such, it is not detected, and I don't get the dialogue in the panel, so I am going to have to go by (foggy) memory.

    I think in X Server Display Configuration, one of the boxes has a drop-down (you might have to click on the Advanced button there, first) where you can choose between various choices, one of which is "Clones" or similar. Choose that, apply, and you should then have cloned displays instead of side-by-side displays.
    Or, alternately:

    From the menu, Configure Desktop => Display and Monitor (under the Hardware section)

    On the left, choose Size & Orientation.

    You want both monitors set to Position: Absolute 0 0
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  6. #6

    Post Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Thanx for the feedback. The login prompt was appearing on the external monitor prior to the update.

    The displays are cloned, and in nVidia X Server Settings the external monitor is set as the primary display, position is Absolute +0 +0, and the laptop screen is off.

    I get the login prompt when I suspend to RAM, but that of course is handled my KDE and not kdm...
    Cheers,

    Rod Schaffter

  7. #7

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    One more data point; xrandr shows the laptop display as connected, even though it remains off when I open the lid ...

    Code:
    :~> /usr/bin/xrandr --current 
    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 8192 x 8192
    VGA-0 disconnected (normal left inverted right x axis y axis)
    TV-0 disconnected (normal left inverted right x axis y axis)
    LVDS-0 connected (normal left inverted right x axis y axis)
       1920x1200      60.0 +
    DVI-I-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
       1920x1080      60.0*+   59.9     50.0     60.1     60.0     50.0  
       1680x1050      60.0  
       1600x1200      60.0  
       1440x900       59.9  
       1280x1024      75.0     60.0  
       1280x720       60.0     59.9     50.0  
       1024x768       75.0     60.0  
       800x600        75.0     60.3  
       720x576        50.0     50.1  
       720x480        59.9     60.1  
       640x480        75.0     59.9     59.9  
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    Cheers,

    Rod Schaffter

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Quote Originally Posted by rschaffter View Post
    One more data point; xrandr shows the laptop display as connected, even though it remains off when I open the lid ...
    Yes, which is why it is giving you the 2 desktops. In my case, I could not give precise information to you because the other monitor is unplugged and packed away, so nVidia now sees it and configures it as a single monitor unit. When it is plugged in, even when turned off, the second monitor is detected.

    Your laptop display is still connected, even though it is off, and is therefore detected, even though it is detected as "disconnected", so the double-monitor interface is active.



    Even though

    The displays are cloned, and in nVidia X Server Settings the external monitor is set as the primary display, position is Absolute +0 +0, and the laptop screen is off.


    If you are still having the problem (I'm unclear on that, now), then just change one or more of those settings away, then back again, then apply, and see if that fixes it.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  9. #9

    Talking Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    Quote Originally Posted by Fraser_Bell View Post
    Y
    [/COLOR]If you are still having the problem (I'm unclear on that, now), then just change one or more of those settings away, then back again, then apply, and see if that fixes it.
    I realized that nvida-settings saves its settings in each user's Home directory (even Root's), so it's not system wide. I used it to generate 20-nvidia.conf and placed it in/etc/X11/xorg.conf.d/

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 331.49  (buildmeister@swio-display-x64-rhel04-14)  Wed Feb 12 21:05:09 PST 2014
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from data in "/etc/sysconfig/mouse"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "IMPS/2"
        Option         "Device" "/dev/input/mice"
        Option         "Emulate3Buttons" "yes"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Seiko/Epson"
        HorizSync       30.0 - 75.0
        VertRefresh     60.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "Quadro FX 570M"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-1"
        Option         "metamodes" "LVDS-0: nvidia-auto-select +0+0, DVI-I-0: nvidia-auto-select +0+0"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    It now works as expected, after setting it to force 96DPI in KDE Config display settings.

    Many Thanx to All for the insights...
    Cheers,

    Rod Schaffter

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Kde Login dialogue only on screen that is off; laptop with external monitor

    If you run nvida-settings as root it should crerate/change the /etc/X11/xorg.conf file

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •