Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Yast software management doesn't launch

  1. #1

    Post Yast software management doesn't launch

    Hi,

    i have a problem with Yast , the control center launch corectly, but the yast software management won't start and i get the following message in my terminal:
    Code:
    Run command: /sbin/yast2 sw_single &
    terminate called after throwing an instance of 'YUIPluginException'
       what(): counldn't load plug-in qt
    YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:1885
    /sbin/yast2: line 375:   6818 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    i have no idea why this happens and my research didn't helped.
    i don't if i can reinstall Yast or something.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: Yast software management doesn't launch

    Which version of openSUSE please!
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,483
    Blog Entries
    2

    Default Re: Yast software management doesn't launch

    Why are you running in a terminal?

    - YAST2 is the gui version which requires running in a Desktop (or Window Manager). If you have a Desktop installed, then it's probably easier to launch from your Application Launcer/Main Menu.

    - If you don't have a Desktop installed, eg you're running in a command line only environment, then you shouldn't be launching yast2, you should be launching yast which is the ncurses (text only) version. And, of course root permissions are required.

    HTH,
    TSU

  4. #4
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Yast software management doesn't launch

    On 3/3/2014 5:56 PM, tsu2 wrote:
    > - If you don't have a Desktop installed, eg you're running in a command
    > line only environment, then you shouldn't be launching yast2, you should
    > be launching yast which is the ncurses (text only) version


    Actually, yast is a link to yast2; as are YaST, YaST, zast, ZaST, ZaST2 and zast2 also links to yast2. See the
    contents of /sbin.

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  5. #5

    Default AW: Yast software management doesn't launch

    Quote Originally Posted by clemband View Post
    Hi,

    i have a problem with Yast , the control center launch corectly, but the yast software management won't start and i get the following message in my terminal:
    Code:
    Run command: /sbin/yast2 sw_single &
    terminate called after throwing an instance of 'YUIPluginException'
       what(): counldn't load plug-in qt
    YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:1885
    /sbin/yast2: line 375:   6818 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    i have no idea why this happens and my research didn't helped.
    i don't if i can reinstall Yast or something.
    Apparently you're missing the appropriate libyui-qt-pkg version. Maybe you have added the Factory repo and have a mixture between 13.1 (or whatever version you installed) and Factory?
    Please post the output of:
    Code:
    zypper lr -d
    rpm -qa | egrep "(yast|libyui)"

  6. #6

    Default Re: Yast software management doesn't launch

    Quote Originally Posted by hcvv View Post
    Which version of openSUSE please!
    I'm on opensuse 12.3.
    Quote Originally Posted by tsu2 View Post
    Why are you running in a terminal?

    - YAST2 is the gui version which requires running in a Desktop (or Window Manager). If you have a Desktop installed, then it's probably easier to launch from your Application Launcer/Main Menu.

    - If you don't have a Desktop installed, eg you're running in a command line only environment, then you shouldn't be launching yast2, you should be launching yast which is the ncurses (text only) version. And, of course root permissions are required.

    HTH,
    TSU
    I launch the gui from the terminal, it's exactly the same as if i run it from my desktop, the error is the same, except i have my error message in my console.
    + i can't launch only yast, Yast2 launch automatically.

    Quote Originally Posted by wolfi323 View Post
    Apparently you're missing the appropriate libyui-qt-pkg version. Maybe you have added the Factory repo and have a mixture between 13.1 (or whatever version you installed) and Factory?
    Please post the output of:
    Code:
    zypper lr -d
    rpm -qa | egrep "(yast|libyui)"

    Code:
      zypper lr -d
    # | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
    --+----------------------------------+----------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
    1 | Bocal                            | Bocal                            | Yes     | Yes     |   99     | rpm-md | http://repo.epitech.eu/opensuse/std                                      |        
    2 | SuSE                             | SuSE                             | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/pub/SuSE/Tumbleweed/                        |        
    3 | Tumbleweed                       | Tumbleweed                       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |        
    4 | google-chrome                    | google-chrome                    | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                      |        
    5 | openSUSE Current OSS             | openSUSE Current OSS             | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |        
    6 | openSUSE Current OSS updates     | openSUSE Current OSS updates     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-current/                    |        
    7 | openSUSE Current non-OSS         | openSUSE Current non-OSS         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |        
    8 | openSUSE Current non-OSS updates | openSUSE Current non-OSS updates | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-non-oss-current/            |
    Code:
    rpm -qa | egrep "(yast|libyui)"
    libyui4-2.42.6-1.1.1.x86_64
    libyui5-3.0.10-2.1.4.x86_64
    libyui-ncurses4-2.43.3.1-1.5.1.x86_64
    libyui-gtk-pkg5-2.42.9-2.1.5.x86_64
    libreoffice-icon-theme-hicontrast-3.6.3.2.4-2.4.1.noarch
    libyui-qt4-2.42.5-1.1.1.x86_64
    libyui-gtk5-2.43.7-2.1.4.x86_64
    libyui-gtk4-2.42.3-1.1.1.x86_64

  7. #7

    Default Re: Yast software management doesn't launch

    Quote Originally Posted by clemband View Post
    I'm on opensuse 12.3.
    No, you're not. According to your repo list, you're on Tumbleweed which is based on 13.1.

    Code:
    rpm -qa | egrep "(yast|libyui)"
    libyui4-2.42.6-1.1.1.x86_64
    libyui5-3.0.10-2.1.4.x86_64
    libyui-ncurses4-2.43.3.1-1.5.1.x86_64
    libyui-gtk-pkg5-2.42.9-2.1.5.x86_64
    libreoffice-icon-theme-hicontrast-3.6.3.2.4-2.4.1.noarch
    libyui-qt4-2.42.5-1.1.1.x86_64
    libyui-gtk5-2.43.7-2.1.4.x86_64
    libyui-gtk4-2.42.3-1.1.1.x86_64
    As expected you miss libyui-qt5 and libyui-qt-pkg5.
    But OTOH you have libyui-gtk5 and libyui-gtk-pkg5 installed, so the Gtk version of YaST should work:
    Code:
    yast2 --gtk
    Why it is trying to start the Qt version by default I don't know, what Desktop Environment are you using?

    If you do want to use the Qt version, install libyui-qt5 and libyui-qt-pkg5.

    And please uninstall the packages libyui4, libyui-qt4, libyui-gtk4, and libyui-ncurses4. They are a left-over from 12.3 and are not used anymore.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast software management doesn't launch

    On 2014-03-06 10:46, clemband wrote:
    >
    > hcvv;2628330 Wrote:
    >> Which version of openSUSE please!

    >
    > I'm on opensuse 12.3.


    No, you are not.

    Code:
    
    > Code:
    > --------------------
    >       zypper lr -d
    >   # | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
    >   --+----------------------------------+----------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
    >   1 | Bocal                            | Bocal                            | Yes     | Yes     |   99     | rpm-md | http://repo.epitech.eu/opensuse/std                                      |
    >   2 | SuSE                             | SuSE                             | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/pub/SuSE/Tumbleweed/                        |
    >   3 | Tumbleweed                       | Tumbleweed                       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |
    >   4 | google-chrome                    | google-chrome                    | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                      |
    >   5 | openSUSE Current OSS             | openSUSE Current OSS             | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |
    >   6 | openSUSE Current OSS updates     | openSUSE Current OSS updates     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-current/                    |
    >   7 | openSUSE Current non-OSS         | openSUSE Current non-OSS         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |
    >   8 | openSUSE Current non-OSS updates | openSUSE Current non-OSS updates | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-non-oss-current/            |
    > --------------------
    You are on Tumbleweed, which at the moment is like 13.1+, on the way to
    13.2.

    As you probably are not using "zypper dup", as mandatory for Tumbleweed,
    you still have packages from 12.3, and the mixture breaks. Thus your
    problem.

    Notice that there is a specific subforum for Tumbleweed.

    More info: Tumbleweed

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  9. #9

    Default Re: Yast software management doesn't launch

    Quote Originally Posted by robin_listas View Post
    On 2014-03-06 10:46, clemband wrote:
    >
    > hcvv;2628330 Wrote:
    >> Which version of openSUSE please!

    >
    > I'm on opensuse 12.3.



    You are on Tumbleweed, which at the moment is like 13.1+, on the way to
    13.2.

    As you probably are not using "zypper dup", as mandatory for Tumbleweed,
    you still have packages from 12.3, and the mixture breaks. Thus your
    problem.
    well if i do a cat /etc/SuSE-release i still have 12.3.
    Code:
     
       openSUSE 12.3 (x86_64)
       VERSION = 12.3
       CODENAME = Dartmouth
    So i don't really know, it seem my school give us a custom Opensuse, and i don't really want to modify it to much;

    However, the gtk version seem to work fine, thank you all !

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast software management doesn't launch

    On 2014-03-08 13:06, clemband wrote:

    > well if i do a cat /etc/SuSE-release i still have 12.3.


    Yes, that can happen.


    > So i don't really know, it seem my school give us a custom Opensuse, and
    > i don't really want to modify it to much;


    Who activated the repos you have, them or you?

    The problematic ones are those with "Tumbleweed" in the URL, and those
    with "current" in the URL. Ie, all of them, but one for which I have no
    data (host repo.epitech.eu doesn't solve). Ok, the chrome repo is ok.

    The "current" named repos are in fact pointers or symlinks to the the
    current release, which at the moment is 13.1.

    Check for yourself, your "oss" repo is this:

    http://download.opensuse.org/distrib...rent/repo/oss/

    Go ahead, click on it. You will see a list of files. Open, for example,
    the "content" file (it is plain text). Read the header carefully:

    Code:
    VENDOR        openSUSE
    VERSION       13.1
    RELEASE       1.10

    So, that's problem number one.

    Problem number two, you also have the main Tumbleweed repository, which
    is a factory version derivative.


    The result then is that you have a mixture of packages from 12.3, 13.1,
    and tumbleweed.

    It is not even pure Tumbleweed, because as you are not aware that your
    repos are setup for Tumbleweed, you have thus not read nor followed the
    instructions for having a proper Tumbleweed install. Basically, that you
    have to forget yast and zypper patch or zypper up, and instead use
    "zypper dup" all the time.

    And this is a dangerous route if you don't know what you are doing, IMO.


    So, who created those repository definitions, your school, or you?

    If it was your school, then, IMNSHO, the person that did the setup is
    daft. And you have to tell them of the problem they created.

    If it was you, then you are excused because you are in a learning
    process. Just undo... no, ask us again for a plan of attack.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •