Results 1 to 2 of 2

Thread: HDMI signal goes away upon log in to KDE

  1. #1
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default HDMI signal goes away upon log in to KDE

    Hello I am using opensuse 13.1 KDE 4.11. On 12.3 I would sometimes
    connect to my flatscreen tv as an alternate monitor while using my
    laptop. It doesn't seem to work as well in 13.1. Here is what I did.

    When I boot up, and I have the HDMI cable plugged in, I see the opensuse
    boot parameters on both my laptop screen and the flatscreen. When it
    gets to the kwin screen where I enter a password to login to KDE, the
    login screen shows on both my laptop screen and my flatscreen. After I
    enter my password to login, when it starts initializing KDE, the HDMI
    cable loses signal and the flatscreen says "no signal"; meanwhile I
    function fine on only my laptop screen.

    If I do the same thing except boot up without the cable plugged in, I
    still get "no signal." In both cases, when I log out of KDE and get back
    to the kwin login screen, the HDMI signal returns, and I see the kwin
    login screen on both my laptop screen and on my flatscreen simultaneously.

    I decided to try an experiment. I logged out of KDE, and then in a
    terminal I renamed the ~/.kde4 directory so that KDE would create a new
    one with all the default settings. I didn't delete it because I have a
    ton of KDE settings that I don't want to lose, so I just wanted to try
    and completely new setup.

    Well, it worked. When I booted into KDE from kwin with a completely
    default configuration, the HDMI signal remained, and I had no problem
    while in KDE having my flatscreen as an alternate monitor to the right
    of my normal laptop screen.

    So the problem is clearly somewhere in my KDE settings, but there are a
    ton of those and I don't know where to start looking. Any ideas?
    --
    G.O.
    Box #1: 13.1 | KDE 4.11 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 13.1 | KDE 4.11 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.11 | Core i7-2620M | 64 | 8GB

  2. #2

    Default Re: HDMI signal goes away upon log in to KDE

    As an FYI: everywhere you have written kwin, replace it with "KDM" ... see here: https://forums.opensuse.org/showthre...70#post2628470

    Quote Originally Posted by golson765 View Post
    So the problem is clearly somewhere in my KDE settings, but there are a
    ton of those and I don't know where to start looking. Any ideas?
    yes, you're correct ... as for where to look, try kscreen : system settings > hardware > Display and Monitor > and then under the display configuration make sure the hdmi monitor is check marked

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •