Results 1 to 4 of 4

Thread: NVIDIA driver problem

  1. #1

    Default NVIDIA driver problem

    I am tired of searching for a solution to this so I thought I would post the question.

    Recently, I did a new install of opensuse and I can't get the proprietary NVIDIA drivers to work, while NOUVEAU drivers work fine. Basically I install the NVIDIA drivers and uninstall Nouveau. And it will work fine at first even after the first reboot. But after a second reboot, the GUI won't load and it just goes to the command line. I get the following error at the top "deprecated config file /etc/modprobe.conf" and I found that this file doesn't exist. In order to get the GUI to come back up I have to reinstall nouveau and uninstall the proprietary NVIDIA. I never had this problem in the past until recently on this machine. I am running opensuse 13.1 with all of the most recent updates from the default repositories on a Alienware computer. I don't know what other specs are relevant here since the drivers used to work fine in the past. By the way, I am install the NVIDIA drivers off of the main NVIDIA repository.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: NVIDIA driver problem

    How did you do the install??

    Are you sure you got the right GOX version for your card. and also the right file for your kernel.

  3. #3

    Default Re: NVIDIA driver problem

    Quote Originally Posted by gogalthorp View Post
    How did you do the install??

    Are you sure you got the right GOX version for your card. and also the right file for your kernel.
    I added the nvidia repository and then I installed using Yast2.

  4. #4

    Default Re: NVIDIA driver problem

    Quote Originally Posted by system1834 View Post
    I added the nvidia repository and then I installed using Yast2.
    So you uninstalled it again?

    Then we cannot diagnose now what went wrong.

    Please install it again, supposing you have a recent card, you would need those packages: (select them manually, if you uninstalled the driver, YaST may pick the wrong ones)
    nvidia-gfxG03-kmp-desktop, x11-video-nvidiaG03, nvidia-glG03, nvidia-computeG03

    If it still doesn't work, please post which graphics card you have, and the following:

    Please post the output of:
    Code:
    rpm -qa | egrep "(kernel|nvidia)"
    uname -a
    Regarding the error message "deprecated config file /etc/modprobe.conf", are you sure the file doesn't exist? (it shouldn't, but where does this error message come from then?)
    Please post also the output of this, preferrably after you got that error message:
    Code:
    ls -la /etc/modprobe*
    Btw, you shouldn't uninstall nouveau.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •