Hello. I using Dvorak's keyboard layout on OpenSUSE 13.1. In generic us-dvorak keymap I found one very unusable feature: every hotkeys placed in unfamilliar positions. And it isn't comfortable and I confused that developers doesn'c care about it. So I found this topic. I did everything like than but with one diffrence: I didn't change /etc/X11/xorg.conf. Instead that I change my /etc/X11/xorg.conf.d/90-keytable.conf:
Code:
Section "InputClass"
        Identifier "LocalKeyboard"
        MatchIsKeyboard "on"
        Option  "XkbLayout"     "us"
        Option  "XkbVariant"    "dvorakqwerty"
EndSection
When I restart my computer I was able to activate my new layout with command:
Code:
setxkbmap us -variant dvorakqwerty
My GUI is Gnome. And Gnome using i-bus to provide layout control. So I edited /usr/share/ibus/component/simple.xml and added this section:
Code:
        <engine>
            <name>xkb:us:dvorakqwerty</name>
            <language>eng</language>
            <license>GPL</license>
            <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
            <layout>us</layout>
            <layout_variant>dvorakqwerty</layout_variant>
            <longname>English (Dvorakqwerty)</longname>
            <description>English (Dvorakqwerty)</description>
                        <icon>ibus-keyboard</icon>
            <rank>99</rank>
        </engine>
When I reboot my computer I found that now i-bus know about my new layout. So when I launch 'ibus-setup' I can found my layout in 'Input Method' tab. I also can set layout with command:
Code:
ibus engine xkb:us:dvorakqwerty
But I still can't change layout in 'Region and Language' settings. It just not exist. How to fix this?

I also have problem with layout that I want to use. When I choosing that I can't use middle mouse key for copy/paste and can't use ctrl+shift+c(j in dvorak) when trying copy/paste from terminal. How to fix that too?