Results 1 to 5 of 5

Thread: Epson printer will not align colours with OpenSuse 13.1

  1. #1
    Join Date
    Dec 2012
    Location
    Minneapolis
    Posts
    38

    Default Epson printer will not align colours with OpenSuse 13.1

    I just read a very similar thread on this subject with OpenSuse 12. The problem was resolved by switching to the proprietary Epson drivers. I've installed every driver that I could find for my Epson NX420, and I can't be sure which drivers I'm actually using anymore. I've installed Gutenprint with Yast, and I've downloaded a number of rpms from the Epson website and installed with zypper. The key rpm, I believe, is epson-inkjet-printer-nx420-1.0.0-1lsb3.2.i486.rpm.

    I have accessed the Cups interface, or whatever you call it, a number of times, edited my printer, and manually selected the ppd file. Here is the one that I have selected.
    Code:
    adam@linux-gb27:/etc/cups/ppd> ls /etc/cups/ppd/Epson_Stylus_NX420.ppd 
    /etc/cups/ppd/Epson_Stylus_NX420.ppd
    It didn't fix anything. Even after a reboot.

    There's a boat load of ppd and ppd.gz files in here
    Code:
    adam@linux-gb27:/usr/share/cups/model> ls
    epson-inkjet-printer-escpr  manufacturer-PPDs  Postscript-level1.ppd.gz  Postscript.ppd.gz  pxlmono.ppd
    gutenprint                  OpenPrintingPPDs   Postscript-level2.ppd.gz  pxlcolor.ppd
    How do I know that I am using the right drivers? How do I get the colors on my printer to line up?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson printer will not align colours with OpenSuse 13.1

    Quote Originally Posted by treeup View Post
    I just read a very similar thread on this subject with OpenSuse 12. The problem was resolved by switching to the proprietary Epson drivers.
    Yes, I think I recall a similar thread whereby the open-source drivers caused an issue as you've described, and the answer was to use the Epson drivers.

    How do I know that I am using the right drivers? How do I get the colors on my printer to line up?
    To check which driver is use, have a look at the printer configuration file /etc/cups/printers.conf

    The printer configuration will start with '<DefaultPrinter....>', or '<Printer....>'. The printer name will correspond the name of a .ppd file in the /etc/cups/ppd/ directory.

    For example, I have 2 two printers defined like this
    Code:
    # lpstat -v
    device for Brother_DCP-7055: usb://Brother/DCP-7055
    device for Brother_HL-2150N: socket://192.168.90.13
    and 2 corresponding ppd files
    Code:
    # ls -l /etc/cups/ppd/
    total 56
    -rw-r--r-- 1 root root 10144 Dec 15 14:49 Brother_DCP-7055.ppd
    -rw-r--r-- 1 root root 10272 Dec 16 15:14 Brother_HL-2150N.ppd
    Last edited by deano_ferrari; 01-Mar-2014 at 19:02.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson printer will not align colours with OpenSuse 13.1

    You may already know this, but I note that one peculiarity with the proprietary Epson drivers is that they are installed by default in the '/opt/epson-inkjet-printer-nx420/ppds/Epson/' directory. Did you navigate to that location when configuring the printer?

  4. #4
    Join Date
    Dec 2012
    Location
    Minneapolis
    Posts
    38

    Default Re: Epson printer will not align colours with OpenSuse 13.1

    The problem was the open source driver. Here is the printer.conf file.

    Code:
    adam@linux-gb27:/usr/share/cups/model> sudo cat /etc/cups/printers.conf
    root's password:
    # Printer configuration file for CUPS v1.5.4
    # Written by cupsd on 2014-03-01 06:58
    # DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
    <Printer Epson_Stylus_NX420>
    UUID urn:uuid:c5ea58c7-434e-3429-497e-0566232cdc85
    Info Epson Stylus NX420 with driver Epson Stylus NX420 - CUPS+Gutenprint v5.2.9
    MakeModel Epson Stylus NX420 - CUPS+Gutenprint v5.2.9
    DeviceURI usb://EPSON/Stylus%20NX420
    State Stopped
    StateMessage Unplugged or turned off
    StateTime 1393678682
    Reason paused
    Type 8425484
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    I went into Yast and selected configure printers in there. It listed a number of drivers in there. I switched from the Gutenprint driver to the Seiko-Epson one. Here is the printer.conf file again.
    Code:
    adam@linux-gb27:/usr/share/cups/model> sudo cat /etc/cups/printers.conf
    # Printer configuration file for CUPS v1.5.4
    # Written by cupsd on 2014-03-01 20:26
    # DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
    <Printer Epson_Stylus_NX420>
    UUID urn:uuid:c5ea58c7-434e-3429-497e-0566232cdc85
    Info Epson Stylus NX420 with driver Epson Stylus NX420 Series - epson-inkjet-printer 1.0.0-1lsb3.2 (Seiko Epson Corporation LSB 3.2)
    MakeModel Epson Stylus NX420 Series - epson-inkjet-printer 1.0.0-1lsb3.2 (Seiko Epson Corporation LSB 3.2)
    DeviceURI usb://EPSON/Stylus%20NX420
    State Idle
    StateTime 1393727183
    Type 8433676
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    Works great now!

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson printer will not align colours with OpenSuse 13.1

    Yes, as I suspected. You'll find that even though the printer name is the same as before (Epson_Stylus_NX420), the ppd in /etc/cups/ppd (of the same same) is now 'Epson-Stylus_NX420_Series-epson-driver.ppd' renamed to match the desired printer name.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •